Windows 8 and 8.1 Forums


Suddenly MS Expression Web 4 doesn't work (Win 7 too)

  1. #1

    Suddenly MS Expression Web 4 doesn't work (Win 7 too)


    Yesterday (March 1) Microsoft Expression Web 4 stopped working. It crashes immediately after the original splash window opens. This happens using the free EW4 version and it happens using the "WebStudio_Trial" only if you apply SP2. When it happened on my Win 8 triple boot partition I went back to my Win 7 partition with the same result. Its interesting that the latest versions of EW4 work well in my Win 10 partition and Virtual Box Win 10 running in Win 8.

    Therefore my assumption is that a recent Win 8 (and Win 7) update has caused this problem. Since EW4 is only on "long term" support MS may not be very interested in this problem. I find EW4 is an excellent free super code editor for website development and would hate to have to find an alternative. I found this page with suggested fixes but they didn't work Causes for Expression Web Crashing - Ruminations from the Expression Web support team - Site Home - MSDN Blogs

    My work-around is to use the WebStudio trial version of EW4 without SP2. Any suggestions would be appreciated.

      My System SpecsSystem Spec

  2. #2


    Forever West
    Posts : 591
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1


    I just checked mine on Win7 and didn't see a problem. I haven't put it on Win8.1 yet. I would wonder if the Folder it opens in has been changed, moved or deleted. Mine is C:\Users\Berton\Documents\My Web Sites\MyDomain.com\WWW\
      My System SpecsSystem Spec

  3. #3


    EW4 without SP2 works fine as does EW3. Removing the whole folder with all the websites makes no difference. Both those versions open fine and one could browse for the moved folder or start a new one. However, having removed the folder will all the web sites EW4 with SP2 still crashes on startup so the problem is something more major. I expect the only "fix" is to refresh the whole installation which is a real pain.
      My System SpecsSystem Spec

  4. #4


    Forever West
    Posts : 591
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1


    I didn't show any SP on my Expression Web 4 so went looking, turns out I have version 4.0.1460.0 and all I found for SP2 was it should be version 4.0.1303.0 SP2. Apparently mine is a newer version, probably when MS went to the free version. I did find that SuperPreview on mine has a problem.
      My System SpecsSystem Spec

  5. #5


    Problem Solved! But this is very strange. Some of the features of the "trial" version without SP2 stopped working so once again I tried uninstalling and reinstalling that version and that didn't help. So I tried installing the free version again and same problem. I was looking at all the files in the Program Files folder and decided to run the .exe As Administrator. Wow it worked. It also starts properly from the desktop icon. I have no idea why that fixed the problem but I' smiling
      My System SpecsSystem Spec

Suddenly MS Expression Web 4 doesn't work (Win 7 too)
Related Threads
My fully updated Windows 8.1 notebook suddenly will not show any wifi connections when I click on the icon in the system tray (it shows "No Connections are Available", although it is connected, and I can surf and browse normally). To connect to a new network, I have to manually enter the...
Solved My product key doesn't work in Installation & Setup
Hi! I've bought Windows 8 when it was first released, but reinstalled Windows 7 again. Now I want to install Windows 8.1, but I get an error saying my product key is invalid. I've tried multiple product keys (We own multiple computers, two of which have Win8 installed), but I get the same error...
I have Starwars: Empire at War Goldpack, but half of it isn't working properly. I can play the orignal SW:EAW but not it's exspansion Starwars: Empire at War: Forces of corruption. I have no clue why one works and the other doesn't.
GPU Sometimes Doesn't Work in Graphic Cards
Hey all, Not sure where to post this so thought I would try here. Ever since I've put together my new PC I have had an issue with my wireless card. Sometimes when I start up my PC the driver doesn't load for it, I can see it in the device manager list but the driver hasn't loaded and when I...
Solved My Windows Key doesn't work in General Support
I had been using the Windows key to switch back and forth from Metro to desktop. When I am in Metro, pressing it does nothing, but it works everywhere else. I simply click on the desktop icon, so it's no big deal, but is there a solution?
WIN + Tab doesn't work but ALT + Tab does Has anyone else observed this?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook