Windows 8 and 8.1 Forums

Metro apps fail when device joined to the domain

  1. #1

    Posts : 5
    Win 8.1

    Metro apps fail when device joined to the domain

    Hello and Help

    First off if this is a repeated thread sorry and please redirect me however I have searched and not found my exact problem.

    I work for a medium sized organisation with Win 7 as our corporate standard. We have started to hand Out Dell Venue Pro 11 devices with 8.1 for trial.

    The Problem that I am getting is as soon as I join these to the domain the next person to log on to the Tablet gets the Metro apps Black x and no store access.

    I can resolve this by doing these first 3 steps

    Firstly delete the localprofile.
    The following finallyfixed all issues for me (Store and all apps broken with black X, can'taccess PC Settings):
    1) Fixing the app store:
    1. Open registryeditor typing regedit.exe from a command line.
    2. Browse to the registry key atHKEY_CURRENT_USER\Software\Classes\LocalSettings\software\microsoft\windows\currentversion\appmode l\repository\packages.
    3. Right click on the “packages” key and bring up the “Permissions”tab.
    4. Click the “Advanced” button located at the bottom right corner.
    5. Check to see the account name that shows up as the “Owner” (thisis the first line of text on the “advanced security settings” dialog for the“packages” key). It should say “SYSTEM”. (For me this showed the built-inlocal Administrators group)
    6. If it is any other account, click on the “Change” button next toit.
    7. Type SYSTEM in the “select user” dialog. If “Multiple NamesFound” window comes up, select the row for “SYSTEM”.
    8. Click OK to the dialogs and close them all.
    9. Run from admin command prompt: Powershell -ExecutionPolicy Unrestricted Add-AppxPackage-DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    2) Fixing all modern apps:
    Run from admin PowerShell:
    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications")| Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode
    * When Iran this the black X persisted until after the next step and reboot. Buttrying to start an app gives me a new message and a link to the store.

    However I need to be able to hand these out to several hundred people and do not want to be performing this fix for every new user logging on to a shared tablet.

    Do we have GPO's causing this?
    Is it a known issue that I cant find?

    Any help would be great and again if there is info already out there please direct me as I cannot believe this is normal.

    Thanks in advance


      My System SpecsSystem Spec

  2. #2

    Welcome to Windows EightForums, coxo2609.

    Never worked IT so not the savviest here. Can this be performed through Group Policy some how?

    Group Policy API (Windows)
      My System SpecsSystem Spec

  3. #3

    Posts : 5
    Win 8.1

    Thanks for the reply however I am looking for explanations/solutions now as speculated enough on this. I am hoping someone has an explanation of what is causing the out of the box failures.

      My System SpecsSystem Spec

  4. #4

    Sorry I can't be of more help. Does the OEM offer any help? In the mean time I'll contact a few pros here to look in.
      My System SpecsSystem Spec

  5. #5

    Posts : 5
    Win 8.1

    Thanks all assistance gratefully received.
      My System SpecsSystem Spec

  6. #6

    You're quite welcome.

    I left messages with a few pros here. I'm sure someone will answer, but it is rather early. Someone else may peak in too. Hang in there.

    LOL! Of course you know Group Policy. I just looked up GPO > Group Policy Object.
      My System SpecsSystem Spec

  7. #7

    It's easy to test if it's a GPO. Create a user and put the computer into a container in AD that does't get any GPO's and see if the problem persists.

    What you are seeing I've never had to do on any of our Windows 8.1 devices on our corporate network.
      My System SpecsSystem Spec

  8. #8

    Thanks for answering, Patrick.
      My System SpecsSystem Spec

  9. #9

    Posts : 5
    Win 8.1

    Thanks again for the replies. I have isolated the device using block inheritance. My concern is that it may receive it from the default domain policy which I cannot block as when you join the device to the domain it auto gets placed in to that OU.

    We have very few options set in the default domain other than security settings etc.

    Good to hear that you do not have to do anything as that means there is something our side that is causing this.

    Thanks Oli
      My System SpecsSystem Spec

  10. #10

    Hi, Oli. Curious as to whether you came to a conclusion with this yet.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Metro apps fail when device joined to the domain
Related Threads
Hello, Need a heady group to assist with remediation; I want to troubleshoot and identify the root cause, then work toward a solution. Resetting, or any action that requires me to reinstall applications, cannot occur. Symptoms: Have a high end workstation running Win 8 Pro x64 w/ Media...
When I'm using the PC Settings app (Update and recovery) it seems almost all my Windows Updates fail with error 80200011. However, if I go to the desktop Windows Update and do the update from there, it succeeds. Stranger still, if I check the update history from within the Desktop Windows...
Hi, Lenovo Thinkcentre Windows 8.1 Pro (with media centre) 64-bit 16GB ram I am trying to add a new user account to my machine (Microsoft account). When complete, none of the default Start screen apps are properly installed - aside from the desktop tile, all others have a black X in the...
I have a Lenovo G505s AMD A8 Laptop, fairly new to Windows 8 as this is my first platform running it. Not had the system long, but generally finding it ok except for this one problem thats decided to arise: All apps, including the Windows Store fail to launch when clicked. They display a splash...
Hi In our domain we have a policy to change the wallpaper every month. The change is done from server side. Now wallpaper of most of users is changed but for few it remains the old wallpaper. For example I have windows 8 and mine is not updated. I also have tried gpupdate /force. No luck....
I've doing research and have not been able to find the solution my problem, hopefully you guys can help me. I am building a Windows 8 Image for our Lab here at UTEP and was wondering if there is a way that I can display the apps (mostly programs installed) to show to all user on our domain? Like...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook