Windows 8 and 8.1 Forums


Ripped games. -how do I mount second DVD ?

  1. #1

    Ripped games. -how do I mount second DVD ?


    I haven't played games in a while. I basically dragged and dropped most of my games onto an external hard drive . I was living with my mom and left the original discs there. I was trying to install flight simulator x just to see how it looked with my new 780 and realized I didn't know how to mount a second image without burning it to DVD. I could get the discs from my mom, but she would have to mail them. Is there a simple way to mount a second DVD? Also feel like I am going to have the same issue with GTA IV. I wanted to see how it looked with the new texture packs. Any assistance is appreciated.

      My System SpecsSystem Spec

  2. #2


    You can mount it with something like this (my favorite) Alcohol 52 FE - Free download and software reviews - CNET Download.com as a virtual CD and work from there.
      My System SpecsSystem Spec

Ripped games. -how do I mount second DVD ?
Related Threads
Solved Mount iso missing in General Support
Hello everyone, Am having a trouble with iso files. When I select the .iso files the Manage is not activating or enabling. pls suggest me to solve this. 15169 Thanks in Advance!
How to mount ext hdd in Drivers & Hardware
So I am running Ubuntu on my laptop which has been my primary computer for the past two years or so. My issue is this: I bought a new computer, I was in the process of setting everything up then when I realized my HDD wasnt there, I figure I didnt plug it in all the way. No, it is in, the computer...
mount .bin.cue files in General Support
hi , having trouble mounting files in w8 always used diamond tools before (in vista) without any trouble. but now its not working at all, im mounting the file and all that happens is audio file(1kb) in the viritual drive. have been sitting here for like 4h and whatever i do nothing works..
Not able to mount iso file in Virtualization
Hi, I didn't install any 3rd party app to mount iso. Yesterday, i tried to mount a iso file, it didn't worked. Then googled about it, tried sfc /scannow, no success. Then i checked "Default programs - associate file extension...", there is no entry for .iso. Please help. 27780 Tried Daemon...
couldn't mount image in Virtualization
i use windows 8 professional edition, when i want to mount the image, the warning message came and it says "couldn't mount image because its in use" although i'm not mount it, do you have any answers ? thanks :D
WOW Windows 8 mount the ISO in Software and Apps
What a nice surprise , you can mount the ISO I just finish to install Visio .... http://i554.photobucket.com/albums/jj432/dataxpert/mount.jpg
Eight Forums Android App Eight Forums IOS App Follow us on Facebook