Windows 8 and 8.1 Forums


Struggling to install .NET Framework 3.5

  1. #1


    Posts : 2
    Windows 8.1 64bit

    Struggling to install .NET Framework 3.5


    Hi there,

    I've tried a lot of different methods in order to install 3.5. All have failed so far. I'm really hoping that somebody in the know will be able to help me with this.

    First of all, I was running 3.5 fine as I could run programs that use it fine previously. This was on Windows 8.1 64bit before. I changed my hardware, specifically the cpu, motherboard and gpu. Reinstalled Windows and then started to reinstall everything else. As soon as I tried to reinstall 3.5, I was greeted by a message saying I wasn't connected to the internet. Error: 0x800F0906.

    I thought this was strange so I decided to google it. Turns out that this isn't a common problem and I did actually find some solutions from this message board that worked for some people. More specifically I tried to install it offline via my installation disc using the command line:

    C:\WINDOWS\system32>DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /Limit
    Access /Source:g:\sources\sxs

    This did not work. I received this after running the command:

    Code:
    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031
    
    
    Image Version: 6.3.9600.17031
    
    
    Enabling feature(s)
    [===========================66.5%======                    ]
    
    
    Error: 0x800f081f
    
    
    The source files could not be found.
    Use the "Source" option to specify the location of the files that are required t
    o restore the feature. For more information on specifying a source location, see
     Configure a Windows Repair Source.
    
    
    The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log
    
    Thankfully, the link they provide me with doesn't work. So that was a whole lot of use.
    
    I look into the DISM log file and I can't see anything immediatley useful to myself. I don't know if anyone else can see anything that could help. 
    
    [2436] Caller did not request sparse mount
    [2436] Mounting new image.
    Wim:         [\\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim]
    Image Index: [1]
    Mount Path:  [C:\WINDOWS\TEMP\d157017b-f81d-49e7-a4e8-10c6e92f470e]
    [2436] Wimserv process started for guid 4c24978b-8c82-4bcf-97fe-a79c1b091fc5.  Id is 2480
    [2480] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2480] Mounted image at C:\WINDOWS\TEMP\d157017b-f81d-49e7-a4e8-10c6e92f470e.
    [2436] [0x8007007b] FIOReadFileIntoBuffer:(1415): The filename, directory name or volume label syntax is incorrect.
    [2436] [0xc142011c] UnmarshallImageHandleFromDirectory:(511)
    [2436] [0xc142011c] WIMGetMountedImageHandle:(2568)
    [2436] [0x8007007b] FIOReadFileIntoBuffer:(1415): The filename, directory name or volume label syntax is incorrect.
    [2436] [0xc142011c] UnmarshallImageHandleFromDirectory:(511)
    [2436] [0xc142011c] WIMGetMountedImageHandle:(2568)
    [2436] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2436] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2436] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2436] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2436] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2436] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2436] ImageUnmarshallHandle: Reconstituting wim at \\?\GLOBALROOT\device\harddisk3\partition3\Recovery\WindowsRE\Winre.wim.
    [2480] Received unmount request for image with guid 4c24978b-8c82-4bcf-97fe-a79c1b091fc5.
    [2480] Unmount for image at C:\WINDOWS\TEMP\d157017b-f81d-49e7-a4e8-10c6e92f470e complete.
    I'm at a loss. I don't know what to do. I've tried everything I could find and I really don't want to start with a fresh install of Windows again. I'd greatly appreciate any help.


    Last edited by Brink; 04 Sep 2014 at 13:23. Reason: code box

      My System SpecsSystem Spec

  2. #2


    Posts : 151
    Win8 Pro


    Try copying the 'sources\sxs' folder onto your hard drive from the installation disc, change your command in the Admin Command prompt to reflect the new location, and see if it works that way.

    And even though MS doesn't provide it, you can also try downloading an installer package from here, which is Windows 8/8.1 compatible:

    Download Microsoft .NET Framework 3.5 Offline Installer for Windows 8 and 8.1 - AskVG
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8.1 64bit


    Quote Originally Posted by lastof View Post
    Try copying the 'sources\sxs' folder onto your hard drive from the installation disc, change your command in the Admin Command prompt to reflect the new location, and see if it works that way.

    And even though MS doesn't provide it, you can also try downloading an installer package from here, which is Windows 8/8.1 compatible:

    Download Microsoft .NET Framework 3.5 Offline Installer for Windows 8 and 8.1 - AskVG
    I did try the second one. Gave me the same error.

    A friend suggested the first method but again it gave the same error
    error. It was really bizarre.

    Gave up in the end and reinstalled. Fixed everything
      My System SpecsSystem Spec

  4. #4


    Posts : 151
    Win8 Pro


    Glad it worked out.
      My System SpecsSystem Spec

  5. #5


    Joisey
    Posts : 315
    Windows 8.1 consumer 64 bit


    Net frameworks 3.5 and 4.5 are available in the "add remove windows features" part of the "uninstall or change a program" window of control panel. Perhaps that is why installing it from a separate installer went south?
      My System SpecsSystem Spec

Struggling to install .NET Framework 3.5
Related Threads
I'm trying to install the .NET Framework 3.5 When I enable it in Programs and Features, it starts installing, and stops when it gets here. It's been like this for a few hours. 57721
:mad: I need to install the .Net framework 3.5 sp1 on Windows 8.1 for Autodesk 3ds Max for work. I initially noticed this in the Max installer...just quit installing and says I need to connect to the internet. Of course I am connected just fine. Tried Windows update, gave me this error:...
Hi there. I hope you're fine. I'm new here, so let me thank you for your help. :thumb: OKAY. I've a problem with my Win 8. It's 2 month now that i'm trying to install the framework 3.5... I've tried with Windows 8, I've tried Ofline too with the boot device... But it still the same. I...
Can't install .NET Framework 3.5 in Windows Updates & Activation
I can't install .NET Framework 3.5 no matter what I do. I tried downloading it and in the midway get the error 0x800f0906. I tried installing through DISM but that didn't work either. It always stops at 65.8 %. Can somebody tell me how to fix it? It's really driving me nuts.
I can't install net framework on Build 9369. I have tried the Command Prompt; "DISM /Online /Enable-Feature /FeatureName:NetFx3 /Source:d:\sources\sxs" and I get an error that it can't download the file
Can I download and install .net framework 3.5.1 externally which is required by some programs to run in windows 8, the problem is I'm not able to download it internally because I've a really slow connection.205120522053 I've already tried this...
3019 hello i installed win developer preview yesterday and tryed to install hp wireless assistant but it required net framework so computer started to download it by windows update but i canceled downloading and downloaded ne framework from microsoft site and every time i try to install it or...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook