Windows 8 and 8.1 Forums


Windows Apps don't work for one user, but work for others.

  1. #1


    Posts : 103
    Windows 8.1 Pro 64

    Windows Apps don't work for one user, but work for others.


    I have checked everywhere online, and I haven't found a single explanation for this.

    I have 3 user accounts.

    1. Administrator
    2. initial user
    3. new user

    So the initial user is the one you are forced to create when first setting up Windows 8.1. It's a local user meaning that I set it up without signing into a MSA.

    In both the Administrator and the initial user, all the WinRT apps/tiles work. Like the weather will show up and everything.
    WITNESS:
    Click image for larger version

    Click image for larger version


    Whether I change the Initial User to Standard or Administrator, everything still works fine. Of course, the Administrator can't open WinRT apps which is standard and normal. And the initial user can't use apps without signing into MSA. But it all still works perfectly fine.




    The problem is with the new user. The new user is meant to be in Administrator mode because it's my main account. But whether I set it up as Standard or Administrator, it's the same thing. None of my WinRT apps work.
    WITNESS:
    Click image for larger version

    Even when I sign into my MSA with the new user, it's still the same thing. It synchronizes to my OneDrive online. It recognizes that I'm completely signed in online. Yet it's still the exact same thing with the WinRT apps. None of them work. Even when I try to open up the Windows Store. It just continues to try to open, but doesn't go all the way through. So whether I'm signed into my MSA for the third user or not, it still gives the same problem.

    I ran Windows Update, and it worked perfectly. Everything is up to date.

      My System SpecsSystem Spec

  2. #2


    Posts : 103
    Windows 8.1 Pro 64


    I created a 4th account using an MSA instead of creating it as a local account. And it still has the same problem as the third account. Like I said, whether the account is created with an MSA or if an account was created as a local user, and signed into a MSA. It's the same extremely frustrating problem. I can't do anything like this.
      My System SpecsSystem Spec

  3. #3


    Posts : 22,585
    64-bit Windows 10


    Hello Crimson,

    While signed into the MSA having this issue, see if going through the listed items in the tutorial below for now may be able to help.

    Apps and Tiles Not Working or Responding: Fix in Windows 8
      My System SpecsSystem Spec

  4. #4


    Posts : 103
    Windows 8.1 Pro 64


    I did the #5 - restart explorer, it was taking forever, then the screen went blank (turned off). Now the tablet won't turn back on. I'm just going to hold down the power button to shut it off.

    If this didn't work, I'm probably going to just delete this fourth account that was created with the MSA. The third account isn't signed into anything, so it's basically a regular offline account.

    Then I'll try using the Bar Code account which is working, and sign into my MSA. Then see what I can do in the Windows store to reset whatever I can, and see if that will get my third account working.

    If that doesn't work, #12 said to turn on Windows Firewall if there's no other firewall installed. I have Online Armor installed. And it's not causing any conflict with the Administrator and the original Bar Code user.

    But I can try resetting Windows Firewall to automatic in Services without actually turning it on. Then see if that works to stop the problem of disabling apps for newly created users.
      My System SpecsSystem Spec

  5. #5


    Posts : 103
    Windows 8.1 Pro 64


    But then there's still the whole problem of why the hell did my screen just turn off when restarting explorer.exe process?
      My System SpecsSystem Spec

  6. #6


    Posts : 22,585
    64-bit Windows 10


    My guess is that something may have prevented explorer from actually restarting after it was killed leaving you with a blank screen.
      My System SpecsSystem Spec

  7. #7


    Posts : 103
    Windows 8.1 Pro 64


    Click image for larger version
      My System SpecsSystem Spec

  8. #8


    Posts : 22,585
    64-bit Windows 10


    Have you already gone through everything on the list while signed into this account?

    This one below (#18 in list) usually helps for the issue in that screenshot.

    App - Sync License in Windows 8
      My System SpecsSystem Spec

  9. #9


    Posts : 103
    Windows 8.1 Pro 64


    So Jesus fixed it.
    Click image for larger version


    I didn't even do anything. All I did was post that jacked-up image in the previous post. I even tried restarting a few times, and still got that same thing. So I quit. So after quitting, it just decides to work. After restarting multiple times, I move on with my life. During my excursion, it goes to sleep while logged into this tester account. I come back, turn it on, and suddenly everything is working. How rude.


    So I'll go through the steps on what I did despite not knowing why it was being gay up until I quit.

    1. The first thing I did was log into Administrator, and delete that 4th user account that was created with my MSA. Restart computer.

    2. I then log into my second user account, Bar Code which is a local account. As I said, everything works on this despite not being signed into a MSA. I'm able to open, and browse the Windows store, and whatever. Just not able to download or manage apps or do anything that requires signing into a MSA. So at this point, it's the same as the OP in which my third account, Source Code (which is local -not signed into MSA) is experiencing the problem.

    3. While in my second account, I sign into my MSA. But I don't do that #18 sync thing. Instead, I just do the #15 which is to update apps. Completely ineffective.
    WITNESS:
    Click image for larger version

    4. Completely ineffective, but not completely useless. That error message about the firewall really supported my original suspicion which I stated in my previous post. That your remark on #12 was only somewhat right.

    You stated: "If you do not have a 3rd party firewall program installed, the "Windows Firewall" service must be set to "Automatic" and running (start) or it will prevent you from installing and using any Store apps."

    My suspicion was that the problem might be exactly as you said, except not just in the absence of a 3rd party firewall. It might apply even with a 3rd party firewall installed. (Even though it makes no sense to have Windows Firewall Service enabled when you have a 3rd party firewall installed.) Hence, if this app update thing didn't work, I was planning to go back, and re-enable the Windows Firewall Service anyway. And this error message just emphasized that it might really work.

    5. I restarted the computer, and log into my third account, Source Code. I notice that it still has the same problem as seen in the OP. I sign out, and log into my Administrator account. I delete the Source Code account.

    6. I go into services, and set Windows Firewall service back to Automatic. But I don't start it back up. I restart the computer so that it restarts itself.

    7. After restarting, I log back into Administrator to check if everything is OK. The Windows Firewall service is set to automatic, and is running. Windows Firewall itself is completely off.

    8. At this point I'm practically certain it will work. I proceed to create a new local user account - tester1. Restart computer.

    9. After restarting, I log into the tester1 account. And everything is jacked up. I really thought this would work, but it didn't, so I decided I should quit. I post the image "iquit.png" in the above post, and quit. And that's when Jesus up and decides to fix it. Story of my entire life.
      My System SpecsSystem Spec

  10. #10


    Posts : 103
    Windows 8.1 Pro 64


    Needless to say, this case is SOLVED.


    CONCLUSION
    A. To avoid this problem: do not disable Windows Firewall in Services. Even if 3rd party firewall is installed. Windows Firewall being disabled in Services is what causes this whole problem of WinRT apps not functioning in newly created User Accounts.


    B. If you're having this problem: it probably means that Windows Firewall is disabled in Services. Log into the built-in Administrator account, and set Windows Firewall Service to Automatic.
    STEPS:
    Open Control Panel.
    Open Administrative Tools
    Open Services.
    Right-click Windows Firewall service.
    Open Properties.
    Set the "Startup type" drop-down to Automatic.
    Restart computer.
    Windows Firewall Service will run.
    This will make WinRT apps begin to work again.
    (You can still turn Windows Firewall completely off in Control Panel. )

    NOTE: It may be necessary to wait a few minutes while logged into the user account so everything can update properly for all the apps to start working. Restarting the system again might be necessary. (The user account can be local, and need not be signed into any MSA.)


    C. Or don't do anything. Just quit. Perhaps pray. And Jesus will fix it.
    Last edited by crimson; 27 Jul 2014 at 19:16.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Windows Apps don't work for one user, but work for others.
Related Threads
Hello! Since some time some Metro apps refuse to work, and they do so in interesting ways... Some apps work fine thought they don't appear to have internet (no connection error), but I receive notifications (e.g. e-mail) from them. Other apps open for a split second then close and return me to...
I've had windows 8 for a bit, but since I've installed the OS not a single one of my windows apps will work. I've tried a lot of options and none fix it. I will open up a app ( windows store app or PC settings for example) and it will open and display the icon and blown up screen then immediately...
Alright guys, Windows update has been really messing with my pc lately. I ran update and when it installed the updates my integrated mouse ended up not working. I rolled back update and installed the updates one by one and the one I ended up not installing was the camera codec pack. Now the problem...
Alright guys, I have just refreshed my pc because I was having numerous problems with it and it turned out to be a bad stick of RAM. However, now I am having software issues. Whenever I try to make a call on the desktop version of skype, the program crashes. Whenever I try to open HP support...
Hi there everybody. Loaded Windows 8 onto my daughters laptop just before Christmas. Everything worked great. Suddenly around mid January, most of the apps stopped working. The computer is connected to the internet. If I go to the desktop, I can open Google Chrome or IE and browse no problem. ...
Windows 8 Apps don't work in Software and Apps
Hi there, I just installed windows 8 yesterday. I've been able to use a few apps like mail, store and skype. But other apps like music or games don't work. most of the apps downloaded don't work either like wikipedia or IM+. I tried using fiddler, turning off my antivirus (trendmicro security),...
Will Windows 8 Work Out For The Average PC User? | Redmond Pie
Eight Forums Android App Eight Forums IOS App Follow us on Facebook