Windows 8 and 8.1 Forums

Unable to install from MSI files

  1. #1

    Unable to install from MSI files

    I am having a problem where any msi (and some .exe's) I have try to run to install a program have trouble accessing the AppData folder.

    Click image for larger version

    This is a recent install of Windows 8.1 (on a fresh drive) and then moved the user folder (which I think could be causing the issue). I moved the user folder using these steps User Folders - Change Default Location - Windows 7 Help Forums, which may have been as mistake on my part. I have proper access to the folder and everything. The most recent failure for me was Skype, after trying to launch the app which (seemingly) comes with Windows 8, I decided to install it myself. When I did, that box came up.

    TL : DR - Programs will not install and it seems to revolve around my AppData folder.

      My System SpecsSystem Spec

  2. #2

    Forever West
    Posts : 591
    WinVista, Win7, Win8.1, Win10, Mac OS X 10.10, Linux Mint 17.1

    It's entirely possible moving the wrong Folders screws things up as program installation routines expect certain Folders to be in certain 'paths' on the HDD. Also of concern is in having large amounts of RAM causes one to disable the Paging File/Virtual Memory as those install routines look for it to hold files temporarily while decompressing them before install.
      My System SpecsSystem Spec

  3. #3

    From what I can tell, what ended up happening is just that. Because Windows 8 allows for the use of a Microsoft Account across devices, the way users are saved in the registries has changed, and by changing the way the user registry saw where the user data was, I accidentally broke that user. The simplest way for me to fix this was to re-install Windows 8.1 and use the built in system to change where the Documents and such links were pointing to rather than use the registry itself. I thought about using symbolic links, but I thought that could cause different issues (well, more correctly that I might make another mistake in setting that up).

    Thanks for your reply.
      My System SpecsSystem Spec

Unable to install from MSI files
Related Threads
I have been trying to fix this issue for hours. This morning i got a "blue screen of death" and my pac said "your pc has ran into some problems". It then fixed everything and all was fine. I then typed "sfc / scannow" in command prompt and come up with the message "windows resource protection found...
SFC scan unable to repair files in BSOD Crashes and Debugging
Experienced issue with games not starting (haven't seen an issue with any other programmes), applies to some of my Steam games and some of my Origin games. I therefore ran a full system scan through cmd which gave me 'Windows Resource protection found corrupt files but was unable to fix some of...
Unable to install windows updates or MSI files in Windows Updates & Activation
So some background. I had issues with being able to install ANYTHING from an MSI file. Then I wasn't able to install any updates from Windows Update. I then reinstalled Windows, and am now facing the same issue after a few days. I would rather not reinstall yet again. I tried doing System...
Hi, I just tried downloading an exe file to the "Program Files" folder & was not able to in Win 8.1 pro. I get the attached message. I believe I was able to save files in this folder in win 7. I am the admin. Any clue why this happens? Thanks!
unable to access my jpeg files in General Support
Sir my name is Rupesh and I am facing a small issue. I am having a folder of size 28.7GB which contains 551000 files (547000 jpeg files and remaining files with some other extension) and 152000 folders. I am unable to access all my files and when I view the properties of the folder in windows...
Sfc shows unable to fix corrupt files in Performance & Maintenance
Hi, I have a new Acer Laptop. It came unpartitioned so I have partitioned it to have a C: and an E: drive. My OS is on the C: and my data is on the E: I have run an sfc scan which halted after 51% saying there were corrupt files it was unable to fix. In the log there are many DIRSD OWNER...
Solved Unable to access my files. in General Support
I have external hdd on which all my music, pictures, movies, docs,... are stored. Haven't used it since Win 8 cp installation. Now I plugged it in my computer, but there's a security issue. for every file and folder I have to add me as owner. That's no good since there is about 8000 files. How...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook