Windows 8 and 8.1 Forums


Mail and People Apps stopped working

  1. #1


    Watford
    Posts : 465
    Windows 7 x64 SP1 Home Premium/Win 8.1 in VBox

    Mail and People Apps stopped working


    Both the Mail and People Apps have stopped working for me. The were both working yesterday. The Mail App still shows a live tile but when opened gives this super helpful screen.

    Click image for larger version

    Has anyone any ideas?

      My System SpecsSystem Spec

  2. #2


    Uninstall them and search for them in the Store and install them again.
      My System SpecsSystem Spec

  3. #3


    Watford
    Posts : 465
    Windows 7 x64 SP1 Home Premium/Win 8.1 in VBox


    I'll give it a try and report back.
      My System SpecsSystem Spec

  4. #4


    Posts : 13
    Windows 8.1


    I have the same problem. As far as I know, this thing implies to the whole "package" of apps - Mail, Calendar, People and Messaging. I have no idea, what could be wrong, but also, I noticed this problem yesterday...

    And I have the same resolution. Tell me, can you run Camera app and Tencent QQ (downloadable for free on Store)? The first one, for a short time worked quite well, but now it just crashes without a reason. Same thing with QQ, although I had no chance to check if it's working.
      My System SpecsSystem Spec

  5. #5


    Watford
    Posts : 465
    Windows 7 x64 SP1 Home Premium/Win 8.1 in VBox


    I am attempting reinstalling them but they have been sitting on installing for a while. Maybe it's a problem with the server.


    Well they installed but still give the same error. I'm going to see if my other VM is the same.
    Last edited by kado897; 06 Mar 2012 at 10:47. Reason: NO Improvement
      My System SpecsSystem Spec

  6. #6


    Try doing this: SFC /SCANNOW Command - Run in Windows 8 .
    If you are lucky, it MIGHT work.
      My System SpecsSystem Spec

  7. #7


    Watford
    Posts : 465
    Windows 7 x64 SP1 Home Premium/Win 8.1 in VBox


    I'll give it a try. They are working in my other VM.
      My System SpecsSystem Spec

  8. #8


    Watford
    Posts : 465
    Windows 7 x64 SP1 Home Premium/Win 8.1 in VBox


    SFC ran clean. I think I'll see what restoring to yesterday afternoon will do.
      My System SpecsSystem Spec

  9. #9


    Watford
    Posts : 465
    Windows 7 x64 SP1 Home Premium/Win 8.1 in VBox


    The restore back to yesterday worked. Ho Hum! So what the cause was I have no idea.
      My System SpecsSystem Spec

  10. #10


    Posts : 13
    Windows 8.1


    Well, my problem still isin't solved. The funny thing is, I can't really do restore, because system is relatively new, so the only restore point is from today, when I installed MS Office (the problem occurred earlier).

    Sssso... got any more hints?
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Mail and People Apps stopped working
Related Threads
Solved mail stopped working, in Browsers & Mail
a pop up window says this app can't be activated when VAC is disabled. what is this and how do I fix it?
My PC info is in detail at my profile if needed. I have switched over to a MS account. The Tiles for Mail, Calendar and People were present on the metro start page even as it was a local account. But they only take me to a splash screen with the icon for the app and then returns to the metro...
I have a HP Pavilion desktop of course running Windows 8 Home When I first logged on I decided to use my Hotmail account and the primary account as Outlook.com :confused: When I first called an agent for some help he said that it was now settled and I could not have a local account. That I did...
Hi All We got a new Sony Vaio Laptop yesterday, with Windows 8; am getting to grips with the new OS at the moment and finding it a bit tricky. I booted up this morning to find the Mail, Calendar, People & Messaging Apps were no longer on my Start Screen. I tried searching All Apps, but it...
Mail & People Apps Messed UP! in General Support
Both the people app and the mail app have screwed up all the images from my LinkedIn contacts. In the People App, The persons name and their details are correct but the wrong photos from the wrong Linked In contacts have been mis referenced making them all wrong. Likewise in the Mail app when I...
This is a little frustrating. Both my people and my mail app will no longer launch. I did some googling, but so far none of the suggestions I have found worked. Tried re-installing. Right now my account is a local account. Any advice appreciated..
hi starting to get this error message in people mail and calendar apps You can't connect this account to any more devices. Remove another device first with help from your system admin or your Internet service provider." any one get this is there any fix
Eight Forums Android App Eight Forums IOS App Follow us on Facebook