Windows 8 and 8.1 Forums

missing MSVCP71.dll win 8 - .netframe 3.5 installed

  1. #1

    Posts : 4
    win 8

    missing MSVCP71.dll win 8 - .netframe 3.5 installed

    Im having a problem with Sid Meiers Pirates and windows 8.
    Even though I have netframe 3.5 installed it keeps telling me i am missing MSVCP71.dll
    I tried some app called DLL File Fixer that claimed to install it but no luck.

    Any suggestions?

      My System SpecsSystem Spec

  2. #2

    Posts : 660
    windows 8.1

    The missing msvcp71.dll is part of netframework 1.1. which is not compatible with windows 8.1.
    The installed netframework 3.5. also includes netframework 2.0. and often programs who need 1.1. will work also with 2.0.
    But it appears that your game Pirates also can't work with 2.0 the follow up of 1.1. Assuming that netframe 3.5. is installed and properly working on your computer.

    The .NET Framework 1.1 is not supported on the Windows 8, Windows 8.1, Windows Server 2012, or the Windows Server 2012 R2 operating systems. In some cases, the .NET Framework 1.1 is specifically identified as required for an application to run. In those cases, you should contact your independent software vendor (ISV) to have the application upgraded to run on the .NET Framework 3.5 SP1 or later version. For additional information, see Migrating from the .NET Framework 1.1.

    The Windows 7 and Windows 8 operating systems do not support the .NET Framework 1.1. As a result, applications that target the .NET Framework 1.1 will not run without modification on Windows 7 or Windows 8. This topic discusses the steps required to run an application that targets the .NET Framework 1.1 under Windows 7 and Windows 8.

    You can retarget the application to run under .NET Framework 4. Retargeting requires that you add a <supportedRuntime> element to the application's configuration file that allows it to run under .NET Framework 4. Such a configuration file takes the following form:

    <supportedRuntime version="v4.0"/>

    I am not a developer/programmer so i don't know if the mentioned configuration file is the config.ini file of the Sid Meier's Pirates Game or a special dedicated netframework configurationfile that maybe only the softwaremaker can change.

    But netframe 4.0 does not include 2.0. so change the configuration file to:

    < startup>
    <supportedRuntime version="v3.5"/>
    < /startup>

    So if you dare i would say add the the supportedRuntime element to Sid Meier's Pirates config.ini and hopefully it will work.


    Netframe configuration files are standard .XML files
    So you must look for .xml file in the game.
    Last edited by lifetec; 04 Mar 2014 at 17:13.
      My System SpecsSystem Spec

missing MSVCP71.dll win 8 - .netframe 3.5 installed
Related Threads
Solved New installed SSD in Performance & Maintenance
I recently installed a New SSD Crucial MX100 CT512MX100SSD1 2.5" 512GB SATA III. I have Windows 8.1 Pro 64bit which when i installed it i did a clean custom install of the OS. Wanted to know if there is anything i need to do to make sure this SSD is running optimally on my system. I have it...
Installed my new SSD in Installation & Setup
Just finished installing my new SSD that was cloned with Macrium Reflect v5. Except for a few minor problems everything went OK. The first problem was Macrium Reflect wouldn't allow me to clone to a smaller drive. I had to shrink my C partition with MiniTool Partition Wizard. My second problem was...
KB2919442 installed then not installed in Windows Updates & Activation
Hi, I'm using Windows 8.1 Pro 64 Bit If I go to Control Panel/Windows Update/View Update History KB2919442 is shown as installed successfully on the 12 March 2014 "BUT" if I go to Control Panel/Windows Update/Installed Updates there is no KB2919442 listed. If I download KB2919442 directly...
When I was on Windows 8 I could install an app from the store and it would automatically put a tile for it on the start screen. After upgrading to 8.1 it stopped doing that. Now after I install an app I have to search for it and right click and tell it to pin to the start. Is there any way to have...
so I was downloading the updates to windows 8.1, but it wasn't going anywhere so I rebooted. Then on reboot, I try again and it's not showing up on the store. I hit the back button a few times and saw the link again, but it says it's already installed. Now I am pretty sure it didn't get...
I am having a windows 8 RTM visual machine which is missing msvcp71.dll in C:\Windows\SysWOW64. Anyone here knows how to get msvcp71.dll? I copied the file from my windows 8 preview vm to my windows 8 RTM. But I couldn't register the file with an error. Any help will be appreciated.
I am asking as my Windows 8 will not boot with more than 12 GByte RAM :cry:
Eight Forums Android App Eight Forums IOS App Follow us on Facebook