Windows 8 and 8.1 Forums

Windows 8.1 Metro Apps Not Working...

  1. #1

    Posts : 8
    Windows 8.1

    Windows 8.1 Metro Apps Not Working...

    After my Windows 8.1 Upgrade, my store and other apps worked fine for a while. After that, all of a sudden, all the apps stopped working, with a 'x' sign on the bottom right of each tile. All apps stopped working, if I click on them, a grey screen appears, and I can see the app in the left side background apps bar, but if I click on it again, it shows a grey screen and the loop continues. I am not even able to open PC Settings, although the 'Store' works fine. Everything desktop related also works fine without a glitch.

    Things I've tried:

    • Windows Apps Troubleshooter, which said that "Some Apps might not have access to required resources" under "Issues Found" tab

    • Running it in safe mode; the apps do not even work in the Safe Mode

    • Creating a new user

    • Running sfc/scannow which returned with no errors

    • Running from admin command prompt:-

    Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    • Running from admin PowerShell:

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

    When I run the CMD command, the error comes:-

    Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF9, Install failed.

    Please contact your software vendor. (Exception from HRESULT: 0x80073CF9)
    Rejecting a request to register from C:\Windows\WinStore\AppxManifest.xml
    because the manifest is not in the package root.
    NOTE: For additional information, look for [ActivityId]
    964b2909-33b2-0001-2a2c-4b96b233cf01 in the Event Log or use the command line
    Get-AppxLog -ActivityID 964b2909-33b2-0001-2a2c-4b96b233cf01
    At line:1 char:1
    + Add-AppxPackage -DisableDevelopmentMode -Register
    $Env:SystemRoot\WinStore\AppxM ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : WriteError: (C:\Windows\WinStore\AppxManifest.xm
    l:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageMa

    When I run the PowerShell command the error comes along the lines of:-

    "Cannot validate argument on parameter 'Path'. The argument is null or empty. Provide an argument that is not null or empty and the try the command again."


    Last edited by Ekansh; 27 Feb 2014 at 12:21.

      My System SpecsSystem Spec

  2. #2

    Posts : 22,577
    64-bit Windows 10

    Hello Ekansh,

    Here's a list of troubleshooting steps that will hopefully help with this.

    Apps and Tiles Not Working or Responding: Fix in Windows 8
    Last edited by Brink; 27 Feb 2014 at 11:53.
      My System SpecsSystem Spec

  3. #3

    Posts : 8
    Windows 8.1

    I'm sorry but I had tried all those solutions before, and none of them worked...

    I was hoping to find out more about why the CMD command

    Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml

    and PowerShell command

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

    could not be executed successfully and returned with the errors mentioned in the original post above...
    Thank you
      My System SpecsSystem Spec

Windows 8.1 Metro Apps Not Working...
Related Threads
I also experienced problems when I upgraded to Windows 8.1 from Windows 8 on my desktop but my laptop went flawlessly. On my desktop, virtually none of my metro apps would work, I had to uninstall virtually all of them and re-install them. However, about five of them including Kindle and...
Solved Certain Metro Apps Not Working in Software and Apps
Hi, I have a problem here... I upgrade my Win7 to Win8 Pro and later to Win8 Pro with WMC (using the free key that Microsoft gave). Later I realized that few of my Metro Apps not working especially News, Sport, and Weather. From what I read, this usually caused by the antivirus. But strangely,...
i have recently installed windows 8 and added my email Hotmail id too and synchronised my id and pc both. but when i click on any of the metro apps it enlarges for few seconds and again the start screen comes . it happens for all metro apps. when i put the mouse pointer to left corner then it is...
I installed my RTM Technet Win 8 pro as an upgrade of my Win 7 ult. Everything was golden... For awhile. After uninstalling some stuff that I wouldn't use/and or designed for tweaking Win 7, etc, some metro apps no longer work. But.. Some do. Example: Minesweeper works, but won't...
Metro Apps not working in Software and Apps
Hello All, I am having somewhat of an odd issue. When I launch a Metro app, it will show the 'app start screen' but then immediately close. It would appear that the process is still running because I can see it, and others attempted, in the running Metro apps area (top left, mouse down). I...
Metro Apps not working in Software and Apps
am trying to open word hunt but its not working. not one of the tiles do anything when i click them..
Metro apps don't working in Software and Apps
Hello, I just finished to install Windows 8, but I have a problem, when I want to run a Metro App as Music or Videos, the icon of the application appears a few seconds on fullscreen, and it closes. I read that it was because of the resolution of the computer, that metro apps requires at least...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook