Windows 8 and 8.1 Forums


Installers cannot elevate, have to run as admin

  1. #1


    Posts : 10
    WIndows *

    Installers cannot elevate, have to run as admin


    In Win8 Pro x64 (and now with 8.1) shortly after installing Windows I couldn't run any installer from a web browser or by just double-clicking the file. I have to right-click and "Run as administrator"

    The error messages vary but they all are variations on a theme of unable to access something.

    I usually have UAC off but the UAC setting doesn't matter. I am an administrator. I am using Start8 and ModernMix if it matters. I've Googled and found nothing that worked but I don't remember exactly what I've tried.

      My System SpecsSystem Spec

  2. #2


    UK
    Posts : 333
    Windows Server 2012 R2 / 8.1


    This is how it is designed in Windows 8/8.1, the UAC is never complete disabled.

    The only account which does not desire a password is the built-in administrator.

    Built-in Administrator Account - Enable or Disable in Windows 8

    Please find more information about the UAC here:

    User Account Control (UAC) - Change Settings in Windows 8

    It is not recommended to run the built-in Administrator and will come with limitation for example; not being able to use store apps.

    Cheers,
    Harry
      My System SpecsSystem Spec

  3. #3


    Posts : 10
    WIndows *


    I know that UAC is never completely off in 8/8.1. But the system is not working as designed.

    I have a VirtualBox Windows 8 VM with UAC "off". If I open IE in it, download an installer, and click "Run", the program runs and installs.

    In my real system if I open IE, download an installer, and click "Run", I get an error message. I have to click "Save", go to Downloads, right-click and Run as administrator.
      My System SpecsSystem Spec

  4. #4


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Just curious: A 3rd party anitvirus installed?

    Upgraded from Win7?
      My System SpecsSystem Spec

  5. #5


    Posts : 10
    WIndows *


    No 3rd party AV, just Windows Defender. Clean install of 8, upgrade to 8.1.
      My System SpecsSystem Spec

  6. #6


    UK
    Posts : 333
    Windows Server 2012 R2 / 8.1


    Hi Jon,

    Can you try creating a new user and login with the new user and try download something from Internet explorer.

    elevated command prompt:
    + X
    + A

    enter command:
    NET USER username "password" /ADD

    add your desired username and password

    Cheers,
    Harry
      My System SpecsSystem Spec

Installers cannot elevate, have to run as admin
Related Threads
Okay, I'm very sure I set my account to be Admin, there's only one account anyway, yet W8 requests admin permission to do everything. All because of this, I can't change the .ini of a game, I can't update Neverwinter Nights using the updater, I can't save .inis or .txts anywhere except...
Solved I needed admin rights using built-in admin account in User Accounts and Family Safety
Using Win 8.1 First off, the account I'am signed on with is listed as admin type account. It's the one I had to enter my windows account email. Since installing the new MalwareBytes 2.0 program (which went in without any problem) it put an shortcut icon on desktop. I tried too move the icon...
Hi everybody, I'm experiencing a weird problem with Windows 8 Pro x64. Although I'm on the only user account on Windows (that is the administrator one), it looks like I don't have the Admin privileges and need to manually request them each time. For instance, when I install some programs (e.g.,...
Just recently this problem has affected me. Whenever I want to install a new program/application on Windows 8 desktop (Ventrilo, Ccleaner, etc.) i asks me for permission and I say yes. Nothing else appears afterwards and I cannot delete the installer(.exe file). If I try to delete it it says it...
So I've been desperately trying to install some programs for a while here. They download fine, but when I click on the set up icon it asks for my permission to launch, but doesn't ever actually launch the installer. I can see all the instances running in the taskbar, but the setup guides never show...
Solved Transferring Standard (Admin) Account to Hidden Admin? in User Accounts and Family Safety
Hi Guys, I'm new to this forum (as in this is my first post) so please be gentle with me if this has been answered before. :o So anyway I have a standard account with admin privileges, turned off UAC etc... but it doesn't seem to be elevated all the time for example I still see the "admin...
Hello, I was attempting to launch a Steam game called Garry's Mod but as I tried this I was notified by the game I needed to update my DirectX Runtime. So, it opened a link in my browser and I downloaded the installer (Download: DirectX End-User Runtime - Microsoft Download Center - Download...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook