Windows 8 and 8.1 Forums

Windows Store Broken

  1. #31


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Quote Originally Posted by David Bailey View Post
    Quote Originally Posted by ectech View Post
    StoreDiag log shows permission issues. So, something is blocking parts of the fix.

    Do you use WinPatrol or something similar?


    You could also run the commands yourself.

    Code:
    subinacl.exe /outputlog=%userprofile%\Desktop\Storeperms.txt /subkeyreg "HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages" /display
    
    subinacl.exe /outputlog=%userprofile%\Desktop\Storeperms.txt /subkeyreg "HKEY_LOCAL_MACHINE\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages" /display
    I use WinPatrol.
    Neither code worked:

    Click image for larger version

    Click image for larger version

      My System SpecsSystem Spec

  2. #32


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Quote Originally Posted by ectech View Post
    Thats a problem, disable WinPatrol and try again.
    OK.
    I'll be back.
      My System SpecsSystem Spec

  3. #33


    Posts : 1,360
    Windows 8.1 Enterprise


    My mistake David, I had a copy in the System32 Folder that's why I didn't have any problems while I was writing to code.

    Copy SubinACL.exe to C:\Windows\System32\
      My System SpecsSystem Spec

  4. #34


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    It didn't help disabling WinPatrol.

    I've used it for years with no problems.

    It's never given me a message about the Store.
      My System SpecsSystem Spec

  5. #35


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Quote Originally Posted by ectech View Post
    Copy SubinACL.exe to C:\Windows\System32\
    OK.
      My System SpecsSystem Spec

  6. #36


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Ran it again.

    txt file attached.

    storeperms.txt
      My System SpecsSystem Spec

  7. #37


    Posts : 1,360
    Windows 8.1 Enterprise


    Here is your problem..

    Code:
    ==========================================
    +KeyReg HKEY_LOCAL_MACHINE\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages
    ==================================================================================================================================
    /control=0xc00 SE_DACL_AUTO_INHERITED-0x0400 SE_SACL_AUTO_INHERITED-0x0800 
    /owner             =system
    /primary group     =system
    /audit ace count   =0
    /perm. ace count   =9
    /pace =builtin\users     ACCESS_ALLOWED_ACE_TYPE-0x0
        INHERITED_ACE-0x10             
        Type of access:
        Read
    Here is my system..
    Code:
    =========================================
    +KeyReg HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages
    =================================================================================================================================
    /control=0x0 
    /owner             =system
    /primary group     =system
    /audit ace count   =0
    /perm. ace count   =7
    /pace =system     ACCESS_ALLOWED_ACE_TYPE-0x0
        CONTAINER_INHERIT_ACE-0x2      OBJECT_INHERIT_ACE-0x1         
        Key and SubKey - Type of Access:
        Full Control
      My System SpecsSystem Spec

  8. #38


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Quote Originally Posted by ectech View Post
    Here is your problem..

    Code:
    ==========================================
    +KeyReg HKEY_LOCAL_MACHINE\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages
    ==================================================================================================================================
    /control=0xc00 SE_DACL_AUTO_INHERITED-0x0400 SE_SACL_AUTO_INHERITED-0x0800 
    /owner             =system
    /primary group     =system
    /audit ace count   =0
    /perm. ace count   =9
    /pace =builtin\users     ACCESS_ALLOWED_ACE_TYPE-0x0
        INHERITED_ACE-0x10             
        Type of access:
        Read
    Here is my system..
    Code:
    =========================================
    +KeyReg HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages
    =================================================================================================================================
    /control=0x0 
    /owner             =system
    /primary group     =system
    /audit ace count   =0
    /perm. ace count   =7
    /pace =system     ACCESS_ALLOWED_ACE_TYPE-0x0
        CONTAINER_INHERIT_ACE-0x2      OBJECT_INHERIT_ACE-0x1         
        Key and SubKey - Type of Access:
        Full Control
    I'll change mine to yours & see what happens.
      My System SpecsSystem Spec

  9. #39


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    I can't find it:

    Click image for larger version
      My System SpecsSystem Spec

  10. #40


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    If I knew how to write a reg file to add it to the registry I would.
    But I don't.
      My System SpecsSystem Spec

Page 4 of 8 FirstFirst ... 23456 ... LastLast
Windows Store Broken
Related Threads
Windows 8.1 x64 broken icons in General Support
So, i noticed this bug long time ago, but now i decided to try to solve it, because i will be using this os for long time now. When i try to delete files or something, and when i get a windows to confirm my actions, there is a big icon on the left side, and that icon has a black line on it, how to...
Hey guys, long time no see! 47025 Well, after a bunch of changes in my pleasantly static life, I'm back here with this problem: I work installing multiple computers using always the same image I made on a virtual machine and use to update often. The image have a normal Windows 8.1 Update 1 x64...
Like the title says, when I go to 'My Apps' and select an installed app, the only options are to clear the selection and INSTALL the app, which is already installed. Anyone else seeing this? Pretty awkward...
Windows FAX broken in 8.1 in Software and Apps
Still broken. FAX send will hang/redial. Didn't work in 8.1PV - may have functioned in 8. The problem is FXST30.dll. Replacing it with the Windows 7 copy resolves it. This may require taking ownership. Someone here with Microsoft's ear might pass that along to the higher echelon.
Windows 8 OS broken in BSOD Crashes and Debugging
I have a Dell Inspiring 15r and yesterday it started running extremely slow. I realised that installed software had restarted the laptop while it was in the middle of an important windows update. After a few attempts to fix it I'm stuck with nothing. Now when booting up I get to a screen...
I have a 2 tb Network store on a 1 gig Ethernet, which worked fine on Windows 7. I ran the upgrade advisor this facility and software was not identified as a potential problem. However it does NOT WORK. It just says it is incompatible on Windows 8. The Novostore website is not helpful.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook