Windows 8 and 8.1 Forums

Install Third Party Soft Admin Mode

  1. #1

    Posts : 29
    windows 8.1

    Install Third Party Soft Win 8.1 64 error 2502/2503

    Greetings to all,

    I have just realized that I can only install third party software in 'admin mode'. That never happened to me before. I have always been able to install software with my user which is 'admin' on my PC.
    Is it bad Doctor ?
    I installed 'classic shell' and realized the issue.
    I am not a pro in IT but I believe installing third party software in 'admin mode' might not be a good idea.
    Any help is, of course, much appreciated.

    zongo saiba
    Last edited by zongo; 07 Jan 2014 at 05:56. Reason: clarity

      My System SpecsSystem Spec

  2. #2

    Posts : 29
    windows 8.1

    Error 2503 and 2502 while installing third party software on Win 8.1 64 should ring a bell to many of you guys. I have been strolling the net the better half of this morning trying to find a solution and here it is. I am posting the work around(s) for others to benefit and save time
    The first solution that I found on the net is to use the 'admin mode' install, if the package has it. I found out that not all package have the admin mode. For example, I tried to install 'LibreOffice' and it did not have it; so I went and look for another solution.
    The next best thing, which I think is really dirty, is to end task 'explorer.exe' and start it again in admin mode through 'task manager'. You should have no issue installing or removing your piece of software. That did the trick for me when installing 'LibreOffice'. No more errors 2502/2503.
    Finally, the one I like the most is using the command prompt, again 'admin mode', and make use of the command line 'msiexec /i "package" '. That worked for me with one msi package but did not work for others. Why, I don't know.
    Nevertheless, I don' really understand why we have to go through that many troubles to install software. If any guru knowledgeable enough could explain why this is happening and most of all provide a decent fix, that would be much appreciated.
    I found some explanations when reading this post: ""; but I could not use his solution as I did not understand the use of MDT

    Best Regards,

    zongo saiba
    Last edited by zongo; 08 Jan 2014 at 04:02. Reason: clarity
      My System SpecsSystem Spec

  3. #3

    Posts : 29
    windows 8.1

    More Updates:
    Some package will just fail to install silently (meaning no error message). For example, I tried to install the latest Quicken package (2014). The install went fine as per software message on screen, but the soft never actually installed on my unit. I searched for it to no avail. I went through the process of installing the soft a second time but still same issue. There were no error message to report at any level. I know that using the 'admin mode' enable the install to complete. Also, as per post on the net, this type of issue seems to be coming from a permission screw up in the windows installer (so prior post for ref - not really sure that it is a permission screw up). The fact that the install works fine in 'admin mode' seems to correlate the permission story. Then it just hit me that every single time I am trying to install a piece of software, I am never asked to elevate privileges via a password. My account is admin and UAC is set to 'always notify'. I remembered in other win version that I was always asked to type in my password before installing a software. So, I thought, why not make the system ask me for my password every time I install a package or at least elevate privilege for the install to complete successfully. It did work. I am now prompted for my password and soft can install correctly without having to go through dirty hacks like the ones above I have described.
    So, you just have to go to 'local policies' enable "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode". You have different type of 'enable'. I picked 'Prompt for credentials on the secure desktop' but I am pretty sure that 'Prompt for consent' should be sufficient enough for you to install software like before without having to type in your password. I have not tested the latest though.
    Now, I don't know if this is a good way to do things, I would argue that it is better than the dirty hacks mentioned in my previous post, but it surely solved my issue
    Hope it helps some of you guys faced with the same issue as I have.

    Kind Regards,

    zongo saiba
      My System SpecsSystem Spec

Install Third Party Soft Admin Mode
Related Threads
gang I have seen this movie before and cannot recall how I solved. I have a "new" laptop via a reseller. it has a factory-loaded windows 8 pro. it works fine - now upgraded to 8.1. however there is a huge security "hole" which I cannot live with. Enabling the builtin Administrator account, it...
I know that a lot of people seem to have similar problems, but none of the advice in any of those other threads is helping me, so I hoped that a new one might prove useful. I work at a hotel, and we are having issues with our public computer (Acer Aspire XC-603G desktop) connecting to the...
Solved Can't Install 3rd-Party App in Software and Apps
Processor: Intel Pentium G2020T @2.5 gHz Main RAM: 8 GB Windows 8.1 64-bit "Activated" Harddrive: 1 TB Trying to install Google "Sketchup" by executing google-sketchup_setup.exe Following sequence occurs with no error report: 1. Double-click file in Windows Explorer
Quicktime stopped working. Logged in as admin. Uninstalled then tried reinstall of and 7.6 using 'run as admin'. No luck. Insufficient privileges to the directory--c:\program files (x86) Quicktime. When I look at the folder properties under security---'You must have read permission to...
Is there any way to install a software without admin password in standard user account?
On a new Windows 8 Installation, I created a local non/domain user. This is typical for me. I had no idea the first user is the "magical" user. Then I added the domain user and made sure it was an Administrator, both on the Metro settings and on the Desktop. At least, if I go in now and look, it...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook