Windows 8 and 8.1 Forums


DvdFab V9 - refuses to open DVD's - not just Blu Ray's

  1. #1


    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    DvdFab V9 - refuses to open DVD's - not just Blu Ray's


    Hi there
    the latest incarnation of DvdFab (version 9.X etc) FAIL to open even bog standard DVD's on W8.1 - error message : "Cannot open E:\"

    DVD is fine - plays OK and it's an OLD one so shouldn't have any problems with any new copy protection schemes -- actually was the 1st Disc in the set of the Classic US TV series "The Invaders" with Roy Thinnes - if you've never seen it well worth it - they just don't seem to make TV series like that these days -- also no Mobile phones back then so half the movie isn't spent looking at people making mobile phone calls !!!. I was wanting to rip this series so I could watch either on a tablet or smartphone (Samsung S4).

    AnyDVD works just fine - I was hoping though to be able to Rip and Convert with a single program instead of using AnyDVD to Decrypt and de-regionalize the DVD and then use Handbrake for ripping it. DVD Catalyst also has problems at getting a decent quality of copy -- seems the old software is still the best -- although Handbrake takes a bit of effort to set it up to get high quality rips.


    If anybody has got DvdFab to work on Windows 8.1 using PHYSICAL DVD's (not previously copied iso's to HDD via using other software) please post what release you are using. I've tried with Rel 9.0.X and 9.1.X both fail.

    Cheers
    jimbo

      My System SpecsSystem Spec

  2. #2


    Posts : 2,130
    Windows 8.0 x64


    Also take a look on VideoHelp.com - Forum, Guides, Tools and hardware lists
    Some very good forums there
      My System SpecsSystem Spec

DvdFab V9 - refuses to open DVD's - not just Blu Ray's
Related Threads
Windows 8.1 refuses to sleep in General Support
Hi, Hope someone can help me. Windows 8.1(full fresh install) will not go to sleep/shut down etc. This has been happening since I installed 8.1 a few weeks back. It works/worked fine in Windows 7 and windows 8.0 till this install. I have narrowed it down to the Ethernet Chipset ( on board...
For some reason, Windows refuses to let any program (utorrent, iexplore, firefox...) connect to animetorrents.me (reporting that it cannot locate the server in Firefox and telling the me machine actively refused the connection in uTorrent) I can access the site through a proxy (eg: by going to...
I have two practically identical Yoga 2 Pro laptops with 8.1. One of them (mine) and several other computers (W7 and 8) are attached to a Zyxel NSA221 network drive. I had no trouble mapping the drives, and they reconnect flawlessly thanks to NetDrives (no thanks to Microsoft for never...
US DVDfab Users - note in Software and Apps
Hi there Just because a law is passed in the US it doesn't automatically mean that it's legal OUTSIDE that particular jurisdiction (although due to various "enforcement methods" they by sheer economic muscle try and make it stick) - but they are trying to block DVDfab's payment processes -- a...
Amazing... I searched for "sleep" here and found the "Windows 8.1 refuses to sleep" thread, which is still going strong after almost 800 posts, talking about the exact opposite problem to the one I'm having! (Now, needless to say, I haven't read the entirety of that thread - yet; could someone...
I bought a new Dell 5 weeks ago (my old one of 9 years died) sadly it came with Wiin 8 installed? I wish I hadn't? The accounts and Passwords are atrocious. I have been locked out Twice using the same password I have used for 5 years and had used the night before and then had to wait a week for a...
Hi there. If you are using DvdFab for DVD ripping etc and running W8.1 64 bit version - latest few builds of the 64 bit version of DvdFab now DOESN'T work on standard commercial DVD's (encrypted ones). You get Cannot Read Disc - on perfectly playable DVD's (even old ones's so it's nothing to do...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook