Windows 8 and 8.1 Forums


App Doesn't Start Upon Login

  1. #1


    Posts : 9
    Windows 8.1 Pro x64

    App Doesn't Start Upon Login


    I placed an app (RealTemp GT) in the Startup folder, so it will automatically run every time I log in to my desktop, but it does not run. The application is listed as "Enabled" under the Task Manager group Startup. I've attempted running as admin, and not. If I manually run the application, I have no issues. Windows 7 had no issues running this application at startup.

    Any ideas why this application will not run automatically at startup?

      My System SpecsSystem Spec

  2. #2


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Administrator rights? 8 is really picky. Sometimes you have to edit the security rights for the app and enable full control for all users. At least it has worked for me the short time I've been using 8.

    Also could try it with UAC off just to see if it makes a difference.
      My System SpecsSystem Spec

  3. #3


    Posts : 22,577
    64-bit Windows 10


    Hello dsDoan,

    This is because the RealTempGT.exe file from Real Temp requires elevation (Run as administrator) to run after approving the UAC prompt. By default, Windows will not run anything elevated at startup for security purposes. This is why it will not run at startup.

    If you like, you could use the tutorial below to create a task to run an elevated shortcut to run the RealTempGT.exe file without getting an UAC prompt. When you get to step 23, you will want to use the run at startup as a task link to create another task to run this elevated shortcut at startup.
    This will only work in administrator accounts.

    Hope this helps,
    Shawn
      My System SpecsSystem Spec

  4. #4


    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit


    Sorry Brink, guess we kind of stepped on each other posting at same time.
      My System SpecsSystem Spec

  5. #5


    Posts : 9
    Windows 8.1 Pro x64


    I have UAC set to never notify, and in the RealTemp GT shortcut properties, I have it set to run as admin. Doesn't that bypass what the tutorial is attempting to do?
      My System SpecsSystem Spec

  6. #6


    Posts : 22,577
    64-bit Windows 10


    Sorry, but no that's not the same. Using the method in the tutorial is the only way to have it run elevated with system rights and run at startup for administatrators.
      My System SpecsSystem Spec

  7. #7


    Posts : 9
    Windows 8.1 Pro x64


    Thanks for the link. I just threw the shortcut in the Startup folder, and it worked fine.

    I'm not of a fan of the direction Microsoft's been heading with privilege restrictions. By default is fine, but settings should be available to fine-tune to personal preference.
      My System SpecsSystem Spec

  8. #8


    Posts : 22,577
    64-bit Windows 10


    Great news.
      My System SpecsSystem Spec

App Doesn't Start Upon Login
Related Threads
Just purchased a laptop for the wife with windows 8.1 & trying to understand it I set up live mail 2012 as her email service & pinned it to the taskbar. But when she clicks the mail tile from the start screen it ask for an account & does not start the correct program. The same is true of IE...
Hi, This is my first post on this forum. I've been searching for a solution for my problem for a couple of days and found nothing, so I hope I can find some answers here. I'm trying to make a certain program (a game, actually) to run as soon as I boot the computer. So, I don't want to click...
I have a year old asus k55n that has been upgraded to win 8.1. Was running a bit slow, so i was checking settings, and noticed that in msconfig it was set to the limited boot option (the last one on the list), not normal boot. I had noticed before, and when i would set it to normal, it would be...
Hyper-V new vm doesn't start in Virtualization
Hello, I've installed Win Pro 8.1 on a new desktop and added the Hyper-V feature. Checking the bios shows Virtualization is enabled, and I contacted intel about the processor who verified it supports virtualization (dell said it doesn't). I can start the VM manager, create an Internal Lan Switch...
Hi, After a clean boot login I need to logoff and login again to start working. Otherwise I cannot move icons (just to name something simple!). UAC is set to the lowest setting and I am logging in as administrator, using Windows 8.1 Pro. Once I'm logged in properly (the 2nd time), everything...
hello guys.it my first post as i am new to this os.when i start my laptop,the leds are lighting but the screen is blank.if i press the reject button of the cd/dvd driver in the first 10-20 seconds.windows will start properly.if i don't, the blanc screen continues to exist.if i start the laptop with...
Hey guys! I'm having a problem with windows 8 professional setup: So I have win8 consumer preview installed on my laptop. A couple days ago its licence expired, so I got win8 professional to upgrade. I made an install USB with the win7 USB utility and proceeded to boot from the stick. The...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook