So I recently had to do a reformat and reinstall of Windows 8 on my homebuilt PC, due to a driver/corrupt system file issue that a system restore couldn't fix. Back in the previous installation I had installed it without any issues and I was able to run software compiled under .NET 3.5 fine. Now I can't install it again after reformatting... I downloaded the full installer for it, and went to install it, and before the actual installer could start Windows kept telling me the installer required .NET 3.5 ("An app on your PC needs the following feature: .NET Framework 3.5 (includes .NET 3.0 and 2.0)"), when this is an installer for it! I also tried the "bootstrapper" installer, which downloads the files itself instead of through the browser entirely, and I have the same issue with that.

Ithen heard of another method found here: Installing the .NET Framework 3.5 on Windows 8

So I tried that and that didn't work either, this method seems to use the "turn Windows features on or off" wizard to download/install .NET 3.5, but this method fails miserably too: there is no download progress AT ALL even though I am connected to the Internet. After about 5 mins of no-go progress it simply times out (error 0x800f0906). I looked up the hexadecimal error code and still couldn't resolve my problem there.