I've installed MySQL Server v. 5.5.28 64-bit won't install, saying A DLL required this install could not be run. A screenshot below:

Click image for larger version

Tried installing other versions, still came up with the same issue.