I upgraded from Win 7 Ultimate to win 8 using an upgrade disk (to save 2GB download). Everything went fine and I purchased the necessary registration and activated OK.

BUT, now I find that a ClickOnce application I wrote in C# and which has always run on XP and win 7 DOESN'T run on Win 8. Investigation showed that it needs to create a temporary file in the Windows/System32 directory and it is denied permission. I found I was also denied access to various other directories even though I am logged in with the account Windows created for me and which is part of the Administrators group.

I spent a couple of days reading about UAC and "Taking ownership" so I figured, OK, let's own the lot. I therefore went in to take ownership of the C: drive and saw it was currently owned by "Trusted Installer". I wanted to set the ownership to my account but it didn't appear in the list, so I set ownership to the Administrator's group. It went through all the sub-directories and changed the ownership.

However, my application still gets access denied. I am just bewildered by this UAC/elevation/access denied nonsense when I am an Administrator and can't do anything.

I realised it is probably my lack of understanding so I decided to set everything back to Trusted Installer. Imagine my horror when I found that this account (just like my own account) is Unknown to the system. (It doesn't apper in any lists of permissions so it cannot be selected.)

The application I mentioned will be deployed to other machines and I don't want to make people turn off UAC in order to install/run it. I also don't want to have to rebuild the entire application and make it write to a different directory. I'd really like to understand what the recommended best practice is for a situation like this.

And I'd really like to know why my user account doesn't show up in the permission lists.

I can (Hopefully) do a system restore and get everything back to Trusted Installer although I haven't tried it yet, but it still leaves me with the problem of writing a temporary file in the System32 directory.

I'd be very grateful if anyone can direct me to a simple tutorial that explains how they intend windows 8 permissions to work and how I can get Trusted Installer and my own user account to show in the permission lists on the Security tabs.

Finally, I tried opening a command box and creating a simple text file in \Windows\system32. Access was denied. Then I used the "Run as Administrator" option by right clicking on the tile, did the same thing, and it worked OK. So it looks like I need to run my application as Administrator. (I thought I already was... confused? yeah, me too ) I tried right clicking the app tile for it and selected "Run as Administrator". The Desktop opens and then nothing happens.

Anyone got any thoughts on this?