Windows 8 and 8.1 Forums

Some Startups won't launch

  1. #1

    Posts : 93
    Windows 8.1 Pro 32-bit

    Some Startups won't launch

    I'm running Win 8 Pro 32-bit

    I want these three programs to load on Startup:
    Natural Reader

    I have tried putting Shortcuts to them in the Startup for "All Users," and just the "Current User," and both at the same time - and they still won't launch.

    I looked through this page:

    I thought maybe the way to go is to make them all Registry Startups, so I have all of my Startups here in the Registry now. I made REG_SZ's for the above three:

    * * * * * * * * * * * * * * * * * * * * * * * * * * * *


    Calendarscope . . . "C:\Program Files\Calendarscope\csde.exe"
    Natural Reader . . . "C:\Program Files\naturalsoft\naturalreader9\NaturalReader9.exe"
    PowerMenu . . . "C:\Program Files\PowerMenu\PowerMenu.exe"

    * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    In the Task Manager, they're all Enabled. Please see screen shots.

    . . . and they still won't launch . . .

    [Related: I see MSWheel in my Registry Startups, with no path. I think that should be ok to delete. How does something get in there with no path?]

    I right-clicked on the .exe's and gave them global compatibility for Win XP SP3 / Run as Administrator . . . and they still won't launch . . .

    I'm thinking that I need to make the Program folders compatibile now - that they won't launch due to some security setting - but there are a lot of settings in there, and before I go allowing Full Control by all Groups and User Names, I thought it might be a good idea for me to try and find out if this is what's causing it, or if it's something else.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * *
    * * * * * * * * * * * * * * * * * * * * * * * * * * * *
    * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    This is also related and useful to know, how to clear past notification icons:

    HKEY_CURRENT_USER \ Software \ Classes \ Local Settings \ Software \ Microsoft \ Windows \ CurrentVersion \ TrayNotify

    Delete both: IconStreams and PasteIconsStream

    Now hit Ctrl+Alt+Del to open Task Manager, and kill the explorer.exe process

    Once done, go to File > Run, enter explorer.exe and hit Enter, this will start explorer.exe again

    . . . but with Windows 8, you get a blue screen with nothing on it - do Ctrl+Alt+Del - a Restart gets you back.
    Attached Thumbnails Attached Thumbnails Registry Startups.jpg   Task Manager.jpg  

      My System SpecsSystem Spec

  2. #2

    Posts : 5
    Windows 8 (x64) Pro

    I have run into this also ... it probably has to do with the horrible permissions setup Windows 8 has (Microsoft is so good at stealing programs from others and incorporating them into their OS .. I have no idea why they haven't stolen the open source of Linux for its security).

    The only way I was able to get one of my programs to run when I started my machine was to create a task in Task Scheduler and make the trigger "At log on" for any user. This seems to be the only way to get the program to run when I log into my account.
      My System SpecsSystem Spec

  3. #3

    Posts : 93
    Windows 8.1 Pro 32-bit

    Thanks for the info! That does work.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    I tried the Task Scheduler Trigger at "At startup" / "At system startup" thinking that the programs would launch after a Restart - which would work great - but they didn't launch . . . (why?)

    I changed it to "At log on" / "At log on of any user" - and they did launch, after I Logged Off as follows:

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    I'm using Classic Shell 3.6.2 . . . under the Special Items tab, towards the bottom / [check] Show Log Off

    So now I can Log Off (Classic Shell) / Sign out (Metro) - and do a Restart from there, in which case, it will then launch the programs I have set for when I log back in.

    I will only have to do this, to save a few clicks, if I need to do a Restart - I use Standby most of the time.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    In the Task Scheduler / Actions / It won't let me point to a Shortcut, where I have it set in the Properties to open the program as Minimized. I'd like to do that with Calendarscope and Natural Reader.

    There is a field there where you can Add arguments (optional) . . . I typed in "Minimized" and it didn't do anything.

    Reading around, I see that you have to check with the software manufacturer, to see if you can use any Command Line arguments (like, to open the program Minimized) - I have to check into this.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    With the Registry shortcuts, I notice that the Command Line is usually in quotes, but not all of them are.

    I see that some of them have switches, such as:

    AVG User Interface: /TRAYONLY
    QuickTime Task: -atboottime
    Realtek HD Audio Manager: -s
    Logitech Webcam Software: -hide
    ROC something from AVG: / /PROMPT /CMPID=roc_ssl_v12

    I tried the first three switches above, with the three programs, with and without quotes, and they didn't do anything.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    I wonder why they don't make a wizard for this, for the programs you want to launch, so you can get things done.
      My System SpecsSystem Spec

  4. #4

    Posts : 5
    Windows 8 (x64) Pro

    Ok I'm a bit confused .. I never used Classic Shell .. but .. as for the setting up of the task .. its kinda crazy .. this is how I got "SpeedFan" to launch:

    First in the general tab under security opstions i have it set to run under the account Administrators (not administrator but administrators.. plural) then I have it set "run only when user is logged on" then also i have checked Run with highest privilages and configured to run with windows vista , windows server 2008.

    Under Triggers:
    I have selected any users at the top .. and enabled at the bottom .. everything else i just left alone
    Under Actions:
    I have the action set to "Start a program" and under the program/script I have the full path to the program

    ** now when it comes to with or without quotes ... windows doesnt like spaces in a path so if your path has spaces like Program Files .. the path should be in quotes to be safe for example C:\temp\executable.exe ... no real need for quotes .. but C:\Program Files\executable.exe may not run properly unless its entered as "C:\Program Files\executable.exe" because of the space .. without the space it may be trying to find it at C:\program. ***

    the add arguments ... in your examples .. you would add the exact argument as listed .. so if its /TRAYONLY... then you would enter /TRAYONLY .. if its -atboottime then it would be -atboottime the start in section is not really necessary but if you wanted too .. you put in the full path without the exe file ... and if it has spaces in the path you would also want to put it in quotes. but again that shouldnt be necessary to put in the Start in option.

    The Conditions tab:
    Basically this is up to you .. I have it only start when comptuer is on ac power .. but then again ... its a desktop so its always on ac power.

    the Settings Tab:
    I have all checked but stop task if it runs longer than: because i dont want this task to stop
    and if task is not scheduled to run again delete it after: .. because i dont want the task deleted
    I also have it set Do not start a new instance because i dont want two of these running at the same time.

    I did set the If task fails restart every: to one minute and 3 times to try again.

    History tab:
    dont worry about it

    With those settings it should start up at login but not sure with the classic shell thing

    The problem with at startup and at system startup is .. i believe those settings are set to start up before the OS is fully booted and most programs wont run without windows actually running ... i believe those settings would be used if you .. say .. wanted to delete files before windows fully boots so the files arent in use by windows and can be deleted.. but thats an assumption on my part.

    and the problem i think you may have had with the "at login" may have also been permission issues .. which is why i have the general tab to run the process as the administrators group with highest privileges.

    Oh yeah, as for the running minimized .. yeah .. there has to be a switch programed in by the manufacturer or a setting in the program itself .. i dont think there is a universal switch for that... the only thing i can suggest it try to get it running with the settings i have mentioned .. if it runs but doesnt minimize ... we know your settings are right .. i have never tried it but you can try making a shortcut in the exe's directory and then set up the action to the full path to the shortcut .. which would be executible.lnk ( LNK) so if the exe was speedfan.exe ... and you made a shortcut in the same folder of course you would have to rename it to remove the "shortcut to" thing that windows adds on ..and save it .. so to you in windows exploerer it would look like just speedfan with no extension ... but in the actions section of the task you would put speedfan.lnk .. then you can open the shortcuts properties and change whre it says Run: Normal Window to Run: Minimized. Again .. not sure if a link will launch in a task like that .. haven't tried .. which is why i suggest you get the task working with the exe first before you attempt the link (LNK) setup. (hopefully this isnt too confusing)

    I hope this more detailed setup of the task will help you.
      My System SpecsSystem Spec

  5. #5

    Posts : 5
    Windows 8 (x64) Pro

    i just tested a link to see how it would work .. using a command prompt .. i tried a link i have on my desktop... the link is called device doctor ... when i entered device doctor it gave me an error cant find device ... so the space thing is a problem .. so when i tried "device doctor" .. it also failed ... but when i tried "device doctor.lnk" it launched .. so if you are having problems with launching a shortcut .. make sure you have the full path and shortcut name and if there are any spaces in the path or shortcut .. make sure it is in quotes.
    you can try this for yourself to find out what command will actually launch your own link .. just go to a command prompt and try putting the full path to the shortcut .. the full name of the shortcut and the .lnk at the end .. it should launch and if it doesn't it may give you some indication as to why its not.
      My System SpecsSystem Spec

  6. #6

    Posts : 93
    Windows 8.1 Pro 32-bit

    In Folder Options, I never have it checked to "Hide extensions for known file types," but I see now that it has always hidden the .lnk extension, because I'm not familiar with it, I have never associated that with a Shortcut. Before, I thought a Shortcut is always just the name of the file, with its extension, like .pdf, and it just says "Shortcut" in the Type column . . .

    I have replaced what I had, a path to the .exe under the Actions tab, with the following:


    These Shortcuts appear in my Start menu.

    When I tried launching these Shortcuts before, I know I left off the .lnk extension. I'm not sure about the quotes. I might have left those on, I see that it puts them on for you. They're probably not needed in this case as you say, since there are no spaces.

    I notice that if I go to put a link back to the .exe, it automatically adds quotes. If I remove the quotes, it gives a warning message - If I say ok to that, it puts part of the path in the Add Arguments field.

    I just logged out and Restarted to see if it launched the .lnk files - unfortunately, it did not. I got the attached dialogue box asking how I wanted to open .lnk files.

    Also attached is a screenshot of what it looks like in the Task Scheduler.

    I'll put back a path to the .exe for now - they launch, after logging out / in / or after a Restart - just not minimized - and see if there's a program that can "make" your Startups. All I see right now are programs that tell you what *is* Starting up:

    Thanks again for the info!
    Attached Thumbnails Attached Thumbnails Shortcut LNK.jpg   LNK as Action.jpg  
      My System SpecsSystem Spec

  7. #7

    Posts : 5
    Windows 8 (x64) Pro

    yeah i wasnt sure if a task could launch a link. I guess not .. not sure what program they should be associated with. try opening a command prompt and typing in
    "C:\ProgramData\Microsoft\Windows\StartMenu\Calendarscope.lnk" and see if it launches or gives you the open with box again .. if it gives you the open with box .... there may be an issue with your setup ... or you might have missed a space .. I just looked at my setup and my startmenu is actually at C:\ProgramData\Microsoft\Windows\Start Menu\Programs .. there is a space between Start and Menu if I run C:\ProgramData\Microsoft\Windows\Start Menu\Programs\TeamViewer 7.lnk" in an admin command prompt (lower left hand corner when start image pops up right click and choose command prompt (admin)) it fails but if I go to the TeamViewer install directory and create a shortcut and name it TeamViewer then go to the command prompt and type "D:\Online\TeamViewer\Version7\TeamViewer.lnk" it launches ...

    I believe this has to do with paths... when you call the link from the start menu directory it looks for the exe in the start menu folder. You may have to make a shortcut in the exe's directory ... or possibly this is where the Start in. section comes into effect .. you would have to tell it to start in the exe's directory even tho you are calling the link from the start up folder.

    Windows is very picky.

    Basically to make it easy on you ... create a shortcut in the install directory of the exe... (where you can see the actual exe that launches the program" rename the shortcut to test. Then launch a admin command prompt and type in quotes the "path to the exe's install folder/test.LNK" if there are any switches after they need to be outside of the quotes .. like "C:\Test.exe" -workthistime ... if it doesnt warn you about associating lnk files .. then you may be able to get it to work

    basically .. putting quotes all the time wont hurt you as long as you only put the path and exe in the quotes not any switches.
    I looked around .. unfortunately i haven't figured out where to see what files are associated with what like you used to be able to see in the "Folder Options" so I couldn't see if or what my lnk files are associated with...

    If none of this works and you cant get links to work with scheduler ... (like i said before .. im not really sure its possible) but you can get them to work with the exe just not minimize ... you could always use a program like TrayIt which will look for the window title and minimize it on creation. Its a very small and free program that I have used in the past with very good results.

    Well .. Good luck... I'm out of ideas now... lol ... Windows 8 is a nightmare ... I'm starting to see a major pattern with Windows ... Windows 98 Good... Windows ME Horrible ... Windows XP Good .... Windows Vista Horrible.... Windows 7 Good ... Windows 8 HORRIBLE .. lol maybe we will have to wait for Windows 9 to be Good again .. lol
      My System SpecsSystem Spec

  8. #8

    Posts : 5
    Windows 8 (x64) Pro

    added example of an autoit script to launch a program

    lol .. hmm .. just checked trayit in 8 ... it works .. and actually sorry it minimizes to the tray instead of the taskbar so it may not be what you actually want. It also seems a bit buggy in 8 leaving icons in the tray after closing the program until you actually kill the TrayIt process

    You may look into AutoIt its a scripting program also free but you can set it to minimize windows and create exe's out of the scripts .. maybe an autoit created exe can be launched in the start up .. or with a task .. and you can set it to run the programs you want and make them launch minimized ... I have used autoit in 8 and it does work well .. I have several scripts to ban people from my website that have been caught doing malicious activities

    AutoIt is very powerful if you know what you are doing but also not real difficult to do a simple task like you want .. launching a program in a minimized window.

    I suggest you get both AutoIt and scite (autoit editor) which will make editing scripts easier ... if you arent sure how to use a command you can click on it in the script and hit F1 and it will open the autoit help file to the command you are trying to use and explain how it has to be formated. For example if you are trying to start a program the command is Run .. if you open an autoit script and in the first line you type Run and then click on the word run so your cursor is in the word Run and press F1 it will launch autoit help to the Run command and tell you the format as well as usually an example or two.

    Here is an example of a autoit script that will open a program minimized.
    Run ("D:\Utilities\Autoit3\Au3Info.exe", "", @SW_MINIMIZE)
    (save file with an .au3 extension or autoit help wont work as i explained above) Once you have your run command you can go to the scite tools menu and compile it into an exe that may be able to be launched in startup or in a task

    Ok .. lol .. you should be able to do something with all this information to get your programs to cooperate with you Good luck again
    Last edited by JohnOrion; 14 Nov 2012 at 22:55.
      My System SpecsSystem Spec

  9. #9

    Posts : 93
    Windows 8.1 Pro 32-bit

    I ran these Shortcuts from the Task Scheduler, and got a similar, but slightly different window asking how it should open them (attached):

    "C:\Program Files\Calendarscope\csde.exe-S.lnk"
    . . . Shortcut tab / Minimized . . . Shortcut tab / Advanced / Run as Administrator (then it opens Minimized)

    "C:\Program Files\naturalsoft\naturalreader9\NaturalReader9.exe-S.lnk"
    . . . Shortcut tab / Minimized . . . Shortcut tab / Advanced / Run as Administrator (then it opens Minimized)

    "C:\Program Files\PowerMenu\PowerMenu.exe-S.lnk"
    . . . Shortcut tab / Minimized . . . Shortcut tab / Advanced / Run as Administrator (then it opens Minimized)
    It automatically runs Minimized though

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    So I deleted them, and just put back the path to the .exe's

    Then I realized:

    Calendarscope - within the program
    Tools / Options / General tab / [un-check] Load program on startup, where it's set to Startup in the Last opened view, and [un-check] Show main window on startup

    Window Manager - a program I recently installed
    The default setting is to put your windows in the same location and size that you last had them - I un-checked this for Calendarscope and Natural Reader

    PowerMenu is just an icon that sits in the Tray

    So now it's working! Just log off and log on - it does exactly what you want it to do.

    In the .exe's, there is no setting to have them open as Minimized, like in the Shortcut. It looks like they automatically do this. Calendarscope goes to the Tray as an icon. Natural Reader minimizes from a window to what's called the MinBar.
    Attached Thumbnails Attached Thumbnails LNK - how to open.jpg  
      My System SpecsSystem Spec

  10. #10

    Posts : 93
    Windows 8.1 Pro 32-bit

    .bat hoses Win 8, requires you to re-install all programs

    In Win XP, I had this bat file run once a month at 1 am, to do Defrag and Check Disk on my two hard drives, starting at 1 am:

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    C:\WINDOWS\system32\defrag.exe c: -v>"c:\Documents and Settings\Administrator\Desktop\defrag c.txt"
    C:\WINDOWS\system32\defrag.exe d: -v>"c:\Documents and Settings\Administrator\Desktop\defrag d.txt"



    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    I put a Shortcut to it in the Win 8 Task Scheduler. I think it was set to run at Logon, but I did not specify a time, and didn't think it would do anything.

    I had not given the Scheduled Task a password, either, which I know it needed to run in XP.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    To my horror, I powered on the computer from a Shutdown and saw a black screen with the messages:

    Preparing Automatic Repair
    Diagnosing your PC
    Scanning and Repairing Drive D:

    . . . it got stuck at 27% - I powered off the computer after 30 minutes

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    The computer had two User Accounts. Both were Administrator, and one had a password on it.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    I could not get to the desktop - not even into Safe Mode

    I put in the Win 8 CD - and somehow that got me back to a Restore Point, the first one before any of the software I installed - so I lost 6 to 9 hours of work.

    I think this problem occurred from the Scheduled Task I made.

    I did a full re-install, and have left out the Defrag and Check Disk bat file. Win 8 runs great now.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    The system only has one User account - set as Administrator, with no password.

    Power Menu and Calendarscope load up on their own, to my surprise, without any work on my part.

    I had to put a Shortcut to Natural Reader in my Startup, but it loads up by itself now, too, where it didn't before.

    * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

    Only having one User Account seems to make this possible. With two User Accounts, then you have to use Log Off / Log On, and have the Task Scheduler launch your Startups.

    I see, also, that in Win 8, it doesn't take very long to run a Check Disk manually - once a month, I like to see if there are any Bad Sectors on the disk.

    I see, also, that Win 8 automatically Defrags itself weekly, too, so now I don't have to worry about that either.
    Last edited by mb1280; 23 Nov 2012 at 16:13. Reason: typo and edit
      My System SpecsSystem Spec

Some Startups won't launch
Related Threads
Make Startups Minimized after Boot in Performance & Maintenance
Why doesn't this work for Thunderbird and SyncBackFree? Is there another way? - - - - - - - - - - - - - - - - - - - - - Mozilla Thunderbird . . . ...
Solved I Can't Launch My Apps in Software and Apps
I click on them but they won't launch. A blank grey screen appears after trying to launch them. Words near the bottom of tile say "Microsoft.WindowsLive.Mail", "Microsoft.WindowsLive.Calendar" and "Microsoft.WindowsLive.People".
(edit: solved. For whatever reason the SSD didn't have an EFI partition and Win8 wasn't installed on a GPT partition... So it didn't show up as bootable UEFI device) Hey :), Been fiddling around with it now for one day but didn't get it running. Guess I need some help... :(
Hi there, my computer is a Acer touchscreen all in one desktop. It was just recently bought last December so less then a year old. Just recently, I would say in the last few weeks, it has started having the issue of being stuck on shutdown to where to shut it down I have to force the shutdown. Also...
Read more at: AMD to launch its first ARM chip | Business Tech - CNET News
Hello! My machine gets various BSOD messages on the first few startups each day. Sometimes it does an automatic restore, sometimes it just starts after several BSOD and is fine. Then, I have no issues for the rest of the day. This reoccurs after a long shut down. I have attached my SF files as...
Solved AutoPlay does not launch in General Support
When I insert a memory card or thumb drive I expect autoplay to launch, but it doesn't. Working on desktop, when I right click the drive in File Explorer, I can open AutoPlay and select an action. But after doing so, then removing and reinserting the card or drive, nothing happens. Any...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook