Windows 8 and 8.1 Forums


metro apps stuck splash screen - I can force them to work kinda

  1. #1


    Posts : 3
    Windows 8

    metro apps stuck splash screen - I can force them to work kinda


    Hey all,
    So i'm having this weird problem. None of the stock metro app will work on my system (weather, news etc')
    It will just get stuck on splash screen. It worked a few days ago. Started reading about it on the forum and this is what I've done so far:

    1. I don't have Avast or any antivirus installed yet.
    2. Tried refreshing Windows, I'm getting an error saying Windows couldn't refresh and no changes were made.
    3. Uac is on default
    4. Windows Firewall service is set to be Running and Automatic


    Annoyed and tired I added another language to windows that will change the display UI etc', I added Hebrew, resarted my machine and the metro apps now WORKS but, in Hebrew. Switched back to english, metro apps doesn't work. Tried adding other types of English (Canada etc') still no go.

    My stock Metro apps will work only in Hebrew display mode.

    Any help would be great.

      My System SpecsSystem Spec

  2. #2


    Posts : 3
    Windows 8


    Bump
      My System SpecsSystem Spec

  3. #3


    Posts : 534
    Windows 7, Windows 8 RP


    Did you try to uninstall one of the Apps and re-install?
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Windows 8


    Yes
      My System SpecsSystem Spec

  5. #5


    Posts : 61
    Windows 8 Pro


    Anyone heard any news, or new fixes or ideas on the APP problem?
      My System SpecsSystem Spec

metro apps stuck splash screen - I can force them to work kinda
Related Threads
Sometimes when I toggle from the classic desktop to the metro desktop using the Win key there is no way for me to get back to the classic desktop - basically it gets stuck (nothing wrong with my keyboard - I've duplicated this using two keyboards). Whenever this happens, I can see the little...
Win2Go stuck on splash screen in Installation & Setup
Hi everyone, i created various flashdrives with win to go 8.1. i did it manually (diskpart, etc),i used WinToUSB,i used AOMEI Partition Assistant, all in all i have used 4 drives. 2 x USB3,2 x USB2. In all cases the results were the same, no matter on which machine i use it ... Windows seems...
First I was having this issue: 45587 I followed a fix that involved: 1. Press "Windows key + R". 2. Type wsreset.exe and click OK. I did that and the splash screen came up. I then waited past the suggested 15 mins and then I got this error:
Hello, I'd like to know if any of you guys have experienced this issue where when you try to open a metro app you get the splash screen for it and then just a few seconds later you're sent back to the start screen with no explanation whatsoever. It's doing my head in since I can't seem to find ...
(atleast those of you running intel-chipsets) Updating my intel RAID driver fixed the issue where I was stuck at the splash screen after the first reboot during initial installation (upgrading directly from Win 7 without loss of files) Download the third link (iata_enu.exe - version...
Hello. when I just installed windows 8, I could run the Windows Store, Bing search and more. now, when I run metro apps, the Logo moves from the center to the top left corner. have these "dots of loading" moving. but nothing happens. after installing windows 8. and saw that this worked. I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook