Windows 8 and 8.1 Forums


app dumping me back to the start screen?

  1. #1


    Posts : 1,127
    Windows 8.1 Pro

    Xbox Music app crashing / dumping me back to the start screen?


    alright, I'm getting a little frustrated here. I've noticed this mostly for Xbox Music but also for a couple other apps.


    here's a sample video.

    I tried loading the Netflix app and it appears to try to load for awhile, unsuccessfully, and then it dumps me back to the start screen. So I check the apps list and it's still running. But when I select it again, it does the same.

    I then play with Xbox Music. music is playing. I then went to search for a specific artist and try to play the song. it dumps me back to the start screen. the music is no longer playing. the app appears to be running (as seen in the apps list). if I play a song that was added to my music library or if I play an MP3 off the hard drive, there's no issue. but sometimes when i'm browsing for songs and selecting them to play, it'll dump me back to the desktop.

    I've had this happen on a totally separate system with various apps where I get dumped back to the start screen.

    what am I doing wrong here? at first, I thought it was the focus being shifted. like there was a time the other day when I did a cold boot. and after the start screen appeared, the black command prompt/dos window popped up which shifted me from the start screen to the desktop. of course, the command prompt window only popped up for a split second. but I was sitting at the desktop thereafter. But I think it's not a focus issue as the music should still be playing even if something is pulling me from the app back to the start screen.
    Last edited by dirtyvu; 03 Nov 2012 at 23:17.

      My System SpecsSystem Spec

  2. #2


    Posts : 1,127
    Windows 8.1 Pro


    I updated my error with a sample video.
      My System SpecsSystem Spec

  3. #3


    Posts : 1,127
    Windows 8.1 Pro

    solution to metro app problems: it's the ATI/AMD driver!!!


    alright! I think I found the solution!

    recap of the problem: metro apps having difficulty streaming or crashing back to the start screen. a lot of these problems were random. so I was having problems with Skype, Netflix, iHeartRadio, Xbox Music, TuneIn Radio, etc.

    it turns out to be the AMD Catalyst 12.6 Legacy Driver for Windows 8!!! Something with the driver is causing the problem! I uninstalled the driver and the entire Catalyst suite and rebooted. The ATI/AMD driver that comes with Windows 8 replaced the 12.6 version and every application started working again!

    You can install the rest of the Catalyst suite again with a custom install as long as you DO NOT INSTALL THE DRIVER! Leave the Windows 8 driver for these legacy ATI graphics.

    I have an ATI HD4670 graphics card.

    I won't take credit for discovering this. I found it from this link:
    Windows 8 Apps (Netflix, Hulu, Youtube, TuneIn) will not - Microsoft Community
    Last edited by dirtyvu; 05 Nov 2012 at 20:52.
      My System SpecsSystem Spec

  4. #4


    Posts : 7
    Windows 8


    So I'm glad you narrowed down the problem to AMD drivers (which makes sense because I recently installed the drivers in question). But I'm wondering if this is creating new problems?

    When I originally upgraded to Windows 8, it automatically installed the Windows 8 driver. I had it this way for about a week but I noticed that I was having video performance issues. Especially in streaming HD video viewed through websites (like Youtube, movie trailers, etc). Some, but not all HD video was extremely stuttery and unwatchable. That's when I started digging into which video drivers I had installed. I completely removed all the old AMD drivers that were still lingering around from Windows 7 and the Windows 8 driver that auto-installed when I upgraded and then installed the AMD Catalyst 12.6 Legacy Driver for Windows 8. Now my video performance is buttery smooth, but now I'm having the same problem you had with Xbox Music and other apps.

    Are you experiencing any video performance issues now that you've "downgraded" the driver?
      My System SpecsSystem Spec

  5. #5


    Posts : 1,127
    Windows 8.1 Pro


    I didn't upgrade Windows 7 to Windows 8. I did a fresh install.

    So far, I haven't noticed any problems with the default ATI Windows 8 driver. I even reinstalled the catalyst from the legacy driver suite (minus the driver of course) and it all appears to be working now and smoothly.

    I don't know what graphics card you have so I'm not sure if we're using the same driver.

    Mine now (the default Windows 8 driver) is ATI Radeon HD 4600 series (Microsoft Corporation - WDDM v1.1)
    driver date: 6/19/2012
    driver version: 8.97.10.6
      My System SpecsSystem Spec

  6. #6


    Posts : 7
    Windows 8


    I'll give the driver a shot again. I have an ATI Radeon HD 4800 series card. I wonder if my old Windows 7 drivers were causing the problem. I'll uninstall all the ATI stuff again, have Windows install the Microsoft driver, reinstall the ATI stuff minus the driver and see how it goes.
      My System SpecsSystem Spec

  7. #7


    Posts : 7
    Windows 8


    So I rolled back the driver to the default windows driver and all the apps work fine now. But the stuttery video came back, but I figured some out about that in the process. The video is only stuttery with videos imbedded in websites when viewing in IE10. If I view the same video in Chrome, it runs fine. So I may just have to deal with it for a bit until ATI comes up with a better driver. And to clarify, it's not all imbedded videos, just some of them. Like the ones at www.movie-list.com where I view most of my movie trailers. But youtube videos run fine. And again, the AMD Catalyst 12.6 Legacy Driver for Windows 8 did make the video run smoothly, but it's not worth the tradeoff for now. Haven't tried any games yet to see if there are any problems running games with the default Windows driver. Thanks again for posting the solution.
      My System SpecsSystem Spec

  8. #8


    Posts : 1,127
    Windows 8.1 Pro


    this problem drove me crazy. so i'm glad that at least for the both of us, the problem is gone. hopefully it helps others!
      My System SpecsSystem Spec

app dumping me back to the start screen?
Related Threads
My first real problem with win 8.1. Problem Defined. I have a shortcut on my desktop. The same shortcut key on my desktop task bar. The shortcut when activated loads the windows 8.1 start screen where my tiles are. The default DPI in this windows 8.1 is 125%. I changed the resolution to...
I know how to dump or acquire login password hashes from the SAM/System hives. What I'd like to dump are hashes from the startup password that's set when a user runs Syskey from within Win 7/8, as referenced at SysKey - Set Startup Password to Lock or Unlock Windows - Windows 7 Help Forums. I...
I got a new computer with Windows 8. I put the Classic Shell on. It skips the worthless Metro interface and goes right to the desktop. Some observations. The Aero Glass interface is gone. Some guy has come up with a work around but I am a little jumpy about trying that. The "new look" 8...
Hi how do i get back the start menu instead of the start screen, and I want to disable the start screen. help thanks :D andrea
I upgraded from Windows 7 to Windows 8 Pro. Everytime or almost everytime I click on an app or go to the desktop and try to get on IE 10 (desktop version), my screen flashes and goes black for a few seconds then returns me to the screen with the space needle, then I click on it and it signs me...
Hi, I have successfully managed to upgrade, add a shutdown tile on the start screen, add a classic start on the desktop screen and get the right tiles on my desktop and remove the initial screen. I have a usable OS on my laptop again and it may sound strange but I like both interfaces and use...
So as the title says, during the installation process it says that windows needs to restart. It does this and then I am right back to the first install window which asks me which language and keyboard layout I want. Basically it starts the install all over again. The only things I changed (got this...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook