Windows 8 and 8.1 Forums

BCDEDIT Command Fails?

  1. #1

    Posts : 275
    Windows 8.1 64 bit

    BCDEDIT Command Fails?

    Over at Ten Forums I'm trying to fix a 1 year old Dell laptop running Windows 8.1 Home which fails to upgrade to Windows 10.

    One person reported that when running the command bcdedit /export <file> it fails with the error message "The store export operation has failed. The handle is invalid" Windows 10 installed when this problem was fixed but the solution posted is unclear.

    I get the same bcdedit error message. Hopefully Windows 10 might install if I can fix it. What steps can I take to repair my Windows 8.1 boot configuration without screwing up the PC? Note the PC boots fine and bcdedit /enum reports the correct details as shown below.

    Windows Boot Manager
    identifier {bootmgr}
    device partition=\Device\HarddiskVolume1
    path \EFI\Microsoft\Boot\bootmgfw.efi
    description Windows Boot Manager
    locale en-GB
    inherit {globalsettings}
    integrityservices Enable
    default {current}
    resumeobject {c75b21b1-d062-11e3-a912-b82a729fff82}
    displayorder {current}
    toolsdisplayorder {memdiag}
    timeout 2

    Windows Boot Loader
    identifier {current}
    device partition=C:
    path \WINDOWS\system32\winload.efi
    description Windows 8.1
    locale en-GB
    inherit {bootloadersettings}
    recoverysequence {c75b21b5-d062-11e3-a912-b82a729fff82}
    integrityservices Enable
    recoveryenabled Yes
    isolatedcontext Yes
    allowedinmemorysettings 0x15000075
    osdevice partition=C:
    systemroot \WINDOWS
    resumeobject {c75b21b1-d062-11e3-a912-b82a729fff82}
    nx OptIn
    bootmenupolicy Standard

      My System SpecsSystem Spec

  2. #2

    Posts : 2,690
    Windows 3.1 > Windows 10

    your system has but one bootable OS.. Windows 8.1

    so what are you trying to do ??

    The BCD should have NO EFFECT on preforming an upgrade
      My System SpecsSystem Spec

  3. #3

    Posts : 275
    Windows 8.1 64 bit

    In my original post someone else who had this error was able to install Windows 10 once the error was corrected. So I'm trying to ensure my boot configuration is correct to enable me to overcome the same error and hopefully be able to install Windows 10. I've listed the repair process below based on 'googling' the issue. There are some options - pleas advise the best approach:

    1. Boot from Windows 8 CD (presumably in UEFI mode with secure boot off?)
    2. Goto command prompt option
    3. Run DISKPART and select the EFI volume
    4. Assign letter z: to the EFI volume
    5. cd /d z:\efi\microsoft\boot
    6. attrib z:\efi\microsoft\boot\bcd -h -r -s
    7. ren z:\efi\micr bcd.old\microsoft\boot\bcd bcd.old

    8. Optional step: bootrec/fixboot (is this needed?)

    There are then 2 repair options which is most appropriate?:

    9a. bootrec /rebuildbcd


    9b. bcdboot c:\windows /l en-gb /s z: /f (for UK)
    Last edited by Steve C; 01 Dec 2015 at 05:54.
      My System SpecsSystem Spec

BCDEDIT Command Fails?
Related Threads
Correct path for Recovery in BCDedit in Installation & Setup
Hi everyone, I have HP250 (without CD/DVD ROM). Windows 8.1 OS. I need help to "recover" my HP Recovery Manager and I am on finish line! ... i hope recently i've parted my hard with EasyUS(damn it). Right after i couldn't use Recovery manager. Thanks this Forum, especially to SIW2 and KYHI....
Solved DISM Command Fails in Performance & Maintenance
I ran SFC /SCANNOW after a recent PC crash. This found some files it couldn't fix so I tried to run DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH which has previously worked. I now get the error shown below referring to "The source files could not be downloaded". I don't know what's changed but how do...
I have been using the instruction from "Safe Mode - Add to Windows Boot Manager in Windows 8" for a very long time to give me that extra chance to get into Safe Mode if Normal Mode is having problems. All of the Windows 8/8.1 PCs at our site are set up that way. Just got a Lenovo Flex 2-15 with...
I’m pretty much stuck at this point. So, backstory: Windows was installed on one of the SSDs currently in my tower. I bought a new SSD to install Windows (8.1 64 bit) on. Windows installation went fine, booted up, and formatted the old SSD from within Windows (this seems to have been a mistake,...
I need to run bcdedit on my Windows 8 To Go installation, but I'm not sure how to do that. Any assistance would be greatly appreciated. Thanks!
First let me give you some background information. My SSD had 3 partitions in this order; System Reserved, Win7 and Win8. I deleted the Win7 partition and used “msconfig” to remove Win7 from the Boot tab, without selecting the “make options permanent” option.(I thought I read somewhere to be...
In detail, I had Win7 installed, I got Win8, but since I dont have a CD-ROM, i managed to install it by doing this: 1 Create a partition, NTFS, and set as the ACTIVE partition 2. Put all the Win8 files on that partition 3. Opened Command prompt and typed boosect /n60 I restarted and the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook