Windows 8 and 8.1 Forums


Newly restored Windows 8.1 64 bit w/ high CPU / RAM usage

  1. #1


    Posts : 1
    Windows 8.1

    Newly restored Windows 8.1 64 bit w/ high CPU / RAM usage


    I have a Toshiba Satellite laptop that's only a couple years old. It came pre-installed with Windows 8. After I upgraded to Windows 8.1 it started having difficulties in certain areas, mainly the File History. It wasn't anything too troublesome, so after a while I let it go. I upgraded to Windows 10 and things got hanky. Everything started moving S-L-O-W. EVERYTHING. CPU usage was often at 98-99% and Memory was up there as well. I eventually restored it back to factory defaults, however that did not correct the issue. As of today, I cannot connect the machine to the internet.

    I've noticed that there is a csrss.exe running on Services as well as Console. I've also found that there is a csrss.exe.mui tucked away in there somewhere. Likewise there's a csrss.exe.mui in the old windows files (which I'm not able to delete for some odd reason). I'm not sure if that's my problem or not, but most everything I find online indicates I need to download some program in order to locate any potential Trojan or other viruses / malware. Without having access to the internet on that PC, it's proving difficult to isolate the cause of my issue.

    Can someone give me some command prompts or search suggestions?

    Oh, FYI the system has a 500GB HD and 4GB RAM, however that was never an issue before... and, considering it's been restored to factory defaults, I'd assume it shouldn't have any now.

      My System SpecsSystem Spec

  2. #2



    BSOD Kernel Dump Analyst
    Posts : 2,274
    Windows 10 Pro


    Hi NoviceTech,

    Welcome to the 8forums.

    Please make a screenshot of the CPU and memory usage of taskmanager and post it so we can identify what is taking the resources.
      My System SpecsSystem Spec

Newly restored Windows 8.1 64 bit w/ high CPU / RAM usage
Related Threads
This suddenly happened one day, my memory usage is currently over 65% with nothing open, I have 8gb of DDR3 Ram. Here's a picture of the task manager.62346 And here are a couple pictures from RAMMAP 62347 62348 There are 5GB of RAM being used by something and I can't tell what it is. Would...
High RAM Usage (Spotify high) in Performance & Maintenance
First off I have 8GB of RAM, and I get notifications all the time that my RAM is high, and it wants to close programs. The main program that worries me the most is Spotify is using 900MB of RAM when playing and 500MB when not playing. Why is this so high? The games I play are not even that high....
I am having problems with my memory it has jumped to 89% and stays there. I tried to restart i looked at the processes it seems that non-paged tools is taking the most. I used RamMAP tool to find this problem. 468584685946860...im still having problems, please help.
Solved Windows 8.1 High Memory usage from startup in Performance & Maintenance
Hello, I found many forums with this issue but none really gave a decent solution. I have a new laptop windows 8.1 (64bit) 8gb RAM i7 processor which should be sufficient for the software I use. however on start-up my memory is already at around 80% and stays like that. The most seems to...
Need Help With High Disk Usage! Windows 8 in Performance & Maintenance
Hi, I am playing a game getting great FPS Then it just quits.. I checked the disk usage and it's at 100%! What should I do? I am only playing that one game and nothing else! I have 8 gigabytes of ram.. PLEASE HELP ME!
Windows 8 High usage CPU/Memory and disk in Performance & Maintenance
i have high usage on my laptop lenovo g580 using windows 8. check task manager and i see cpu memory and disk fluxuating up and down to 3% can go up to 100 at times. when i open google chrome. watch video or play games. i hear my fan turn on and i think my hardrive and i check task manager and i see...
Very high disk usage [Windows 8 Pro 64-bit] in Performance & Maintenance
Hello, Over the past couple of weeks I have been getting high disk usage on my computer, causing it to run extremely slowly. Is there any way to fix this issue? Just after I took the attached screenshot, my System went down to around 6MB/s and the "Service Host: Local System (Network...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook