Windows 8 and 8.1 Forums

Properly formatted DISM command incorrectly parsed

  1. #1

    Posts : 100
    Windows 8.1, 10, various Linux

    Properly formatted DISM command incorrectly parsed

    When I execute a DISM command in an administrator-level command window, the command line is being incorrectly parsed by either DISM, an API it calls, or by CBS, or an API CBS calls. This causes an "invalid path"-type error after the argument to "/Source:" argument is incorrectly parsed.

    From this post: DISM - Fixing Component Store Corruption in Windows 8

    here are some extracts of what I typed:

    dism  /Online /Cleanup-Image /RestoreHealth /Source:esd:G:\sources\install.esd:1 /limitaccess
    what DISM said I typed:

    ...DISM.EXE: Executing command line: Dism  /Online /Cleanup-Image /RestoreHealth /Source:esd:G:\sources\install.esd:1 /limitaccess
    and what CBS says it got as the path:

    ...CBS    Exec: Addsource called, Session: 30466707_885613462, Client: DISM Package Manager Provider, from GPO: No, Path: C:\WINDOWS\system32\esd:G:\sources\install.esd:1
    Note that the path CBS has is simply an incorrectly parsed "/Source:" argument with my current directory tacked on the front.

    What went wrong here? How can ANYONE use that "/Source:" argument to DISM and have it succeed (since I'm doing nothing interesting at all other than invoking a CMD command).

    And how to fix this?

      My System SpecsSystem Spec

  2. #2

    Posts : 2,690
    Windows 3.1 > Windows 10

    dism /Online /Cleanup-Image /RestoreHealth /Source:G:\sources\install.esd:1 /limitaccess

    try the above - removing the esd: - although I believe it to will fail
    as the reference to /source:wim:
    is in regards to server location
    and I still have not found reference to /source:esd:
      My System SpecsSystem Spec

  3. #3

    Posts : 100
    Windows 8.1, 10, various Linux

    Quote Originally Posted by KYHI View Post
    dism /Online /Cleanup-Image /RestoreHealth /Source:G:\sources\install.esd:1 /limitaccess

    try the above - removing the esd: - although I believe it to will fail
    Though I didn't mention it in this post, I did indeed try some variations, all of which failed identically.

    What I was planning to do next was to completely ignore the hints to DISM about the type of file (the "esd:" and ":1" substrings) and make sure I actually was in the directory with the "sources" subdirectory - that way any tacking on of my "current" directory would be correct AND there wouldn't be any strangeness with "esd:" getting injected into the pathname. Something like this (where the ISO file is mounted as "g:"):

    dism  /Online /Cleanup-Image /RestoreHealth /Source:sources\install.esd /limitaccess
    I do not remember where I read it - probably at least a couple different locations maybe even including something on eightforums - but the gist of what I read was that "install.esd" is equal to OR maybe even the replacement for "install.wim" and could be used with the DISM "/Source:" argument.

    Certainly using the "esd" strings caused no complaint at all from DISM so I assume it accepted it just fine, though maybe it simply passed along the string to some other library/application that totally choked on it. That is the gist of the questions behind this thread - how is this error happening to ME when many others have apparently used this exact same argument format and it's worked fine?

    Anyway, I'll probably be trying that out "soon" and will post a followup whether success or failure.


    Post-post edit:

    I just tried this with the displayed results - DISM accepted an ".esd" file as if it were a ".wim" file:

    G:\sources>dism /Get-WimInfo /WimFile:install.esd /index:1
    Deployment Image Servicing and Management tool
    Version: 6.3.9600.17483
    Details for image : install.esd
    Index : 1
    Name : Windows 8.1 Pro
    Description : Windows 8.1 Pro
    Size : 13,185,962,705 bytes
    WIM Bootable : No
    Architecture : x64
    Hal : acpiapic
    Version : 6.3.9600
    ServicePack Build : 17415
    ServicePack Level : 0
    Edition : Professional
    Installation : Client
    ProductType : WinNT
    ProductSuite : Terminal Server
    System Root : WINDOWS
    Directories : 18805
    Files : 104794
    Created : 11/21/2014 - 1:07:26 PM
    Modified : 8/28/2015 - 8:34:32 PM
    Languages :
            en-US (Default)
    The operation completed successfully.
    Last edited by brokensoftware; 31 Aug 2015 at 13:39.
      My System SpecsSystem Spec

  4. #4

    Posts : 2,690
    Windows 3.1 > Windows 10

    I use a mounted install.wim or install.esd as the repair /source

    to use the install.esd it is first exported to an install.wim, then mounted

    Image_Health is a script that runs ALL the needed dism cmd's without having to manually typing each one

    SFC SCANNOW and DISM RESTOREHEALTH - Repair Corrupt Files
      My System SpecsSystem Spec

Properly formatted DISM command incorrectly parsed
Related Threads
I want to install .net framework 3.5 I tried everything but still can't install it I used this command "dism /online /enable-feature /featurename:NetFx3 /All /Source:C:\sxs /LimitAccess " but this didn't give me any result and didn't show any error !!
Solved DISM Command Fails in Performance & Maintenance
I ran SFC /SCANNOW after a recent PC crash. This found some files it couldn't fix so I tried to run DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH which has previously worked. I now get the error shown below referring to "The source files could not be downloaded". I don't know what's changed but how do...
Greetings. How can I identify what file(s) are corrupted and can I use the P50t files as a repair source? If so, what do I do? I can follow instructions, most times :) Here is the problem: My wifes laptop, a Toshiba P840 (running 8.1 64bit) has a problem. I also have a Toshiba laptop, a P50t...
If I wanted to use the installation disk as the source for replacement files when I have corrupted files, instead of Windows Update, do I just replace the C; drive as the source with the drive letter of my DVD player in the following command; shown in red? The 'Limit Access' argument means not to...
i install Uxtheme multi patcher and install Windows XP Theme with icons but i dont like that theme i switch back to normal theme but i think theres a Bug in the charms bar This PC 50436 seems xp my computer icon in charms bar but i search for solution but its for Desktop but my desktop This PC is...
Solved DISM Analyze command not recognized in Performance & Maintenance
Can anybody please help me fix this? 41287
username is set up incorrectly in User Accounts and Family Safety
I have a new Windows 8 computer. I set it up with my Bob Campbell account. It works fine, except for one thing. The environment variable username=Bob That's a problem. It seems to be a glitch in Windows 8. On Windows 7, when I set up a new computer my username environment variable would be...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook