Windows 8 and 8.1 Forums

'dism' error message

  1. #11

    Quote Originally Posted by topgundcp View Post
    If you wish, you can try to fix this error by using the Windows 8.1 installation disk if available. If not, download the ISO for your Windows version from the link below:
    Create installation media for Windows 8.1 - Windows Help
    1. .........
    2. From Admin Command prompt, type:
      Dism /Online /Cleanup-Image /CheckHealth
      Dism /Online /Cleanup-Image /RestoreHealth /Source:c:\mount\windows /LimitAccess

    Topgundcp, for the hospital computer, they have the original installation CD, which they will give me on Monday. Would one of the following two methods have the same result:

    a) dism /online /cleanup-image /restorehealth /source:H:\WinSxs /limitaccess (assuming I copied all the WinSxS files onto a removable drive, which in the above example would be drive H ?

    b) use a similar command setting the source to the DVD drive, with the install CD in it?


    As a separate question, from reading, and re-reading, and re-re-reading all the above, I am running 'scanhealth' again.
    Presumably that should tell me the exact names of any corrupted files. (Will find out when it finishes). Either is there any way to specifically download those specific files from Windows Update, and save them in a folder? Or, is it acceptable to copy them from the WinSxS folder on a different Windows 8.1 computer?

    A side note: It's fascinating that all the "tech people" I talk to in person tell me to just re-install Windows and be done with it. To me, that's a very last resort - it sounds like the above tools should work. I'm beginning to think they're not really "tech" people, and they would rather replace than fix.

    ..........and I should add that even if this does work, I would like to know why 'dism' fails to access Windows Update. David Bailey posted one area in Windows that had incorrect settings. Maybe there are others?

      My System SpecsSystem Spec

  2. #12

    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit

    Windows update fix sometimes repairs DISM not being able to download the necessary files:
      My System SpecsSystem Spec

  3. #13

    Possible solution to the issue on my Compaq C740EM laptop

    Progress. This is on my laptop, not the hospital computer. The 'scanhealth' completed, and if I understand what I'm doing, this is the only reference to 'corruption':

    TID=2476 <----- Starting corruption detect/repair info -----> -
    Checking System Update Readiness.

    (p) CSI Payload Corrupt amd64_prncacla.inf_31bf3856ad364e35_6.3.9600.17415_none_95dd5540d57f8c01\Amd64\CNBJ2530.DPB

    Total Detected Corruption: 1
    CSI Payload Corruption: 1
    Ending corruption detect/repair info -----> -

    If I am following the above advice correctly, on my laptop, apparently the file listed above in red is corrupt, and maybe the reason why Windows Update can't replace the file, as it is from AMD and not Microsoft? Does this make sense?

    Edit: added later.... Is this the appropriate next step?
    SFC /Scannow Unable to fix error.
      My System SpecsSystem Spec

  4. #14

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    According to this post by Microsoft, WinSxS has many duplicated files. The files are are *not* copies, but are instead “hard links” that point to the same data, and thus do not take up any extra space. Microsoft says a typical WinSxS folder contains around 400 MB of data.

    Having said that, I am not sure that your question a) above will work since most of the files are hard linked to WinSxS even though I have tried the command and it was successfully executed but I have no way of telling if it does any repair since my PC does not have the same problem as yours.

    It is best to use the steps I suggested above which DISM GUI does the dirty job of composing the DISM command with appropriate options and swiches.

    question b) Instead of using the DISM GUI to mount the install.wim, you can in fact use the command below from CD directly:
    DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:X:\Sources\Install.wim:1 /LimitAccess
    Where X is the drive letter of the installation CD

    EDIT: Make sure the CD is the same version of Windows 8 in your laptop.
      My System SpecsSystem Spec

  5. #15


    DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:X:\Sources\Install.wim:1 /LimitAccess
    where X is the drive letter of the installation CD

    The IT person at the hospital who originally worked with me to set up this computer tells me he has the original CD. There aren't that many computers at the hospital running Windows 8, so he probably does have the right disk. This PC was an experiment to find out if others at the hospital would be able to use Windows 8.

    Now that I know a bit more about the 'dism' command, where is a good place to try to understand "/source:WIM:X:\Sources\Install.wim:1" ? I expected to see something starting with "X:" (the drive letter of the DVD drive) pointing down to the appropriate folder on the CD. I've never seen something yet that looks like what you just wrote.


    Regarding mylaptop, unless people here think the AMD file can be corrected using Windows Update for the source for 'dism', I will start another thread about how to replace my corrupted file with a good version:
    If my file did come from Microsoft, the 'dism' command should now be able to replace it. If it came from AMD, then either I follow the advice in the other thread I linked to above, or contact AMD for advice.

    Thank you again!
      My System SpecsSystem Spec

  6. #16

    Posts : 2,690
    Windows 3.1 > Windows 10

    that "prncacla.inf" is found in the folder "\SystemRoot\WinSxS\amd64_prncacla.inf_31bf3856ad364e35_6.2.9200.16430_none_fdce12188b615b12"
    it references a Canon printer driver with a hash mismatch

    amd64 refers to x64 arch - not AMD
      My System SpecsSystem Spec

  7. #17

    Oops.... "amd64" ...bad assumption on my part. Since I don't have a Canon printer, is there an way I can delete, or rename that single file on my laptop? I doubt Windows will let me do that.....

    Back to the hospital PC. They didn't have the original DVD from way back when, but they did have an ISO image that they think is for this computer. I burned it to a DVD, and tried the above command:

    DISM /Online /Cleanup-Image /RestoreHealth /source:WIM:F:\Sources\Install.wim:1 /LimitAccess

    The good news is that 2/3 of the way through the 'dism' operation, it did access drive F, the DVD. Unfortunately, I still got the exact same error message.

    Here are the lines about the error from the earlier scan....

    Checking System Update Readiness.
    (p) CSI Payload Corrupt amd64_microsoft-windows-skydrive-exehost_31bf3856ad364e35_6.3.9600.17230_none_77e98b2afe9223f9\SkyDrive.exe
    (p) CSI Payload Corrupt amd64_adobe-flash-for-windows_31bf3856ad364e35_6.3.9600.16456_none_1c80b64f3d6c763f\FlashUtil_ActiveX.dll
    (p) CSI Payload Corrupt amd64_prncacla.inf_31bf3856ad364e35_6.3.9600.16384_none_9590ba64d5b91f79\Amd64\CNBJ2530.DPB

    Total Detected Corruption: 3
    CSI Payload Corruption: 3
    Ending corruption detect/repair info

    Tomorrow, I'll open the log file, and look for any ERROR instances. Maybe that will indicate whether the 'dism' utility is looking in the proper place. (Maybe I should try this in Safe Mode?)

    The IT technician at the hospital told me he had a similar problem with Widows Update on a server. His "fix" was to download the update, save it on a drive, and (somehow) tell Windows Update to use that file. We may try that tomorrow, but I doubt it will fix the above problem (unless it was a Windows problem from the beginning).
      My System SpecsSystem Spec

  8. #18

    If nothing else, can I boot into Safe Mode with DOS only, navigate to the files, and rename them? Since they're already corrupted, renaming them can't cause any more damage to anything, as I see it.

    1) - Boot into Safe Mode with command prompt.

    2) - Navigate to the directory with the file:
    cd /windows/WinSxS/amd64_prncacla.inf_31bf3856ad364e35_6.2.9200.16430_none_fdce12188b615b12

    3) First, use 'takedown' to give my user name, 'mike' full ownership of the file:
    takeown /f

    4) Second, use 'cacls' to give user 'mike' full control:
    cacls /G mike:F

    5) Last, rename the file:

    My understanding of DOS is from 1980 or so. Searching around the internet I was looking for ways to rename a system file. The worst that can happen, is I need to re-install Windows, which is what several people think I should have done from the beginning.

    Edit: no-go. Even when I put that long directory path in double quotes, I get "The system cannot find the path specified".
    Last edited by Ravi; 11 May 2015 at 11:08.
      My System SpecsSystem Spec

  9. #19

    Thanks to everyone for all your help.

    I couldn't rename the original problem file, even after a DOS restart, and when I went to look at the corrupted file later, it was no longer there. Dism now reports three corrupted files; different files than what I remember from earlier.

    I moved all my data from the laptop to a USB device, then deleted all of my installed software (other than Chrome, Malwarebytes, and Vipre). I ran the disk utility to free up space, then ran Ccleaner. After all this, a final restart. I ran 'dism' again - no change. I will run all three dism commands later today, and verify that the reported errors haven't changed.

    What I've learned from all this, especially the help in this forum is:
    • How to understand log files, and find errors (never could do that before).
    • Now that I understand the log files, I'll avoid removing them after each session.
    • Always make a Windows Repair Disk, and keep it with that specific computer "just in case".
    • Run 'SFC' and 'DISM' on a monthly basis, to monitor the computer.
    • Never enter a thread here that refers to more than one computer.
    • Finally, organize my records better, so if DISM changes its listing of what it thinks is wrong, I'll know it.

    Again, thank you to everyone here.
    (I will still try to find a fix for the laptop until this evening. At that point, I'll give up, and install the latest version of Windows 10 Trial, which I downloaded last night.)

    Added an hour later, after running the DISM tools again:

    "The restore operation completed successfully. The compoment store corruption was repaired. The operation completed successfully." !!!!!

    I am happy, but lost. Maybe someone here has an explanation of why cleaning out all MY programs and files allowed 'dism' to fix the SYSTEM files?
    Last edited by Ravi; 12 May 2015 at 03:50.
      My System SpecsSystem Spec

  10. #20

    One more update to this story....

    After following the above steps to allow 'dism' to work properly, I just ran 'SFC /scannow'. While it did find corrupted files, it also successfully repaired them.


    • 'dism' works now.
    • 'sfc /scannow' works now.
    • Windows Update works now.

    (In a way it feels to me like "throwing the baby out along with the wash water"... To clean up the system, I had to remove most of what I use and do on the latop. Of course, I can put them back now, and then re-test.)
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
'dism' error message
Related Threads
Solved DISM error: 0x80240021 in Performance & Maintenance
Please help! I've been trying to run dism for a couple of days now and all I'm getting is this: "DISM failed. No operation was performed. Error: 0x80240021" Already tried the Start Component Cleanup then the Restore health but to no avail. I already ran chkdsk but still failed to fix...
Solved DISM Giving 0x800f081f Error in Performance & Maintenance
Running DISM because sfc failed. DISM is telling me the operation failed that either the repair source was not found or the component store cannot be repaired. Any ideas? Thanks! Rob
Windows 8.1 - DISM returns error 50 in Performance & Maintenance
Hi! Im trying run: DISM.exe /Cleanup-image /AnalyzeComponentStore But i get: Version: 6.3.9600.17031 Error: 50 DISM does not support servicing Windows PE with the /Online option.
DISM and SFC error, 0x800f0906 in Performance & Maintenance
Heya all! Recently I got problems when running SFC or DISM to repair my system. As far as I know it concerns the shortcuts in the folder Administrative Tools, there I changed under Properties the Run option to Maximised Windows and since then SFC and DISM have shown this error that the services...
Hi, I've been having many problems with my comp, and I think many of them can be attributed to my HDD. Not sure whether or not it's corruption or a failing disk or what have you, but I tried to do the sfc /scannow command and the Dism /Online /Cleanup-Image /RestoreHealth command and neither...
dism error 87 in General Support
every time I get this "DISM.exe / Image: F: \ 7work \ WIM / Add-Package / Package Path: F: \ 7work \ LP \" try to run I get an error situation. error 87? What should I do now. I have so many looked on google but I'm desperate. thanks (google translate)
Solved SFC and DISM Fail. Error 0x800f081f in Performance & Maintenance
Hey Everyone, I have a similar issue to others on this forum, but posted solutions do not work. Both SFC and DISM fail to complete. I'm stuck...need a new set of eyes here; solution cannot include an OS refresh or reset. Here's the detail: Windows Update works. Everything below is done in...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook