Windows 8 and 8.1 Forums


Memory usage slowly climbing without processes running

  1. #1


    Posts : 6
    Windows 8.1

    Memory usage slowly climbing without processes running


    Brief Summary: I had this problem with windows 7, and figured upgrading to windows 8 would solve the issue (I wanted to upgrade anyway) but it's still happening. I have 8 GB of DDR3 RAM and when I start windows it has about 1.5 GB in use. Just letting it sit there, the memory use slowly climbs and climbs until memory usage says 90%+ and it gets extremely laggy or freezes. It takes less than a day of being on to hit the 90% memory usage. Restarting my PC resets memory usage and the climb begins over again until I have to reset, rinse repeat.

    The processes tab shows all processes only using the original 1.5GB and the continuous memory usage comes out of no where. I thought it could be a problem with my RAM so I swapped it out and it's still happening - even running memtest for half a day shows 0 failures. I have tried disabling all services from starting at startup except Microsoft services and it still happens. I have tried setting my page file manually (I set it to minimum AND maximum at 16GB). Still happening.

    I have Windows 8.1, Asus Z97 Sabertooth Mark 2 motherboard, Corsair vengeance DDR3 1600MHz 8GB, Asus 970 GTX, Samsung 250GB Evo 850 SSD, WD 2 TB Black HDD. My system is fully up-to-date with updates and all drivers are the newest versions. I have to leave for work right now but will be checking this thread and responding throughout the day if anyone has any advice of what my problem could be, and I will be back to test any advice from you guys when I'm off work tonight. Thank you so much in advance for anyone that replies - this issue has really been bugging me.

      My System SpecsSystem Spec

  2. #2


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Drivers perhaps? Can you post a picture like this of the memory under the performance tab in task manager (when it looks bad). Screenshots and Files - Upload and Post in Eight Forums

    Click image for larger version
      My System SpecsSystem Spec

  3. #3


    Posts : 6
    Windows 8.1


    Will do. Since my PC is usually unusable by the time I get home from work I have it shutdown at the moment. It will have to wait until tomorrow but I will upload it as soon as I can.
      My System SpecsSystem Spec

  4. #4


    Posts : 6
    Windows 8.1


    Various screenshots:

    Sorry if they are a bit out of order. I uploaded 3 screenshots for the start of turning on my computer (this is with a second monitor running so the usage is high off the start) and then 3 more screenshots of the same programs running but 3 hours later. I am going to bed so I figured I'd post them now as my computer will have crashed if I leave it on overnight. But the usage just keeps climbing the way it does until it's unusable.
    Attached Thumbnails Attached Thumbnails 1.png   2.png   3.png   4.png   5.png  

    6.png  
      My System SpecsSystem Spec

  5. #5


    Posts : 6
    Windows 8.1


    A quick update, PC has been on for only an hour and it's been much faster this time. Here's 3 more screenshots.
    Attached Thumbnails Attached Thumbnails 7.png   8.png   9.png  
      My System SpecsSystem Spec

  6. #6


    Posts : 4
    windows 8


    1)try to turn off all the antivirus thingy
    2)turn off the write caching in Device Manager

    Those things consume a lot of RAM. that's my suggestion
      My System SpecsSystem Spec

  7. #7


    Redmond
    Posts : 651
    Windows 8.1 x64


    Get output from RAMMap in this case - your memory usage doesn't match the screenshots of process usage.
      My System SpecsSystem Spec

  8. #8


    Posts : 6
    Windows 8.1


    Hope this gives more insight. Let me know if you need certain parts of RAMmap - The order is messed up - The first and last screenshots are taken at startup, and the middle ones are taken from only 1 1/2 hours after startup.
    Attached Thumbnails Attached Thumbnails 10.png   11.png   12.png   13.png  
      My System SpecsSystem Spec

  9. #9


    A brief search suggests Bit Defender Free (gzserv.exe) a suspect to the problem.

    A few users have had this problem since 2014, but not enough to invest in problem solvers.

    Since the Free version can be installed/uninstalled at will (I assume), the problem can be isolated to Bit Defender Free if the problem goes away after the uninstall.
      My System SpecsSystem Spec

  10. #10


    Posts : 6
    Windows 8.1


    [Solved] Thank you so much for helping everyone, especially 10soonerlater. I didn't think it would be Bit Defender as it didn't seem to use that much memory, but it was certainly the culprit. Uninstalled completely and have been running PC for about 16 hours straight now, doing various things throughout the day after leaving it on overnight, and my memory is fine.
      My System SpecsSystem Spec

Memory usage slowly climbing without processes running
Related Threads
Hi there, I'm currently troubleshooting performance issues with my work PC. Even when I am not doing much, the memory usage is quite high. I have 4GB RAM in the system (128MB allocated for the GPU, I believe, as System Properties window shows 3.88GB memory usable) and am running Windows 8.1...
Identify Processes Running Upon Login? in Performance & Maintenance
Lately, and I'm not sure if I'm noticing it for the first time, after I login and access my desktop from the touch screen, I can't access any programs until after a few seconds (maybe 10-15). Is it possible there are background programs running that are interfering here? If so is there a way to...
Running out of memory when running overnight. in Performance & Maintenance
First let me say, I rarely leave my 8.1 system running all night as I generally switch off before bed. On the FEW occasions I leave the system running all night I always get the "Your computer is low on memory" warning. For instance, yesterday my software RAID mirror was "Re-synchronizing"...
Hello everyone, I have a problem with the updating of my adapters. This happens sometime after one hour sometimes after a week. The computer works just fine afterwards aside that I can not use any Lan adapter anymore or any other adapter like usb. When I shut down my Laptop afterwards it always...
Disk + Memory Usage ~100% in Performance & Maintenance
Hello. For the past couple days, my computer has been running pretty slow, and it shouldn't be, it's only a few weeks old. The disk usage goes up to 99/100%, my computer slows down/lags, stays like that for awhile, returns to normal, and repeats. My memory usage is at 94% (7.5/8gb) at all times,...
I have 4gb ddr3 memory . Ive checked the new pretty task manager from Win8 and I saw upp to 30% memory usage without runing any app besides task manager ofc. I want to ask if is this normal ? Ive took some screenshots for most of the entire taks manager window showing apps , background...
High memory usage in Performance & Maintenance
hello all, I found my PC really slow after a while of use, checking Task Manager found that my total percent of memory was at 99% while playing BF3, funny thing today also 2 friends had exactly the same problem, friend's PC system X79 SSD RAID nvidia 670 32gb, my other friend's PC intel 1356 HHD...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook