Windows 8 and 8.1 Forums


an unspecified error occurred during system restore

  1. #1


    poland sopot
    Posts : 4
    windows 8,1

    an unspecified error occurred during system restore


    hello guys,

    thats what i get everytime im trying to do system restore
    an unspecified error occurred during system restore (0x8007051a).
    im restoring from windows installation dvd and i tried many times with different dates of system restore.....

      My System SpecsSystem Spec

  2. #2


    poland sopot
    Posts : 4
    windows 8,1


    its been two days now guys,can somebody help?

    also i forgot to say that i cant create a windows recovery disk,files are missing.......
      My System SpecsSystem Spec

  3. #3


    System Restore and restoration from installation disk are different. Did you try system repairs first ?

    DISM - Fixing Component Store Corruption in Windows 8[1]=Performance%20Maintenance
      My System SpecsSystem Spec

  4. #4


    poland sopot
    Posts : 4
    windows 8,1


    very helpfull article i tried Dism /Online /Cleanup-Image /RestoreHealth and it says that everything is restored and ok,but no changes,also i run sfc/scannow and it finds problems that cant fix.
    im uploading cbc and dism maybe you can see what wrong.....
    an unspecified error occurred during system restore Attached Files
      My System SpecsSystem Spec

  5. #5


    Posts : 2,627
    win8.1.1 enterprise


    Quote Originally Posted by CountMike View Post
    System Restore and restoration from installation disk are different. Did you try system repairs first ?

    DISM - Fixing Component Store Corruption in Windows 8[1]=Performance%20Maintenance
    likely just using the disk to access the repair section to run system restore [I know there is another name for it but it just will not come to me ]
      My System SpecsSystem Spec

  6. #6


    poland sopot
    Posts : 4
    windows 8,1


    the point is that system restore is not working even with repairs,and even when i put the installation disk and repair startup and disk nothing is happening......
      My System SpecsSystem Spec

an unspecified error occurred during system restore
Related Threads
I'm not really used to posting in forums so I'll just try to explain my issue first. I did a system restore on Windows 8.1 the other day to restore some of my display settings and drivers. For whatever reason, the restore said it didn't take, but the settings were restored and my system had rolled...
I can not connect to the Internet. Diagnostic Policy Service will not start to correct the problem and returns with the above error message. Attempting to start DHCP or a myriad of other services all return the same error message. I have tried elevated command prompt. Restoring the hidden...
I'm trying to print images/pictures using windows photo viewer and I get this error "Your pictures can't be printed because this error occurred".... It doesn't tell me which error.. simply just says that in the dialog box. THe dialog box comes out like 4 times with the same message and I have to...
Recently, I've discovered that my system restore does not work. I thought it was due to errors with the specific restore points that I'd tried, but it also failed with a test restore point I'd created. The error can be found below. 46051 I would very much like to fix this issue before the...
I'll just assume that we have all seen this post, or had the issue our selves, at some point. I too was not lazy about this and searched Google, bing, and every forum on earth (including this one) for a solution. I was told, WRONGLY of course, by a web site that the Environment Variable PATH(all...
About an hour after the automatic installation of Windows Update KB2919442 (Windows 8.1) on April 1, I began to get Event 55 errors showing up in Event Viewer (screenshot attached). I tried to go back to the System Restore point before the update, but the restore failed. I ran sfc /scannow and it...
Win 8 system backup image restore error help in Performance & Maintenance
Hi there, My windows 8 pro install messed up n i have almost 2.8tb of stuff on my drive on a 3tb hd. I have an identical hd as a backup which i have (an apparently successful) a backup of my system from a couple of weeks ago on. I had set the system to do scheduled backups of the system (set to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook