Windows 8 and 8.1 Forums


Brand new laptop: Very slow and / or unresponsive....

  1. #21


    Quote Originally Posted by adamf View Post
    So to be clear you are saying it is firefox? Your screenshot above looks OK - mostly system idle and GIF generation.

    What version of firefox are you using? What happens if you use IE or Chrome instead?
    I don't like IE, It's not secure enough. there's so many bloody exploits in that piece of garbage.... I'll never use that. Ever. I use it once on every PC to download firefox.

    Chrome runs way too many background processes its a resource hog... and since I'm having enough resource problems i don't think I'm going to try running a resource intensive program..... On previous computers Chrome would just slow them down even worse so i don't see the point in trying that...

    EDIT: I'm not saying it's firefox, It's the computer... I don't get where the problem is.
    Every program can boost the CPU to 100%. It doesn't even have to be anything. If i run two programs the CPU will boost to 90-100% zone, If one is idle it'll drop but if i start using any program while im using another then the CPU boosts.

    This system will NOT multitask without boosting to 90-100% CPU zone.... I don't get it. I've never had this problem until i got this computer.

    So tempted to try a pirated copy of 7 to see how it performs on 7 but i gotta use this laptop for scchool as well and school starts today so it's kinda hard to wipe it and put 7 on it after setting it up for school....

      My System SpecsSystem Spec

  2. #22


    Posts : 1,875
    Windows 10 Pro Prieview x64


    Your last 2 screen prints didn't show much CPU usage but you said opening 2 Firefox tabs caused the problem. Testing other browsers could confirm this - then it may be a case of upgrading Firefox or looking at extensions.

    You could try Chrome 64 bit as it is supposedly the most efficient just as a test https://www.google.com/chrome/browser/?platform=win64 if you don't like IE.

    If not can you post again the CPU usage when it is high.

    As for 7 personally I find 8 uses less resources (I have an 8 year old MacBook). Yours really should run either fine.
      My System SpecsSystem Spec

  3. #23


    Quote Originally Posted by adamf View Post
    Your last 2 screen prints didn't show much CPU usage but you said opening 2 Firefox tabs caused the problem. Testing other browsers could confirm this - then it may be a case of upgrading Firefox or looking at extensions.

    You could try Chrome 64 bit as it is supposedly the most efficient just as a test https://www.google.com/chrome/browser/?platform=win64 if you don't like IE.

    If not can you post again the CPU usage when it is high.

    As for 7 personally I find 8 uses less resources (I have an 8 year old MacBook). Yours really should run either fine.
    Like i said... It's not even firefox. Like i said. It's been like this since the fist startup when i got it in the mail.
    I have 1 Firefox extension ( Colorzilla ), I have the latest FF Version.

    Yeah i realize it should run it fine. But it doesn't.. and i don't understand why. Damn Dell.... God i remember why i hate this manufacturer..... Took what i could get. I have had 1 previous windows 8 laptop and it ran perfect ( It was an Acer, But i wiped it and put 7 on it ) and had less specs than this i believe but it could also run Saints Row Three & Crysis 2 maximum edition. I can't get this to run Battlefield Play4Free and that game is built for old computers....


    EDIT:
    As well i have 4GB DDR3 Ram in this laptop and the laptop NEVER uses half a gig... It ALWAYS says 3.89GB useable ram but it never uses anything more.... 4GB and it never uses half of 1GB... I don't get it... I have all this RAM that's not being used.....
    Last edited by alex809; 03 Sep 2014 at 10:03.
      My System SpecsSystem Spec

  4. #24


    Like I said in my first reply, send it back! No way a new laptop should behave as it's doing.

    You paid good money for it so make them fix it or refund your money so you can get a different one.
      My System SpecsSystem Spec

  5. #25


    Quote Originally Posted by Ztruker View Post
    Like I said in my first reply, send it back! No way a new laptop should behave as it's doing.

    You paid good money for it so make them fix it or refund your money so you can get a different one.
    It seems to be ok now, I ran AVG PC Tuneup and it seems to be running really good now. It's not freezing but this isn't the only laptop with windows 8 that i've seen with the CPU issue staying between 90-100% all the time with no reason. This is actually the second or third laptop i've seen with this CPU issue.
      My System SpecsSystem Spec

  6. #26


    Glad for you it's running better. I know it can be extremely frustrating when you get a new computer and have problems.

    How does the CPU utilization look now?
      My System SpecsSystem Spec

  7. #27


    Quote Originally Posted by Ztruker View Post
    Glad for you it's running better. I know it can be extremely frustrating when you get a new computer and have problems.

    How does the CPU utilization look now?
    Yeah it is lol
    CPU utilization hasn't changed. It's still the same but i've seen it like this on multiple windows 8 laptops... Which is weird because i NEVER saw that issue with Windows 7.
      My System SpecsSystem Spec

  8. #28


    USA
    Posts : 99
    Windows 8.1 with Bing


    I know you solved your problem but, I just wanted to say, that ie11 isn't that bad.... While I still use Firefox as my default, Microsoft patched and is on a rapid release schedule. Btw if you do have anything bad with Firefox shoot me a PM. I'm a FF Contributor so I can help :3
      My System SpecsSystem Spec

  9. #29


    Quote Originally Posted by Daxter View Post
    I know you solved your problem but, I just wanted to say, that ie11 isn't that bad.... While I still use Firefox as my default, Microsoft patched and is on a rapid release schedule. Btw if you do have anything bad with Firefox shoot me a PM. I'm a FF Contributor so I can help :3
    Alright good to know.
      My System SpecsSystem Spec

  10. #30


    But even though that issue is solved i'm still wondering why my PC never uses 1GB of the 4GB ram i have...
    It always says 3.89GB usable but it never uses anything more than what it says.....

    What's up with that?
    What can i do about that? I'm sure i'd have less trouble if it actually utilized all the memory that i have....
      My System SpecsSystem Spec

Page 3 of 4 FirstFirst 1234 LastLast
Brand new laptop: Very slow and / or unresponsive....
Related Threads
Greetings folks! Very glad I stumbled across this website. I'm having issues with my new desktop computer that I bought from IBUYPOWER. The issue is slow/intermittent internet. Seems like a lot of 8.1 people are having internet problems. Computer specs are as follows: -AMD 6300 Six Core...
I recently received a brand-new HP Pavilion 10-e010nr laptop for Christmas. I went through the setup process and it went smoothly. I quickly noticed that the computer was slow, even before installing anything, but thought nothing of it at first, until a day or two later; then it got annoying. I did...
Hi, I have a brand new Windows 8 Dell Inspirion laptop, and it has a horrible internet connection. I have not downloaded any new programs and I don't visit shady websites so I don't think it's a virus. Sometimes the internet is just moderately slow, and sometimes it just completely won't move, I...
Hi all. I recently purchased a Toshiba Satellite C50-A02-V running Windows 8 Home Edition. I've never really had the fastest internet, but its always been alright for what I used it for... untill i purchased this computer. Suffice it to say the internet is... a little below sub par. Heres a...
Solved Very high RAM use at a brand new laptop? in Performance & Maintenance
Hello, I recently got a new laptop, first thing I did was delete most bloatware and such, and there really isn't a whole lot remaining other then OS and drivers. However, when checking the taskmanager recently I noticed it using 80-90% of the RAM. While being under very little use. Only thing was...
I've recently purchased a Samsung Series 7 all-in-one computer. Having used iMacs all my life, and the need for a Windows computer for programming, I opted for this machine. Here is a screenshot of my specs before I continue: 26456 At times the system is unresponsive. All I have open is...
As mentioned above..... Vote..... :)
Eight Forums Android App Eight Forums IOS App Follow us on Facebook