Windows 8 and 8.1 Forums

CTD, Lots of game crashing, ntdll.dll, code c0000005

  1. #1

    Posts : 3
    Windows 8.1

    CTD, Lots of game crashing, ntdll.dll, code c0000005

    Hi everyone.

    I've been strugling with this error in many games for some time. I haven't been able to find a trigger for the faults. A game like The Witcher crashes after 2-3 minutes, Divinity Original Sin worked for 2 hours, but after reaching a certain point it crashes every 5 minutes, Football Manager works without problem unless I go on holiday in which case it crashes after 30 seconds.

    I think everything works in fail safe mode, as I was able to play the witcher for approx 10 minutes without problems.

    What I have tried:

    Memtest86 - no errors
    Tried three different video drivers
    Reinstalled games
    Reinstalled Windows
    Probably more, that I can't remember from the top of my head .

    The gfx is a AMD 7850 Tahiti LE, which normally is overclocked, but the error persist even when it is not.

    Dump file from most recent Witcher crash

    This dump file has an exception of interest stored in it.
    The stored exception information can be accessed via .ecxr.
    (b7c.4a0): Access violation - code c0000005 (first/second chance not available)
    eax=00000000 ebx=10571668 ecx=53e59799 edx=00ee5ed4 esi=10571620 edi=10571630
    eip=7765df8c esp=01ccda8c ebp=01ccda98 iopl=0         nv up ei pl nz na po nc
    cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000202
    7765df8c c20800          ret     8
    0:000> !analyze -v
    *                                                                             *
    *                        Exception Analysis                                   *
    *                                                                             *
    *** WARNING: Unable to verify checksum for mss32.dll
    *** ERROR: Symbol file could not be found.  Defaulted to export symbols for mss32.dll - 
    *** WARNING: Unable to verify timestamp for atiumdag.dll
    *** ERROR: Module load completed but symbols could not be loaded for atiumdag.dll
    44c1dfa5 000400          add     byte ptr [eax+eax],al
    EXCEPTION_RECORD:  ffffffff -- (.exr 0xffffffffffffffff)
    ExceptionAddress: 44c1dfa5
       ExceptionCode: c0000005 (Access violation)
      ExceptionFlags: 00000000
    NumberParameters: 2
       Parameter[0]: 00000001
       Parameter[1]: 8968322a
    Attempt to write to address 8968322a
    CONTEXT:  00000000 -- (.cxr 0x0;r)
    eax=00000000 ebx=10571668 ecx=53e59799 edx=00ee5ed4 esi=10571620 edi=10571630
    eip=7765df8c esp=01ccda8c ebp=01ccda98 iopl=0         nv up ei pl nz na po nc
    cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000202
    7765df8c c20800          ret     8
    PROCESS_NAME:  witcher.exe
    ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
    EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.
    WRITE_ADDRESS:  8968322a 
    007716ac 6a6c            push    6Ch
    APP:  witcher.exe
    ANALYSIS_VERSION: 6.3.9600.17029 (debuggers(dbg).140219-1702) amd64fre
    FAULTING_THREAD:  000004a0
    LAST_CONTROL_TRANSFER:  from 007716ac to 44c1dfa5
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    01ccf318 007716ac 01ccf3f4 01ccf3a4 00000001 0x44c1dfa5
    01ccf31c 01ccf3f4 01ccf3a4 00000001 05684554 witcher!initializeEngine1+0x2107c
    01ccf320 01ccf3a4 00000001 05684554 00000000 0x1ccf3f4
    01ccf3f4 53e59799 00ee5ed4 05c3f040 05684501 0x1ccf3a4
    01ccf3f8 00ee5ed4 05c3f040 05684501 01ccf4fc 0x53e59799
    01ccf3fc 05c3f040 05684501 01ccf4fc 00afdd5c witcher!Internal_TagesLoadModule+0x5b3dc4
    01ccf400 05684501 01ccf4fc 00afdd5c ffffffff 0x5c3f040
    01ccf404 01ccf4fc 00afdd5c ffffffff 00771a95 0x5684501
    01ccf408 00afdd5c ffffffff 00771a95 00002758 0x1ccf4fc
    01ccf4fc 00afe8f8 ffffffff 0090b11b 44c2be5e witcher!Internal_TagesLoadModule+0x1cbc4c
    01ccf620 00b11470 ffffffff 009ef2c1 47569d5c witcher!Internal_TagesLoadModule+0x1cc7e8
    01ccf69c 00b16120 00000000 009efb0b 47575864 witcher!Internal_TagesLoadModule+0x1df360
    01ccf6c4 00b16140 00000000 00000607 009a0497 witcher!Internal_TagesLoadModule+0x1e4010
    01ccf808 00b13430 00000002 009b4046 00000345 witcher!Internal_TagesLoadModule+0x1e4030
    01ccf860 00b12f68 ffffffff 00ab3aaa 00000345 witcher!Internal_TagesLoadModule+0x1e1320
    01ccf9d8 00b17c31 ffffffff 00ab4e70 01ccfa0c witcher!Internal_TagesLoadModule+0x1e0e58
    01ccfa2c 00b12f68 ffffffff 00ab604d 00000000 witcher!Internal_TagesLoadModule+0x1e5b21
    01ccfab4 00aeec18 ffffffff 00000000 00000000 witcher!Internal_TagesLoadModule+0x1e0e58
    01ccfb6c 00b0c866 ffffffff 00912480 0000000a witcher!Internal_TagesLoadModule+0x1bcb08
    01ccfcfc 63f103de 63f1aa8c 13f13f81 5f87725b witcher!Internal_TagesLoadModule+0x1da756
    01ccfd00 63f1aa8c 13f13f81 5f87725b 01e61eb9 d3d9!_EH_epilog3_catch_GS+0xa
    01ccfd70 00b102ca ffffffff 00753389 5f87725b d3d9!CD3DBase::Clear+0xb4
    01ccff8c 7700919f fffde000 01ccffdc 7766a8cb witcher!Internal_TagesLoadModule+0x1de1ba
    01ccffcc 776aaab4 761be042 00000000 01ccffec kernel32!BaseThreadInitThunk+0xe
    01ccffe4 7765f664 00000000 00000000 012df2ed ntdll!wcstombs+0x86
    01ccffe8 00000000 00000000 012df2ed fffde000 ntdll!FinalExceptionHandlerPad5
    STACK_COMMAND:  ~0s; .ecxr ; kb
    SYMBOL_NAME:  witcher!initializeEngine1+2107c
    FOLLOWUP_NAME:  MachineOwner
    MODULE_NAME: witcher
    IMAGE_NAME:  witcher.exe
    FAILURE_BUCKET_ID:  INVALID_POINTER_WRITE_c0000005_witcher.exe!initializeEngine1
    FAILURE_ID_HASH_STRING:  um:invalid_pointer_write_c0000005_witcher.exe!initializeengine1
    FAILURE_ID_HASH:  {98673e52-7b47-62db-2754-3097d05b3240}
    Followup: MachineOwner

    Hope some of you are able to help.

      My System SpecsSystem Spec

  2. #2

    Posts : 3
    Windows 8.1

    Mistake post
      My System SpecsSystem Spec

  3. #3

    Posts : 3
    Windows 8.1

    Of course it is now after I finally ask for help I find the solution.

    For people finding this thread later on:
    Short version:
    I reset the BIOS to defaults

    Long version:
    Basically I went back and looked at my old logs from when I first overclocked my CPU (I document everything as a precaution). I then went through all my settings and found that some of the RAM timings where not in accordance with what I had written down 18 months ago. I reset the BIOS to defaults and tested the system. It worked, so I changed it to the settings in my log and checked it still worked.
      My System SpecsSystem Spec

CTD, Lots of game crashing, ntdll.dll, code c0000005
Related Threads
Hello all, I'm new to the forums here as I can normally troubleshoot and problems myself, but I've been having a hard time resolving this issue. I've recently upgraded my motherboard, processor and RAM to an ASUS Z87-K, Intel i5-4670K, and Corsair XMS3 1x8GB, and ever since I have been...
Hi, I am new here but have been known about this place for ages and you all seem to be very helpfull. I will explain the problem I am having below, let me let you know that I am not new to computers and have been dealing with them since the late 90s and I am A+ certified. Ok here we go, what I...
Windows 8.1 crashing when playing any game in BSOD Crashes and Debugging
Hi, my Windows 8.1 (64 bit) is crashing with the Blue Screen from time to time when playing any game or using any Office program (Excel, Word, etc), I enabled the driver verifier and got the minidump files which I am attaching. Any help will be very appreciated. Thanks. 52362
Lots of Crashing. Plz Help in BSOD Crashes and Debugging
Ok. I know that the 70113-3048401 and the one after that were both caused by trying to sleep/shut down the computer. The last two were from playing a flash game and browsing the internet. This is my third time uploading my BSOD stuff and i don't know what to do. I have checked to the length of my...
Lots of BSOD during game play... in BSOD Crashes and Debugging
Playing various games WoW, Battlefield 3, Rift, Star Wars TOR, just to name a few, after anywhere from 5-30mins of game play I get random BSOD's or game will shut down and pop up box will tell me Windows has encountered an error and is restarting in 1 minute. I followed the BSOD reporting info...
I have Windows 8 RTM installed and have noticed this since the very first day of using it. explorer.exe keeps crashing, say, when I'm opening folders with a lot of media content in them. Sometimes I can browse without any problems, and sometimes it crashes. I checked Event Viewer and ntdll.dll...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook