Windows 8 and 8.1 Forums


New AMD FX9590 slower than my old Phenom 1100T

  1. #1


    Posts : 6
    Win 8.1

    New AMD FX9590 slower than my old Phenom 1100T


    I just built a new system around the AMD FX 9590 on an Asus MB with 32GB of RAM. I excitedly decided to run a benchmark (in this case, Novabench) on the new system once I got all my other programs loaded. Imagine my shock and dismay when my "super system" posted HALF the total score of my 4-year old Phenom! I opened Task Manager, focusing on the CPU, and ran the tests again. It never budged from 1.5GHz. I understand it running at a lower frequency since when not under load, but in this case, it should have jumped up to the full 4.7GHz for the tests. And strangely, my Samsung SSD only recorded 41MB/s, where as the same SSD in my older system registered something like 150MB/s. With the exception of memory, every benchmark, frankly, sucked.

    Anyone have an idea where to look for what might be throttling back my system so severely? Thanks for the help.

      My System SpecsSystem Spec

  2. #2


    Try some other benchmarking program like Cine Bench, MAXON | 3D FOR THE REAL WORLD: Overview it might load up system better. Also benchmark with all power saving options disabled.
    You checked for BIOS updates, of course, didn't you. It's a brand new processor so it could be a problem there. Another thing is that 9590 draws a lot more power and MB might be throttling voltage.
      My System SpecsSystem Spec

  3. #3


    Posts : 43
    Windows 8.1 Pro


    Would also help to know what motherboard.
      My System SpecsSystem Spec

  4. #4


    Posts : 902
    Win8.1 Pro, Desktop Mode


    Is it possible that you need a bios update for your motherboard....??
      My System SpecsSystem Spec

  5. #5


    Posts : 6
    Win 8.1


    Thanks for the suggestions. My MB is an Asus Crosshair V Formula-Z, top of the line for them for the AM3+ boards, and the BIOS is the most recent. Though I've built computers for many, many year, I'm not sure on this one (whether in Win 8 or the BIOS), where to disable the power reduction options, but I'll try to find it. The BIOS is pretty massive to wade through, and not all options are clear to me. With your suggestions, I think I'll call Asus Tech Support and see where i can get with them. My problem has been not quite knowing whether the problem is something within Win 8 or hardware/BIOS. Especially since it has effect ALL aspects of speed from SSD write speed to video to overall number crunching (image processing). I read an article that mentioned that Win 8 was slightly faster in benchmarks than Win 7.
      My System SpecsSystem Spec

  6. #6


    Posts : 902
    Win8.1 Pro, Desktop Mode


    Ok, there's your problem right there. Your mb only supports cpu's up to 140w, and the fx-9590 is 220w.

    Motherboards - CROSSHAIR V FORMULA-Z
      My System SpecsSystem Spec

  7. #7


    Posts : 902
    Win8.1 Pro, Desktop Mode


    Hmmm... perhaps I was wrong, as it seems a bios update was available that did add support for your 9590...

    Motherboards - CROSSHAIR V FORMULA-Z
    Although I would check the bios, make sure the cpu is in fact getting it's required 220w.
      My System SpecsSystem Spec

  8. #8


    Posts : 43
    Windows 8.1 Pro


    Did you connect both the 8 pin and 4 pin CPU power connectors on the motherboard?
      My System SpecsSystem Spec

  9. #9


    Posts : 6
    Win 8.1


    After calling Asus Tech Support and discussing the issue at length, we finally narrowed the issue to either the RAM or the CPU. I also realized, I still had a switch and pin set on the MB to Slow Mode, which can help with cold bugs and other issues. That forces the CPU to throttle back to about 1.5GHz, so with that "unlocked", it freed up the CPU speed.

    After pulling all but one stick of RAM (I have four 8GB sticks), I tried each one alone in the system. Each time I experienced a lockup. I also, tried some 4GB sticks I had lying around. same thing. I used the Asus monitor to check temps as I ran test and noticed that, considering I wasn't overlly stressing the system, that the CPU was running pretty hot -- about 140F. I even had a notice pop up about either temps or voltage for the NB, but it went away too quickly for me to really read. Before things got really bad, I was able to run a complete set of Novabench tests at normal speed. It FINALLY was higher than my old system, though not by much. I was a bit off in my total bench score for the Phenom. It was actually 1469, while the FX was 1759. So a modest increase, though not the oomph I'd hoped for, considering cost.

    With that in mind, and thinking the CPU may be faulty at higher temps (so much for overclocking thoughts), I decided to tear down the CPU and cooler. I cleaned the CPU and cooler plate with alcohol and reapplied a generous glob of CPU paste. I also put a fourth exhaust fan in the case. Where as at idle, the CPU was running hot, around 130F, it's now, for non-stress tasks, running in the 90s. A big difference.

    So, at least for the moment, I think my issues are solved. It was combination of pilot error, as well as thermal issues. The FX9590 does not like it hot. In the end, I think I probably have a marginal sample of this chip, and may have to replace it with another (if I can AMD to make good), or buy a slower chip and clock it up if necessary. I hear the FX9590 is essentially already factor overclocked, so unless you have an amazing cooling system (mine is the stock double push/pull water cooler/fan that came with the chip), I have to take baby steps to see how it holds up.

    Thanks for all the suggestions and input and ideas.
      My System SpecsSystem Spec

  10. #10


    Posts : 902
    Win8.1 Pro, Desktop Mode


    Glad ya got it sorted, and thanks for posting back the fix.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
New AMD FX9590 slower than my old Phenom 1100T
Related Threads
New laptop slower than old one in Performance & Maintenance
Hi, if you look at my specs and compare my old laptops specs,you might be wondering, "What the F#$%?" Here is the link to my old account when I had my old laptop: Windows 7 Help Forums - View Profile: MCPlayer18 I could get 10-20 FPS on that at most (Rough Estimate) But Now I only get 1-29...
Is 8.1x64 slower than Win7x64? in General Support
I'm putting together a laptop with a Celeron 1.1ghz. I have 3GB memory, with option to go up to 8GB. I have an identicle laptop with win7x64 and 8 gb ram with the 1.5 Celeron. I haven't played with the new 8.1 to know for sure but it does seem a bit slower, think its probably lack of ram?
Laptop has become slower in Graphic Cards
Hi everyone. When i first bought my laptop i was able to run League of legends max settings with 60 fps stable,but somehow after a couple of months i started to notice that my fps are getting lower and lower,so i tought maybe the game has become more demanding so i tried Cod but the same thing...
Hello, I dual boot with win 7 and win 8. I have faster download speed when i'm in win 7 than when i'm in win 8. Obviously my router wireless settings is the same for both OS. I Googled this and it seems that it's a problem for a lot of users.If it's a question of updating drivers, my laptop is...
Hi there Got a older desktop with AMD QUAD Phenom 3.2 GHZ processor -- and the whole computer seems more sluggish than my small ACER 11.6 inch V151 laptop which only has an Intel I3 Dual core processor in it. Can't really explain this -- the only thing now that the desktop gives me advantage is...
Since W8, slower download speed! in Network & Sharing
Hello :) So, when I had Windows 7 I downloaded like 6MB/s, but since I upgraded to Windows 8 I'm only getting 2MBs! So, I searched on Google etc and I saw that Windows 8 is using 20% of your download bandwidth, or what ever it was. So, I want to turn it off by searching 'gpedit.msc', for the...
Windows 8 is slower to boot up. in Performance & Maintenance
This post has been edited now I have found what is causing the problem. Okay, so this same post 4 days ago was me saying that my boot had been slowing down after updating to Windows 8, The Dell Logo at the start was taking 20 seconds to load when it should appear instantly, MisterApathy posted a...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook