Windows 8 and 8.1 Forums


Windows 8 Strange Issue with desktop flashing on and off

  1. #1


    Seattle, WA
    Posts : 117
    Windows 8.1 Pro with Media Center

    Strange Issue with desktop flashing on and off


    My friend's laptop is having a strange issue where the desktop flashes on and off with the theme color.

    I did a virus and malwarebytes scan, and found nothing.

    I turned off all startup programs except a few.

    It seems to work fine in Safe Mode, however.

    Here is a video: https://www.youtube.com/watch?v=3pXMqmvZhhw

    Does anyone know what this issue is and how to fix it?

    Let me know.

    Thanks,

    David

      My System SpecsSystem Spec

  2. #2


    Posts : 2,191
    Windows 8.1


    Hi davidkimball,

    At first glance, I'm suspecting a graphics' driver/card issue but I could be wrong. In any event, could you check the Event Viewer logs to see if there are any entries being logged that are "time-coincident" with the flashing? If some are found, please post a few examples. However, if none are found, do you have an extra monitor you could try?


    my2cents
      My System SpecsSystem Spec

  3. #3


    India
    Posts : 1,184
    Windows 8.1, Windows 7, Linux Mint 14


    Hello David,

    In safe mode, the graphics driver (and many other drivers) are disabled. According to you, it seems to work fine in safe mode. Therefore, we have good reasons to think that it might be (I'm not absolutely certain) related to graphics driver. Try downloading and installing the latest graphics driver from the manufacturer's website.
      My System SpecsSystem Spec

  4. #4


    Posts : 2,191
    Windows 8.1


    Quote Originally Posted by Arpan View Post
    Hello David,

    In safe mode, the graphics driver (and many other drivers) are disabled. According to you, it seems to work fine in safe mode. Therefore, we have good reasons to think that it might be (I'm not absolutely certain) related to graphics driver. Try downloading and installing the latest graphics driver from the manufacturer's website.
    It seems to work fine in Safe Mode
    @Arpan: I did miss that. Good pickup on your part.
      My System SpecsSystem Spec

  5. #5


    India
    Posts : 1,184
    Windows 8.1, Windows 7, Linux Mint 14


    Quote Originally Posted by my2cents View Post
    @Arpan: I did miss that. Good pickup on your part.
    Thanks mate
      My System SpecsSystem Spec

  6. #6


    Posts : 1
    Windows 8.1

    Silverlight as a factor?


    Hey, so I'm the friend. There was a Silverlight update that ran just before this issue started. Would that have anything to do with the problem?
      My System SpecsSystem Spec

  7. #7


    Posts : 2,191
    Windows 8.1


    Quote Originally Posted by rbrewster View Post
    Hey, so I'm the friend. There was a Silverlight update that ran just before this issue started. Would that have anything to do with the problem?
    Hello rbrewster,

    I cannot say conclusively that Silverlight could be the definitive cause of your issue but there is one easy way to find out. Just uninstall it and see what happens. Good luck,

    my2cents
      My System SpecsSystem Spec

  8. #8


    Posts : 2
    Windows 8.1


    I am also having a very similar problem. I am using the same computer as the one in the video and am using a nvidia graphics card. Unfortunately, safe mode does not seem to help my computer. The desktop will load, but as soon as I try to do something, the desk top refreshes and flickers.
      My System SpecsSystem Spec

  9. #9


    I have the same problem with my Dell Inspiron 15r. I am currently running fine in safe mode. This problem first came up a few months ago and I recall finding a "solution" online but it is back and I haven't found anything to fix it. The PC shop said yesterday that I picked up a couple trojans a few months ago and they seem to have been reactivated. They removed the trojans but the problem persists. Apparently I have hundred of files that are corrupted so the best thing for me is to do a clean install. Unfortunately, I get errors when attempting either a refresh or reset via Windows 8.
      My System SpecsSystem Spec

  10. #10


    Posts : 2
    Windows 8.1


    What I did may be a bit extreme bit Windows Refresh completely fixed the problem. The downside to this is that it deleted about 300 gigabytes. If all else fails, this is a good solution.
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
Windows 8 Strange Issue with desktop flashing on and off
Related Threads
Dear Forum, Summary: I deleted system's pagefile because I want to run the system fully on ram (32gb), but dxdiag still reports that 21gb is occupied by the deleted pagefile. I cannot find the file. It seems to be deleted, however, 21gb is missing from my hard drive. It is a painful situation...
Desktop Page Flashing in General Support
I have hp pavilion g6-2249 wm notebook. My laptop is 4 months old. Two days ago when I started my pc, the welcome page opens and then I sign in. Everything is ok on the apps page that immediately opens. If I click the desktop app icon, it goes to the desktop and the entire page starts to flash,...
Windows 8 desktop flashing in General Support
Hi please can one of you talented people help me. I have a Windows 8 HP laptop and the screen is just flashing. I have looked through other users posts and tried a few things but nothing is fixing the issue. I can't get past the flashing screen to enter Control panel, Safe boot or anything as the...
Hi after I restarted my computer I noticed desktop.in files, is this normal, and can I delete them?
I just replaced the HD in my laptop with an SSD and did a clean install of Windows 8.1. I have a very strange issue now. When I first try to run a program the icons disappear from the desktop for a second then reappear but the program doesn't run. The second time a do this the program starts right...
EDIT: this problem is solved! Hi everybody, i have a strange issue with my Laptop, as the title says, i have a very strange issue when switching from the start menu to the desktop, you can see this issue in action on youtube and further explanation. Please watch the video and please help me solve...
Hi! My first post on these boards, hoping to get some help with an issue I've run into... I got a laptop (Lenovo T420) which I've been running Windows 7 on for a while - everything has been working fine. Today I formatted my hard drive and did a clean install of Windows 8 Pro - working fine...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook