Windows 8 and 8.1 Forums


DPC latency spikes from USBPORT.sys

  1. #11


    Posts : 6
    Windows 8


    Quote Originally Posted by fireberd View Post
    I doubt that the card reader is causing any problems. You could disable it in the Device Manager, though.

    Wi-Fi will cause DPC latency and even dropouts in Sonar. Disable the Wi-Fi and see what happens.
    Tried already at no avail. Disabled everything in the "Network Adapters" section, just to be sure . I mentioned the card reader because I had read somewhere that in rare cases it could be the culprit.

      My System SpecsSystem Spec

  2. #12


    Have you looked at THIS thread?
      My System SpecsSystem Spec

  3. #13


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Ok, I deal with what you're saying all the time on MOTUnation.com for people. (Haven't been there as of late though, for no particular reason. Just slackin' I suppose.)

    For USB interfaces, here are the rules:

    Update bios to newest.

    Update chipset drivers to newest.

    Update USB 3.0 driver to newest. (If there is a specific firmware update for 3.0 itself (not bios) - then install too.)

    Use a 2.0 port (since your device is likely to be 2.0 anyway) and not 3.0.

    If you are using any hub, remove the hub and don't use it.

    Update drivers to all other USB devices.

    Plug the unit into one that is away from others. For example, if a front port is available and everything else uses rear ports - then use front port.

    I would also uninstall any 3rd party antivirus and use Defender instead.

    In worst case scenario, I can look over your system:

    Blue Screen of Death (BSOD) Posting Instructions

    Out of curioisity, which interface and DAW?
      My System SpecsSystem Spec

  4. #14


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Quote Originally Posted by fireberd View Post
    In addition to the Legacy mode, for many, most audio devices that use Firewire use either the DICE or DICE II Firewire chipset in the device. The DICE/DICE II want to see a T.I. chipset at the PC end for proper operation.
    Yes, this is the touted advice, direct from hardware makers themselves, but I've found it to be of little interest. All sorts of chipsets have worked well and I always advise that too. Seems to be "alright, alright" for all I've helped. But I suppose, if in dire straits, then adhere to it. Good!
      My System SpecsSystem Spec

  5. #15


    Posts : 6
    Windows 8


    Quote Originally Posted by fireberd View Post
    Have you looked at THIS thread?
    Yep. Looked at that and at many other sites. It's like a curse... I had this problem with my previous laptop as well, it turned out to be the ACPI. This time it is the USBPORT.sys I guess, or at least that's what I thought by looking at the .etl file and LatencyMon.

    By the way, I've posted the .etl and .txt summary on the first page, just in case.



    Quote Originally Posted by MasterChief View Post
    Ok, I deal with what you're saying all the time on MOTUnation.com for people. (Haven't been there as of late though, for no particular reason. Just slackin' I suppose.)

    For USB interfaces, here are the rules:

    Update bios to newest.

    Update chipset drivers to newest.

    Update USB 3.0 driver to newest.

    Use a 2.0 port (since your device is likely to be 2.0 anyway) and not 3.0.

    If you are using any hub, remove the hub and don't use it.

    Update drivers to all other USB devices.

    Plug the unit into one that is away from others. For example, if a front port is available and everything else uses rear ports - then use front port.

    I would also uninstall any 3rd party antivirus and use Defender instead.

    In worst case scenario, I can look over your system:

    Blue Screen of Death (BSOD) Posting Instructions

    Out of curioisity, which interface and DAW?
    According to my "samsung update center" every driver is updated. I recovered the laptop to factory settings and installed every driver just the other day (2 or 3 days ago).

    So : bios updated, chipset updated, not using hubs, tried disabling everything Universal serial bus controllers in device manager, not using any antivirus. I have even tried tune-up utilities since I was desperate, needless to say it didn't solve much.

    The only thing connected right now apart from the power supply is my mouse. Even if I disconnect it the problem still persists, notice this also happens when the audio card is not plugged.

    I'm using a Focusrite Saffire 6 USB and FL Studio.
      My System SpecsSystem Spec

  6. #16


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    Quote Originally Posted by CaptainTuna View Post
    I have even tried tune-up utilities since I was desperate, needless to say it didn't solve much.
    No, no - uninstall. Unnecessary driver.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
DPC latency spikes from USBPORT.sys
Related Threads
Solved Help analysing DPC latency spikes in Performance & Maintenance
So I am having sound crackling while gaming and so I read I can use DPC latency checker to see if there are problems there and I appear to have a problem, since there a lots of red peaks. How to I go about finding the problem? Just ask if I have to post anything else. System specs are current. ...
Hi guys, I've been reading a lot about this USBPORT.sys problem, but have tried everything and still no luck. I have the power savings set to Performance, have Cool 'N Quiet disabled and Performance Boost (Turbo Core) disabled aswell in BIOS. My main problem is that I don't get full...
PC Lag Spikes in Performance & Maintenance
Recently I have been receiving strange lag spikes in general use of my PC. These spikes occur when using Google Drive, playing games or doing whatever. A lot of the time my PC is very fast and responsive, however every minute or so everything slow down for about twenty seconds; typing becomes...
Hello there! As I was having problems regarding stuttering with Battlefield 4 since I started playing it, I decided to run DPC Latency Checker and see if it helps me find the culprits. What I found was pretty weird. The latency was at 1000us with occasional red spikes that are more present during...
Solved Lag spikes every 60 seconds in Network & Sharing
Hello, I need help with this issue that has been persisting ever since I bought this laptop. Every 60 seconds (exactly 60 seconds), my wireless internet will spike dramatically to the point of making me extremely angry like this. In any game I play where I average a 30-60 ping, the ping would...
Solved [HELP] Constant Lag Spikes in Performance & Maintenance
Hello Dan Here! - I've been dealing with this for days and still have it happening as im typing this. Ever since a few weeks back, my PC has been really messed up. When i start up my PC i sign in as normal and all is fine...untill about 10-20secs later, when my PC has CONSTANT lag spikes causing...
Usbport.sys causing mass CPU usage in Performance & Maintenance
Good day, I am experiencing technical difficulties regarding my desktop regarding this "usbport.sys" spiking issue. this occured somewhat last week. I am sure that this is usbport.sys because when I disabled USB2.0 Controller from the BIOS, the problem went away but most of my ports are...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook