Windows 8 and 8.1 Forums

SFC and DISM problems

  1. #31


    Hoping a miracle may have occurred, I ran dism and sfc again ... same results:

    Microsoft Windows [Version 6.2.9200]
    (c) 2012 Microsoft Corporation. All rights reserved.

    C:\Users\rrkurtz>d:\temp\DISMandSFC.bat

    C:\Users\rrkurtz>Dism /Online /Cleanup-Image /StartComponentCleanup

    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384

    Image Version: 6.2.9200.16384

    [==========================100.0%==========================]
    The operation completed successfully.

    C:\Users\rrkurtz>pause
    Press any key to continue . . .

    C:\Users\rrkurtz>Dism /Online /Cleanup-Image /RestoreHealth

    Deployment Image Servicing and Management tool
    Version: 6.2.9200.16384

    Image Version: 6.2.9200.16384

    [==========================100.0%==========================]

    Error: 0x800f0906

    The source files could not be downloaded.
    Use the "source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see
    Configure a Windows Repair Source.

    The DISM log file can be found at C:\windows\Logs\DISM\dism.log

    C:\Users\rrkurtz>pause
    Press any key to continue . . .

    C:\Users\rrkurtz>SFC /scannow

    Beginning system scan. This process will take some time.

    Beginning verification phase of system scan.
    Verification 100% complete.

    Windows Resource Protection found corrupt files but was unable to fix some
    of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For
    example C:\Windows\Logs\CBS\CBS.log. Note that logging is currently not
    supported in offline servicing scenarios.
    The part I really don't understand is this: The source files could not be downloaded.

    I have dism setup via gpedit to use Windows Update, so why can't dism download needed files from there?
    How can I point dism to a location where the necessary files are? I have Windows 8 Pro X64 iso but pointing to it doesn't seem to help either. I don't have a Windows 8 Pro X64 .wim file though and it sounds like that is what dism wants.

      My System SpecsSystem Spec

  2. #32


    ectech, I went back to post #17 in this thread and did the copy:

    copy /y "C:\ESD\Windows\sources\luainstall.dll" "C:\Windows\System32\luainstall.dll"

    and it completed successfully. I compared the luainstall.dll in both locations before the copy and they were different, and after the copy and they were identical.

    Rerunnin: Dism /Online /Cleanup-Image /RestoreHealth
    I'll run sfc after that.
      My System SpecsSystem Spec

  3. #33


    Posts : 1,360
    Windows 8.1 Enterprise


    My apologies Rich I forgot all about this. I will take a good look tomorrow after I get back home.
      My System SpecsSystem Spec

  4. #34


    No problem. I'll be here when you get time.

    sfc failed again. I see 4 files it had problems with:

    luainstall.dll Referenced by Package_10_for_KB2871777~31bf3856ad364e35~amd64~~6.2.1.3.cat and .mum
    MpAsDesc.dll Referenced by Package_24_for_KB2856373~31bf3856ad364e35~amd64~~6.2.1.2.cat and .mum
    fastprox.dll Referenced by Package_9_for_KB2871777~31bf3856ad364e35~amd64~~6.2.1.3.cat and .mum
    smipi.dll Referenced by Package_10_for_KB2871777~31bf3856ad364e35~amd64~~6.2.1.3.cat and .mum

    I don't know how to go about fixing them though.
      My System SpecsSystem Spec

  5. #35


    Posts : 1,360
    Windows 8.1 Enterprise


    Check to see if you have KB2871777 installed on your machine. If you do uninstall it, restart, download a fresh copy.

    Link: Download Update for Windows 8 for x64-based Systems (KB2871777) from Official Microsoft Download Center
      My System SpecsSystem Spec

  6. #36


    Posts : 146
    Windows 8 Pro


    This works on a desktop if you have an ISO or dvd......definitely worth a try and you still retain Windows 8.1.
    Start laptop then click on "Restart holding down Shift Key".
    This will bring up a "Choose An Option Screen"
    Click on "Troubleshoot"...then "Advanced Options"....then "System Image Recovery".
    This will not affect any thing other than System Image.
    Hope this helps.
      My System SpecsSystem Spec

  7. #37


    Ectech, I do have KB2871777 but I can't uninstall it. When I right click on it, I don't get any context menu options. I wonder if I can just re-install it? I'll give that a try.

    Dencal, what is the purpose of doing this? I have 8.0, not 8,1.

    Edit: Nope, could not reinstall KB2871777, detected it was already installed and exited.
      My System SpecsSystem Spec

  8. #38


    Posts : 1,360
    Windows 8.1 Enterprise


    I found the solution, update to Windows 8.1

    This problem has already been resolved by updates included in the Windows 8.1 Package.
      My System SpecsSystem Spec

  9. #39


    Posts : 146
    Windows 8 Pro


    Quote Originally Posted by Ztruker View Post

    Dencal, what is the purpose of doing this? I have 8.0, not 8,
    This will solve your sfc /scannow problem....this works in both 8.0 and 8.1....any faults found in sfc ....System Image will rectify.
      My System SpecsSystem Spec

  10. #40


    No thanks. Don't want to update to 8.1 since it's not really an update but a new install. I'll wait for 8.2 and see what it has to offer, may update then.

    Thanks for all your help.
      My System SpecsSystem Spec

Page 4 of 7 FirstFirst ... 23456 ... LastLast
SFC and DISM problems
Related Threads
Solved SFC or DISM - Which to Run First? in Performance & Maintenance
Since I have seen "both" recommended as a first step, and since the correct sequence is not defined anywhere that I can find, here's my take on this subject: Run sfc /scannow (first) This will attempt to fix any corruption from the resident component store (Note: internet access is not...
DISM Question in Performance & Maintenance
I have had a problem with DISM in that it runs, but can't find the source files on my pc. Can anyone tell me if I can copy Windows SXS file from another computer and put my extenal disk as a source? Both pc's are running Windows 8.1 Update 1 and are x64. The only difference in the 2 pc's is...
Windows 8.1 64 bit running Windows Update continuously. Suddenly I had significant problem getting a two year old laptop started. Repair, recovery, reset, restore did not work. Recovery would not recognize the recovery disk! None of the reset points would work! After trying boot options 1, 4 and...
DISM and SFC error, 0x800f0906 in Performance & Maintenance
Heya all! Recently I got problems when running SFC or DISM to repair my system. As far as I know it concerns the shortcuts in the folder Administrative Tools, there I changed under Properties the Run option to Maximised Windows and since then SFC and DISM have shown this error that the services...
dism error 87 in General Support
every time I get this "DISM.exe / Image: F: \ 7work \ WIM / Add-Package / Package Path: F: \ 7work \ LP \ lp.cab" try to run I get an error situation. error 87? What should I do now. I have so many looked on google but I'm desperate. thanks (google translate)
Running DISM Tool in Performance & Maintenance
When running the DISM Tool to scan and restore any missing or corrupted files on the drive, is it imperative to be connected to the internet, or can it be run offline? I have run the Tool both online and offline and both the methods has worked giving the same result. But the Command implies an...
Hi guys, recent errors have come up in my system and I'm not sure what the cause is or the best way of fixing it. If I run sfc /scannow I get either this: http://img855.imageshack.us/img855/5637/6du9.png Or after restarting/shutting down some other message telling me a system repair is...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook