Windows 8 and 8.1 Forums


Defrag issues when system idle ...

  1. #1

    Defrag issues when system idle ...


    After approx 4 minutes of my system being idle, the program 'service host disk defragmenter' starts running using high CPU. I've disabled automatic defragmenting but it hasn't made any difference. As long as the machine is busy it doesn't run ... but after 4 minutes idle, it kicks in. This is a real pain as it means I'm having difficulty watching anything on Netflix, IPlayer etc. Clearly my system is not recognising that there is activity at these times, therefore the defragmenting begins and the CPU usage sky rockets and my fan goes nuts trying to cope. I'm at a complete loss re how to fix this issue. Could someone offer some help? Thanks.

      My System SpecsSystem Spec

  2. #2


    Southern California
    Posts : 788
    Windows 8.1 Pro with Media Center x64


    Hey mate, welcome to the forums

    Just to make sure, did you check to see that optimization is Off, as in the picture:

    Click image for larger version

    You don't have any installed defrag programs or optimizers, right?

    Here is a good additional tutorial on how to potentially make windows 8 run a little faster, you might enjoy having a look: Optimize Performance of Windows 8
      My System SpecsSystem Spec

  3. #3


    Posts : 1,883
    7601.18247.x86fre.win7sp1


    I don't have an 8 install to check, and haven't used 8 in a few weeks, so memory is a little fuzzy, but there might be some entry in Task Scheduler to look at and disable. Worth a check in any case.

    taskschd.msc

    Also not sure what you've disabled, but if you didn't mean services.msc, check there too. For 8: Optimize Drives service. (defragsvc)
      My System SpecsSystem Spec

  4. #4


    I'm having this same exact problem also. I've made sure to disable my optimizations. I use my laptop for music production and this spike in CPU usage causes my sound card to crash exactly when the "service host disk defragmenter" starts to run. I checked the services and disabled the "optimize drives." Looked at the task scheduler and didn't really see anything. Any ideas? Thanks!
      My System SpecsSystem Spec

  5. #5


    Southern California
    Posts : 788
    Windows 8.1 Pro with Media Center x64


    Quote Originally Posted by redbeardedone View Post
    I'm having this same exact problem also. I've made sure to disable my optimizations. I use my laptop for music production and this spike in CPU usage causes my sound card to crash exactly when the "service host disk defragmenter" starts to run. I checked the services and disabled the "optimize drives." Looked at the task scheduler and didn't really see anything. Any ideas? Thanks!
    By 'disable my optimizations', what do you mean? Do you mean the disk drive optimization was turned off (as in my picture posted above)?

    Did you follow my link at the bottom of my post above?
    Last edited by DustSailor; 12 Dec 2014 at 00:04. Reason: clarity
      My System SpecsSystem Spec

  6. #6


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    Quote Originally Posted by redbeardedone View Post
    Looked at the task scheduler and didn't really see anything. Any ideas? Thanks!
    Task Scheduler Library\Microsoft\Windows\Defrag
      My System SpecsSystem Spec

Defrag issues when system idle ...
Related Threads
Solved Help needed Defrag Dual Boot System in Performance & Maintenance
I have a dual boot system Windows 8.1 that came preinstalled and Windows 7 where I do all my work. Lately my computer started to slow down slightly especially at start. I checked System Configuration startup and found only five applications that is needed like sound...... I thought I would buy a...
This is like a ghost in a machine issue of mine now, and it's been for a few months, killing me at this point as I can't figure out what it is... what happens is that while I'm working on the computer, everything is fine. As soon as I step away for a few minutes, and the PC is idle, the audio...
Despite having disabled the defrag it still tries to 'optimize the drive' when the system is idle. Is there any way to override this? It's only started doing this again after I installed the huge rollup update earlier this week.
I have a 1.8tb external hard drive that I defragged using Advance System Care's Smart Defrag 3. I re-analyzed the drive to check the result as it completed overnight. The disc is still 21% fragmented. I also analyzed the drive using CCleaner's Defraggler, which shows 27% fragmentation. I ran...
Defrag System Reserved Partition Revisited in Performance & Maintenance
Sure it's only a 100 MB partition. Sure Everybody and their mother says don't fool with it. I'm not interested in the opinions of everyone and their mother, I want my 79 % system reserved partition derfragged. Help me make this happen. Be part of history and eradicate the very silly notion that...
SSD defrag issues in Windows 8.1 RTM in Performance & Maintenance
I upgraded to 8.1 and everything is fine, apart from these 2 issues: - 1. If I start a maintenance run manually via Control Panel, Windows will start defragging my SSD, which obviously shouldn't happen. You can see it happening here, even though the drive is correctly identified as an SSD: - ...
System Hangs when idle in General Support
So i recently built my own desktop and it runs fine except from a problem where the computer will hang if left idle for any length of time. I have windows 8 pro installed and again it seems to work fine except from this problem. The PC is still running has full power and can hear the fans going...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook