Windows 8 and 8.1 Forums


Can't open my mounted vhdx backup image

  1. #1


    Posts : 2
    Windows 8 Pro x64

    Can't open my mounted vhdx backup image


    I can't open the mounted image in the disk management console. This is my backup image from my previous win 8.1 pro x64 system. Its stored on a external hdd w/ bit locker protection. My problem is I want to recover some files from the previous image but when I mount the vdhx image, the "Open", when i right click on the partition on the disk mgt console, is greyed out. I also noticed that no drive letter is assigned after i mounted it. I have tried converting it to vhd using Hyper-V, then opening it in win 7 but the same thing happens. It gets mounted, but no letter assigned and still can not be opened in the explorer. Are there 3rd-party tools to open & mount vhdx files?

      My System SpecsSystem Spec

  2. #2


    Germany/Florida
    Posts : 4,514
    Vista and Win7


    That is indeed strange. Normally it would assign a drive letter and show up in Computer. All I can suggest is a possible alternate solution to get at your files. Have a look at the link. If you have restore points from the timeframe that those files still existed, this is an easy method to retrieve the files.

    ShadowExplorer - Recover Lost Files and Folders - Windows 7 Help Forums
      My System SpecsSystem Spec

  3. #3


    Posts : 2
    Windows 8 Pro x64


    Thanks but actually the case is I reformatted my system that is why I can't recover those files through restore points. my last hope was through this back up image. I guess my last resort would be to restore the backup image recover my files then restore this new system I have.
      My System SpecsSystem Spec

  4. #4


    Posts : 1
    win 8.1


    Had exact same problem. When attaching vhdx file in disk management it is not automatically assigned drive letter, therefor it does not appear in "my computer" as a separate drive to explore.
    Once you attach the vhdx file simply right click on that attached drive in disk management and elect "Change Drive Letter and Paths..." option and assign a drive letter. I used the default drive letter windows suggested and whammo! it works.
      My System SpecsSystem Spec

Can't open my mounted vhdx backup image
Related Threads
Hello, I was thinking about purchasing this program for my computers. This will allow me to restore each one from the external hdd that I used for windows 7 correct? Thanks! Acronis True Image 2015 For PC & Mac - 3 Devices - Newegg.com
It's been around since Vista, but I rarely ever hear anything - either good or bad - about it.
0xc000000e at restoring backup image at mbr in BSOD Crashes and Debugging
0xc000000e at restoring backup image at mbr. I backuped windows 8.1 x64 of MBR with 'Terabyte image for windows', and restored this backup image on gpt hard disk drive. At booting screen, I got this error message. 0xc000000e Please let me know how to resolve this error or inform me...
I use O&O Disk Image 7.2 to make images of my Windows 8 drive. Occasionally I need to mount an image to access folders and files. One folder I can't access is my user folder. I get the message 'You don't currently have permission to access this folder.' I took ownership of the folder but that...
Solved Error creating backup image in Performance & Maintenance
Since a week is it impossible to make a Win7 Backup Image (Control Panel). This is the feature that got removed in 8.1 but now (on 8) I'm still using it in case I need to restore the OS. The message shows this: 26238 "Not enough disk space" but I have 360GB free on one disk and 150GB on...
System Image Backup Problem in Performance & Maintenance
In Windows 7 you have the ability to do a system image I know how to do this and it works great on all my machines, in fact one of my hd failed and i used the image to put it all back so I know it works. I have upgraded 2 window 7 computers to windows 8 Pro and the system image works fine I...
Solved System Image backup in General Support
Has anyone found a system image backup utility in Windows 8 Customer Preview ? I have found some discussion of this that says go to Control Panel / Restore. I can not find that option. I do see Control Panel / Recovery which has system Refresh and Reset options.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook