Windows 8 and 8.1 Forums

WMI repository broken (already tried several solutions)

  1. #1

    Posts : 7
    Windows 8.1

    WMI repository broken (already tried several solutions)

    I've done a clean install of Windows 8 and updated to 8.1 via the store update on a new SSD about 1 month ago.
    Everything was fine back then. Regarding hardware or settings I've changed nothing since then.

    Since about 1 week I've got some serious problems related to WMI:

    • event id 28
      At each system boot an error of event id 28 gets logged which points at the WMI core components.
      Seems that the WMI-Installation is somehow broken.
    • event id 3
      As a consequence of the WMI error windows security center reports this error. Seems that windows needs WMI to check for running antivirus programs which fails. This leads to a notification in the taskbar which tells me that there is no active antivirus software (which is wrong).
    • event id 43
      Furthermore I get this warning which says something like "there was an connecting to namespace "\\.\root\cimv2" through WMI: 0x80041001" (translated from german)

    As a sidenote: the WMI service is running at startup and can be turned off or restarted with no problem.

    I concluded that the problem must be WMI, so I tried to fix it:

    • WMI repository (refresh via commands)
      winmgmt /resetrepository or winmgmt /salvagerepository didn't help
    • WMI repository (manual refresh)
      Renaming the repository folder and let windows recreate it after reboot didn't help either

      I also found a batch script that should recreate the repository which also didn't work.
      (some for-commands for every dll, mof and some other file type; can't remember exactly)
    • System restore
      Gives me an "unknown error at system recovery" 0x80070057.
      Although I don't think this would help much, as I've only got 1 restore point thats about 2 days old.
      As I've said earlier I didn't change anything os wise.
    • System refresh
      Prompts me to insert an installation medium which I don't had in the first place (as stated earlier I bought windows 8 on disk and updated to 8.1 via the store update, so I don't have any disks for 8.1).

      So I downloaded the ISO for 8.1 by exploiting the windows 8 downloader glitch (cancel download for 8 and then start downloading 8.1).

      Even with this ISO I still could not refresh my system - got an error which I don't know anymore.
    • WMI connection
      I also found a command which opens a tool where you can try to connect to the WMI repository.
      This gives me the same error as stated under "event id 43" (see above).

    Are there any other ways to repair WMI or the repository?
    I don't want to do a complete system refresh again since the system otherwise runs perfectly fine...

    Would appreciate every tip you could give me!
    If you need some more details or system logs just ask for it and I'll provide them!

    PS: Please bear with me that I can't give you full details on every solution I tried... I did this at 3 o clock in the morning and forgot to take notes / make screenshots of everything.

      My System SpecsSystem Spec

  2. #2

    Posts : 7
    Windows 8.1

    No one that can help me here?

    Edit: Just ran sfc /scannow and attached the cbs.log to this post.

    Edit2: I also did a reboot and exported the eventlogs that show the errors I get.
    WMI repository broken (already tried several solutions) Attached Files
    Last edited by Gishan; 18 Dec 2013 at 13:59.
      My System SpecsSystem Spec

WMI repository broken (already tried several solutions)
Related Threads
BackUp Solutions/Suggestions for 8TB of Data? in Performance & Maintenance
Greetings! Today while casually browsing the iNet my Music suddenly stopped playing and while at first I believed it to be an issue with Xbox Music I later discovered that the Culprit was actually one of my RAID0 HDD's which decided to go AWOL - The Intel RST Manager confirmed this by showing...
Hi Guys! In few days I will have my new computer with Windows 8.1, and I wonder what solution would be the best for easy backing up and restoring of system drive in the new machine. For last 5 years I've been using Acronis to creat an image of entire partition c: , with windows and all my...
CMS Backup Solutions in Software and Apps
Is there anyone using the CMS Backup Ultimate ver 14? I have been reading about it and would like to hear from anyone who has used it. Thanks!
I've used Keytweak in the past with Win7. Now I find it's not working as expected in Win8. Changes are not being adopted by the registry and at reboot the app does not reflect the key remap change. Is there a trick to get this utility behaving as expected? Change / Modify / Reassign the Keys or...
Hi everyone, I see that many Cedar Trail devices (Intel Atom N2600 with Intel GMA 3600/Power SGX545) run Windows 8 quite well due to its dual core architecture. However, when using the Intel's currently supplied GMA 3600 driver (dated 1/2012), all Windows 8 Metro apps crash when attempting to...
Hello! I'm searching for solutions for reducing the winsxs stuff. First, I'm not a layman so I don't need an umpteenth reiteration, that I shouldn't delete anything because they're backups and variants of dlls. I simply don't need it. I pretty much use the same programs for the most part and I...
Source A Guy
Eight Forums Android App Eight Forums IOS App Follow us on Facebook