Windows 8 and 8.1 Forums

Windows 8.1 vs. 8.0: mouse accelaration

  1. #1

    Posts : 8
    Win 7 Pro 32, soon Win 8.1 Pro 64

    Windows 8.1 vs. 8.0: mouse acceleration


    I am currently testing a Samsung ATIV book 9 (not plus) with Win 8.0 pre-installed.

    I have checked cursor acceleration (precision) in the mouse settings and moved the lever all to the right.

    The Samsung has a Elantech Touchpad and I also checked all additional settings of the driver software.

    The problem is that the touchpad is definitely too slow for my taste. I am also testing an ASUS Zenbook UX301LA and touchpad acceleration speed for navigation across the whole screen was much better and this did not come at the cost of bad precision in short-range navigation, or in mid-range).

    Both laptops are FHD (1080p) and set to 100% desktop zoom. I have them here for testing purpose prior to making a purchase.

    My question: I have read that Windows 8.1 has better support for high res displays (consider 1800p!). This naturally also comes with new requirements in mouse pointer handling: 1800p displays (sic, not 1080) require, when set to 100%, very well programmed acceleration to allow for both short range precision and swiping across the whole screen. Also, I read that Win 8.1 has had its mouse pointer handling changed, cf. reports on gamers experiencing lag etc.

    ==> Could anyone please tell if upgrading to 8.1 provided them with an extended range of mouse acceleration/speed? I.e. if you had you settings set to max in in windows 8.0, was is now possible to set it to a quicker, respectively was it automatically set to a quicker speed that you noticed, and set it back (or kept the new speed as an improvement)? Thanks a lot for your feedback!!!

    PS. On the asus, the pointer would go about twice as far with a short, quick swipe, than on the Samsung.
    Last edited by DarkBlue; 17 Nov 2013 at 20:06.

      My System SpecsSystem Spec

Windows 8.1 vs. 8.0: mouse accelaration
Related Threads
Hey folks, This is very frustrating and I am at my wits end. I have tried 5 different wireless mice and two wireless keyboards with nearly no success. Hardware tried: HP Wireless mouse. Returned to store. Logitech mk320 mouse/keyboard combo Logitech m325 (two different ones) iHome...
Solved Windows 8.1 mouse options? in General Support
Hey where is the mouse option for acceleration? I can't seem to find it even in the mouse settings ...... I only see: How fast I want it to scroll down, primal mouse button and 1 other thing regarding the scroll thing.
Hey.. Recently i updated my bios to v0105 after that i booted up my pc and there was no mouse pointer i tried to drag or click nothing happened.So i restarted my pc then to nothing happend.Next time i shutted down my pc and unplugged the main wire and plugged it back in and then started...
Qosmio X505-Q887 Tried installing latest synaptics drivers but got a failed to install error. Win8 drivers not listed on toshiba site. Tried via Toshiba service centre but couldn't download this to install. Got message "Oops! Google Chrome could not connect to" Pad...
Solved Windows 8 Mouse Lag in Drivers & Hardware
On a new custom built desktop, running Windows 8, I am having the annoying problem with the mouse lagging or sticking on the screen. It can do this differently at times, depending on what program I am in. For instance, on the desktop a few moments ago, just running the mouse pointer back and...
Hi Guys, so I've just finished a HTPC build and using HippoRemote on the iPhone to control Windows. Works great if I have a mouse plugged in but as soon as I remove the mouse the cursor hides itself. I can still click on things etc but it makes it pretty hard to do without the cursor being visible....
Windows 8 and Magic Mouse... in Drivers & Hardware
Hello everybody. I've just installed it through Boot Camp on my iMac. Of course I could not install Boot Camp drivers ( as a matter of fact no need to install drivers for resolution - iMac 27 - or network or sound ), and that brought me a problem. The scroll is not working because I'm using a Magic...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook