Windows 8 and 8.1 Forums

SpeedStep Not Working

  1. #1

    Posts : 57
    Windows 7 Professional

    SpeedStep Not Working

    I have an Intel i5 and ASUS motherboard (on a desktop machine), and with Windows 8 I was able to implement Intel SpeedStep to slow the CPU when it didn't need to run at full speed. Updating to Windows 8.1 broke this, but I somehow got it to work again. Not it's not working again, and the only change to the configuration was a Windows Update for Intel Management Engine Interface that occurred on 10/25. SpeedStep is enabled in the BiOS.

    Can anyone offer any advice? I'm not shy about registry hacks if necessary.

      My System SpecsSystem Spec

  2. #2

    Have you tried uninstalling speedstep and then re-installing it? Sometimes that will do the trick.
      My System SpecsSystem Spec

  3. #3

    Posts : 57
    Windows 7 Professional

    Quote Originally Posted by bassfisher6522 View Post
    Have you tried uninstalling speedstep and then re-installing it? Sometimes that will do the trick.
    Intel SpeedStep isn't a program, it's enabled in the bios and Windows is supposed to use it automatically.
    Last edited by PJL; 26 Oct 2013 at 14:57.
      My System SpecsSystem Spec

  4. #4

    Posts : 835
    Win 8.1 Pro

    Well, SpeedStep has never been perfect and never will be
    There are too many variables that can cause speedstep to never down the Core Voltage and Frequency
    In some cases it can actually work backwards and never step back up when needed.
    Personally, if there is ever a chance for me to turn it off I do. I set sleep modes instead.

    Enhanced Intel SpeedStep® Technology - How To Document

    Please Note:

    To verify that Enhanced Intel SpeedStep Technology is enabled, do the following:

    Close all applications and ensure that Windows OS is in idle mode.
    (Note from me: Rarely will this ever be achievable, Too many things running in the background to achieve this level)

    Press Ctrl + Alt + Delete and select the "Performance" tab.

    Verify that CPU usage is 0. (This is almost impossible on todays PC's, see above)

    Right click "My Computer" and select, "Properties."

    Under the "General" tab, examine the installed processor and speed.

    If Enhanced Intel SpeedStep Technology is enabled, two processor speeds will be listed.
    The first speed listed is the specified speed of the processor.
    The second speed is the current operating speed.
    The second speed will be less then the first speed. (See Figure 1.)
    This indicates that Enhanced Intel SpeedStep Technology
    has effectively lowered the processor voltage and core frequency, which can (depending on system usage and design)
    result in decreased average power consumption and decreased average heat production.

    If Enhanced Intel SpeedStep Technology is off, then both processor speeds will be equal. (See Figure 2.)
    If the processor is not in idle mode, Enhanced Intel SpeedStep Technology can be enabled and both processors speeds can be equal. If this happens, try steps 1-3 again.
      My System SpecsSystem Spec

  5. #5

    Posts : 57
    Windows 7 Professional

    After extensive testing I've determined that something changed from Windows 8 to Windows 8.1 with how SpeedStep is handled. Monitors show that the CPU speed does change, but only if Intel Virtualization Technology is disabled. This was not the case with Windows 8. I run Hyper-V for a virtual XP machine (I have two very old programs that won't run with anything but XP). With Windows 8 and the virtualization active the CPU monitors would correctly show step down to half-clock speed under low CPU load. With Windows 8.1 this does not happen. Further, power options for CPU clock settings are not available in Windows 8.1 with virtualization on but they were in Windows 8. I'm not sure what's going on, of if this is a real change in Windows 8.1.
      My System SpecsSystem Spec

  6. #6

    Posts : 57
    Windows 7 Professional

    Yet another update. Further testing using a CPU monitoring function that does not use Windows services (like CPU-Z) confirms that SpeedStep (and Turbo mode) in fact work with Hyper-V active. Windows apparently does not report the physical CPU clock but rather the virtualized processor speed for the host when Hyper-V is active which is why it doesn't appear that the CPU steps down or up.
      My System SpecsSystem Spec

  7. #7

    Posts : 52
    Windows 8.1 Pro Pack x64

    I've been getting this error after updating to Windows 8.1. Does this error pose a threat of some kind to my system? Will disabling SpeedStep eliminate it? If so, how would I do that?

    Log Name:      System
    Source:        Microsoft-Windows-Kernel-Processor-Power
    Date:          2014-03-21 1:59:36 AM
    Event ID:      37
    Task Category: (7)
    Level:         Warning
    User:          SYSTEM
    Computer:      Raj-PC
    The speed of processor 7 in group 0 is being limited by system firmware. The processor has been in this reduced performance state for 71 seconds since the last report.
    Event Xml:
    <Event xmlns="">
        <Provider Name="Microsoft-Windows-Kernel-Processor-Power" Guid="{0F67E49F-FE51-4E9F-B490-6F2948CC6027}" />
        <TimeCreated SystemTime="2014-03-21T05:59:36.703326400Z" />
        <Correlation />
        <Execution ProcessID="4" ThreadID="9072" />
        <Security UserID="S-1-5-18" />
        <Data Name="Group">0</Data>
        <Data Name="Number">7</Data>
        <Data Name="CapDurationInSeconds">71</Data>
        <Data Name="PpcChanges">1</Data>
        <Data Name="TpcChanges">0</Data>
        <Data Name="PccChanges">0</Data>
      My System SpecsSystem Spec

SpeedStep Not Working
Related Threads
My usb gamepad stopped working suddenly and never work again in this computer I tried the gamepad in other computers and it works good, but not in this computer, I tried to reinstall windows several times, install all kind of drivers, I tried to configure it in different ways and its not working...
Hi! I am repeatedly getting the error "Internet Explorer not working" / Windows checking for solution/Last browsing closed unexpectedly , then Restore Session. I went to google to find a fix for this error .I'm being told to Press Window + W key then type in Troubleshooting in the Search box , then...
Hi, I updated my Synapse software (Razer) and suddenly my BlackWidow mechanical keyboard isn't working fully. The F keys are not working correctly the F10 mutes and F11/12 turn the volume up and down (almost like it's a laptop keyboard). The Windows key has swapped with the ALT key and also the...
This is my first time posting this but im trying to find a solution to this problem, EVERY key except for the c can be capitalized using the shift key, when i press the shift and the c i get ..nothing..but if i use caps lock and c i get C ...i tried using ctrl and c and that works perfectly...
Solved W E I not working in Performance & Maintenance
Most people with W8 try out the wei just for fun as it doe's not mean a lot. I personally can confess to three on W7 and three on W8. One of the W8 pc's has just been reloaded from 32 bit to 64 bit and it won't complete wei. It says"COULD NOT MEASURE VIDEO PLAYBACK PERFORMANCE". Any one have a...
Wi-Fi not working in Network & Sharing
Hey, awhile ago I downloaded the Consumer Preview but then I decided I didn't really like it and wanted to go back to windows 7. But I didn't know about it overwriting Windows 7. I also didn't know about .iso? and dual-booting. So I restored my system to factory settings, but Windows 8 didn't go...
Working/Non Working software for Windows Developer Preview AKA Windows 8 Please use color code above when posting your list Paint.NET Google Earth Divx Plus Web Player (free) Logitech webcam software - model, Logitech HD Pro Webcam C910
Eight Forums Android App Eight Forums IOS App Follow us on Facebook