Windows 8 and 8.1 Forums


Very high RAM use at a brand new laptop?

  1. #1

    Very high RAM use at a brand new laptop?


    Hello, I recently got a new laptop, first thing I did was delete most bloatware and such, and there really isn't a whole lot remaining other then OS and drivers. However, when checking the taskmanager recently I noticed it using 80-90% of the RAM. While being under very little use. Only thing was chrome taking up 200-300MB.

    The laptop is a samsung 9 series, with 8 GB RAM, so I can't see how it should be having so much troubles when just running on lowgear. I checked and it does have 8GB RAM registered, and the performance view shows it using 6GB of 7,6. Considering there are plenty of windows 8s laptops with just 4GB I couldn't imagine this being normal?

    Adding together what is shown by the task manager wont get me higher then 1 GB at most as far as RAM usage, is there any tool giving better information about what is all used? Could it be the quickboot system of samsung that eats up some or some sort of reserve that will let go of some RAM if other programs demand it?

      My System SpecsSystem Spec

  2. #2


    Windows has moved to a model where it caches whatever it can, since RAM is so much faster than looking anything up on a hard drive (even an SSD drive). So, it's important to make sure that you are looking at Available RAM versus free RAM.

    I've got a Windows 8 box sitting here with nothing on it. It has 16GB of RAM and shows right now that 2.1GB is in use and 13.5GB is available.
      My System SpecsSystem Spec

  3. #3


    Germany/Florida
    Posts : 4,514
    Vista and Win7


    Post a picture of the Resource Manager > Memory tab (the colored chart). Then we have a better view of what's going on.
      My System SpecsSystem Spec

  4. #4


    Click image for larger version a bit less use now, but still high, only thing going here is a single tabbed chrome on this forum and netflix in the background.
      My System SpecsSystem Spec

  5. #5


    Germany/Florida
    Posts : 4,514
    Vista and Win7


    Try RAMMap from Mark Russinovich. Maybe that gives you some clues.
      My System SpecsSystem Spec

  6. #6


    that tools shows me having a lot of active ram in something called "nonpaged pool", would that be the caches mentioned earlier? And in that case, it's to consider available

    more accurately nonpaged pool has 4,5GB of active ram memory. being quite a large chunk of the current 5,7GB of active ram
      My System SpecsSystem Spec

  7. #7


    Germany/Florida
    Posts : 4,514
    Vista and Win7


    1. Mapped File = Cached

    2. Did you look into the 'Processes' button

    3. Here is some reading if you want to understand 'pools':

    Memory Management - Understanding Pool Resources - Ask the Performance Team - Site Home - TechNet Blogs
    Memory Pools (Windows)
      My System SpecsSystem Spec

  8. #8


    ok, bit of an update, searching around a bit I found that some claimed this was caused by drivers leaking memory, downloaded some windows driver tools and a program called poolmon that was able to probably identify the leak as something that went under the tag ECMC, when running that through the driver folder it gave a result stating the tag belonged to "intmsd.sys".
    which again google identify as Intellimemory storage filter driver, so should I try update or install this somehow? bit unsure what to do less? even if the results are correct, little idea what I was doing but just following a guide step by step. the ECMC showed 4.802.969.600 Bytes which must be unusually high? and the connection to intmsd,sys was found with findstr /s ECMC *.sys
      My System SpecsSystem Spec

  9. #9


    Germany/Florida
    Posts : 4,514
    Vista and Win7


    I guess you have to update this driver. I am not very familiar with this particular driver and leaks in general.
      My System SpecsSystem Spec

  10. #10


    I simply deleted it, now my RAM is running at 16%. I would however like if someone could tell me what it was, considering I have now removed it. If that may bite me in the ass later on. This was installed with the laptop, and I could find it on samsungs SW update tool, however no updates available which made me delete it instead.
    I also sent a mail in to samsung to ask about it, just in case they were unaware of it and more have similar problem, which to me didn't sound too unlikely considering I had it on a new laptop right out of the box.

    Anyway, thanks for the help
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Very high RAM use at a brand new laptop?
Related Threads
Hey guys, So i just got this laptop today. So there's nothing on it that could have been causing this problem. The laptop is very slow and / or unresponsive (as in one or the other or both) when connected to the internet, There is absolutely no reason for this as i have completely disabled...
Adding SSD to a brand new Asus laptop in Installation & Setup
I've bought a new laptop , it's an Asus K95 series. (K95VB) Since it has an open slot for a second drive i also bought an SSD for it , a Crucial M500 240Gb if that should matter. So the laptop comes preinstalled with windows 8. There are no discs (recovery,repair,...) with the system. (a...
BSOD on a brand new 2 day old Lenovo laptop in BSOD Crashes and Debugging
I just got the Lenovo Z710 laptop with I7-4700, 8gb, 1TB, Intel HD Graphics 4600 and Nvidia GEForce 745 graphics card. We had only loaded CCleaner, Auslogics Disk Defrag, AVG anti-virus & World of Warcraft (WoW) gaming. As soon as my son logged onto WoW, he got a black screen & then the BSOD. I am...
Hi, I recently bought a brand new laptop (MSI GT70 2OD, Dragon Editon 2) in August and even since I bought it I kept on getting lots of BSOD. First I thought I was a driver issue so uninstall my Nvidia Drivers (Back to stock drivers). Then few days after I got another one, so I decided to refresh...
Hey, My parents just bought me a gaming laptop ASUS off amazon but i ended up putting on EBay for sell. After the buyer received, he claimed that this was already used due to there was a update done on it like 5 months ago but I've never used it ever since i got it from my parents as a gift....
Solved Brand new laptop problems in Windows Updates & Activation
I'm setting up an MSI CR70 for one of my staff and am having nothing but problems. I removed some of the bloatware and installed avast! plus a couple other programs and it seemed to be working. She had to ship the laptop back to me because it had become unresponsive and she couldn't use it. I...
As mentioned above..... Vote..... :)
Eight Forums Android App Eight Forums IOS App Follow us on Facebook