Windows 8 and 8.1 Forums


“Run as administrator” prevents aplications from autostart

  1. #1


    Posts : 12
    Windows 8

    “Run as administrator” prevents aplications from autostart


    I've been running a problem that some of the applications from the startup menu doesn't actually start upon login. After looking at the list of the applications I've noticed that actually only the exe files that I've set in properties to "Run as administrator" (in compatibility tab) doesn't run (and also a .cmd file).

    How do I run those apps (set to 'run as administrator') during startup?

      My System SpecsSystem Spec

  2. #2


    Posts : 22,576
    64-bit Windows 10


    Hello Wojtek, and welcome to Eight Forums.

    Windows will not run elevated programs at startup by default.

    A workaround for this would be to use the tutorial below to create an elevated task shortcut.

    Elevated Program Shortcut without UAC Prompt - Create - Windows 7 Forums

    Afterwards, use the tutorial below to create another task to run the shortcut above.

    Task - Create to Run a Program at Startup and Log On - Windows 7 Forums

    Hope this helps,
    Shawn
      My System SpecsSystem Spec

  3. #3


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    I made a picture that might help.
    I found the info using Google--
    Although you may have solved the issue by now.--


    Run as Administrator - in Windows 8

    Click image for larger version
      My System SpecsSystem Spec

  4. #4


    Posts : 12
    Windows 8


    Thanks. I went and removed the problem alltogether - disabled UAC...

    meh, after all my tweaking to make the experience with 8 at least bearable I think that I ended up with basically windows 7 :/

    EDIT: @medab1 - but this will prevent aplication from autostarting! that's the whole point...
      My System SpecsSystem Spec

  5. #5


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    Quote Originally Posted by wojtek View Post
    Thanks. I went and removed the problem alltogether - disabled UAC...

    meh, after all my tweaking to make the experience with 8 at least bearable I think that I ended up with basically windows 7 :/

    EDIT: @medab1 - but this will prevent aplication from autostarting! that's the whole point...

    I was confused.
    I read your message poorly.
    Sorry.
      My System SpecsSystem Spec

  6. #6


    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center


    I'm glad you solved it.
    This picture is a shot my REVO UNINSTALLER program with options to add things to startup.
    MAYBE you would like try it out.
    I like it.
    I forget what I paid for it but it was cheap.--

    Click image for larger version
      My System SpecsSystem Spec

“Run as administrator” prevents aplications from autostart
Related Threads
Everything worked fine on Windows 7, but not anymore. Both Google Drive and Dropbox are set to autostart with Windows, but they don't. I even tried adding Drive shortcut to startup folder, but to no avail. I can start Drive manually though. And Dropbox has another issue - I couldn't install...
While checking some autostart apps, that I could possibly deactivate, I found something strange. There are multiple entries for "Conhost" and "icacls.exe". Moreover Adobe CEF helper also appears 3 times. On my other machine, Conhost and icalcs.exe don't appear at all and Adobe CEF helper only...
I want the VPN to automatically start up when I start the machine. How would I achieve that using the Windows VPN functionality?
UEFI prevents rootkits? in System Security
I've been reading that EUFI booting prevents rootkits, is this true?
How to disable unwanted autostart delay? in Performance & Maintenance
Hi! Windows 8 waits several seconds before it start my programs that are set to auto start. I would like to make win8 behave like older variant. This new feature is of no value to me and annoying. The apps start too late and steal focus, or I just watch and wait stupidly for the apps to start...
I recently installed a new GTX660 Ti GPU, but I am now experiencing a major issue with the sleep function. Whilst I am able to sleep the PC, when I try to wake it, nothing really happens. I hear the "device disconnected" sound and then nothing for at least 2 minutes before it automatically...
When some aplications hang i try to terminate them via task manager but that doesnt work, when trying to terminate process of that app, the result is same: the process could not be terminated Reason: Access is denied. I m logged in as administrator, using just windows defender as protection. I...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook