Windows 8 and 8.1 Forums

Big problems with the file explorer, mouse and keyboard

  1. #1

    Big problems with the file explorer, mouse and keyboard

    I purchased HP ENVY h8-1440eo Core i7-3770/8 GB/1 TB + 16 GB SSD/GeForce GT 640 3 GB/Windows 8 64-bit while ago. I've been using it for about month now. First everything was working fine, but now some weird problems have appeared.

    First of all the wireless mouse and keyboard keeps laggin and cutting the connection quite regularly. It feels like the wireless connection cuts at a very fast pace but I'm almost certain that the problem isn't in the wireless conection. For example when you move the mouse from left to right the movement stops couple of times during the movement for a very short time. This problem appears regularly but not all the time. I have opened task manager when this happens to see if this is memory or CPU related, but it isn't. Memory usage has never been over 40% and CPU usage has never been over 10% when this happens.

    Other even weirder problem is that the programs can't access file explorer. For example when I try to use Save file as.. or Save image as.. function via Firefox or Chrome browsers file explorer doesn't open at all. Nothing happens. If I try to load a file attachment from webmail via those browsers it asks do I want save the file or open it. When I choose save nothing happens. If I use IE10 everything works fine. Today I noticed that the file explorer doesn't work right anymore even when I use Notepad++ as seen in the Image below (I can't navigate backwards since it doesn't show anything in the left side of the explorer).

    I have never had problems like these in the previous versions of Windows. Is this OS related or is there something wrong in the hardware (for example 16 GB SSD cache)?

    Thanks for your help.
    Click image for larger version

      My System SpecsSystem Spec

  2. #2

    Harrisonburg, Va.
    Posts : 10,488
    Windows 8.1.1 Pro with Media Center
      My System SpecsSystem Spec

Big problems with the file explorer, mouse and keyboard
Related Threads
USB Keyboard & Mouse in Drivers & Hardware
I have a HP Pavillion 500 Deasktop, running windows 8.1. The other day when shutting down the computer it stated it needed an upgrade and to restart. So i let it upgrade and restart. When it came back on I had no keyboard or mouse. I couldn't get anywhere. I tried safe mode and still couldn't use...
I'm using an external mouse and keyboard (both new and working) for my Windows 8 laptop. Both are having problem with the laptop - very few keyboard keys work and when left clicking an icon, it opens the properties. Right clicking does nothing. I've checked the mouse properties and the left should...
PS2 keyboard/mouse in Drivers & Hardware's a weird one. On my son's PC, which used to be my old PC, has a problem with the PS2 keyboard and mouse staying on after the PC is turned off...the lights are still on. The only thing different when I had it was the keyboard and muse and the OS....I use a logitech G510 and a Razer...
Mouse click with keyboard key? in Software and Apps
Is there any program that lets me use a custom keyboard key to left mouse click? I tried a Autohotkey script, but many programs don't accept it, so it's very limited...
Mouse and keyboard not working??? in Drivers & Hardware
I have installed Windows 8 Release Preview for a month. I installed this OS normally without any problem during installation and I used hardwares normally. I But now, my mouse, keyboard and all USB plugins don't work. When I start my computer, the light on my keyboard turn on and then off when...
How's it going everyone, I just installed Windows 8.1 and so far so good except for one minor but extremely annoying bug. Any file explorer window I open is not properly aligning with the mouse pointer. So if I want to click on lets say the C drive, I can't hover the mouse pointer directly...
Solved Mouse/Keyboard Center in Drivers & Hardware
A reinstall of Keyboard Center solved this issue. Clicking MOUSE in Control Panel returns an error that "a network resource is not available." Only after two cancellations of that message does the mouse config box appear. Latest .1777 version is installed. Why does it seek this "resource"...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook