Windows 8 and 8.1 Forums


SSD, sluggish performance on Chrome and other applications

  1. #1

    SSD, sluggish performance on Chrome and other applications


    Hello community,

    I've been experiencing some weird issues with my newly installed OCZ Vertex 4. Specifically, I've been having poor performance on a whole compared to the previous month when I had bought it. Photoshop loads fairly quick (7-9 seconds?) from the shortcut but I remember it taking just under 3. VLC Media Player can take upwards of 10 seconds as well to open.

    As for Chrome, I have an issue where browsing in the same tab.. browsing is fairly speedy. (Near instant) but opening a new tab, or clicking a link which in turn opens a new tab takes forever to load and then load a new page. Once the tab is loaded, speeding then begins to be fairly speedy again. (Using the address-bar directly even in the same tab causes slow downs as well.) I figure this is something to do Windows 8 or my SSD. Even opening the downloads or history page is slow! Or settings. Chrome variants such as Comodo and SRWare Iron share this problem. Internet Explorer and Firefox do not suffer from this problem. (Although, Firefox seems to lock up QUITE often... 5 times in 30 minutes on first install)

    I've attached some benchmarks, files, and specs. All help is appreciated very much!

    WEI:

    Before
    Click image for larger version

    After
    Click image for larger version

    ATTO Score
    Click image for larger version

    SPECCY Notes
    Click image for larger version
    Click image for larger version

      My System SpecsSystem Spec

  2. #2


    Have you got the latest Firmware update v1.5 for Vertex 4 installed? What security program you have installed? If you have any third party security program installed, disable it and see whether it helps.
      My System SpecsSystem Spec

  3. #3


    Yes, 1.5 is installed. Performance on Chrome is excellent upon reboot but within 20 minutes of using the OS it begins to degrade. I also notice Photoshop and the like taking a lot longer to load.
      My System SpecsSystem Spec

  4. #4


    You could also try uninstalling recent Windows Updates one by one starting from the latest and see whether it fixes the problem.
      My System SpecsSystem Spec

  5. #5


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    I see 63C CPU temp.

    Is that idle? Then it's a bit high if you ask me.
    Check to see if that goes even higher when the slowdown happens.
      My System SpecsSystem Spec

  6. #6


    No, that is under load (a game was running) The tempature with a few applications open, Skype and Chrome sits at about 40 degrees Celsius. I'm currently experiencing the slowdown even at 40. (Average for this boot is 39)
      My System SpecsSystem Spec

  7. #7


    Unfortunately Vertex 4 slows down when you use 50% of disk space, could you try transferring your important files to an external HDD and reduce the used space to a minimum and check the performance.
    EDIT:
    For additional information have a look at this link:Technical Discussion VTX4 performance and storage modes...1 thread discussion only, you want info you will only find it here
      My System SpecsSystem Spec

  8. #8


    I have done so and freed up to 70% of my drive.. but as you can see in my orginal post even when I had about 50% free my numbers were still around 400 MB/s. This shouldn't account for 15 seconds to load a page in chrome or for some apps to lag to load.
      My System SpecsSystem Spec

  9. #9


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Quote Originally Posted by HeliosLeviatis View Post
    This shouldn't account for 15 seconds to load a page in chrome or for some apps to lag to load.
    It's something with the browser then...

    Have you got many addons/extensions running in Chrome?
      My System SpecsSystem Spec

  10. #10


    Posts : 354
    Windows Server 2012 Standard w/Hyper-V


    The OP stated clearly that neither Internet Explorer nor Firefox suffered from the same problems as Chrome. Doesn't this indicate that the problem is most likely with Chrome?
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
SSD, sluggish performance on Chrome and other applications
Related Threads
Hello, Am I the only one suffering from a very laggy Google Chrome? I have a new Windows 8.1 laptop and Chrome is very laggy, every time I type a sentence to search at the search bar, it shows the first 1-2 letters of the sentence, and then the whole PC gets stuck for a few seconds before the...
Windows 8.1 Acting Sluggish.... in Performance & Maintenance
Hello, my HP Pavilion g7 running Win 8.1 has been running sluggish. When surfing the net with Chrome I occasionally get a 'Not Responding' message in the title bar. Antivirus scans are clean as are Malware scans. Any tips in getting it peppy again?
Applications and multi-core performance in Performance & Maintenance
Hi, I have a video encoding app that seems to only use 1 core. When it's doing a run the cpu on my pc rises to about 13% (I have 8 logical cores). When I view the load across the cpus I see 1 core is maxed out and the others are yawning in the background. Can someone explain how applications...
feels very sluggish - is this right? in Performance & Maintenance
Hey all, I am slowly getting used to the new Windows 8 layout and in particular the whole user experience however the overall speed of my system feels very sluggish when perhaps it shouldn't ? Is there anyway to see what is causing my PC to act to slowly and highlight ways that it can be...
Sluggish start up and multitasking in Performance & Maintenance
Wondering if others note that Windows 8 is slower to fully load than is Windows 7 . It reaches the Desktop in approx the same time, but isn't usable for another 10' or so. I7 2600K CPU on a ASUS P8P67le MB Multitasking also is very sluggish, when compared with its predecessor O/S. When...
Hi all I've tried out BOTH versions of W8 on a fairly modest laptop with 4 GB RAM -- my observations are that W8 x-86 beats W7 hands down for boot speed and performance but W8 x-64 (the 64 bit version) still isn't quite ready for prime time yet --it seems a lot more sluggish and a few programs...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook