Windows 8 and 8.1 Forums


W8 keeps deleting thumbnail cache (changed folder permission)

  1. #61


    Posts : 12
    Windows 8.1 Pro x64


    ....... thanks for you advice windows8thumba.

    I see what you mean, but I'll do a manual backup of my "Explorer" folder to a different location anyway, now daily and in the future at least every couple of days - Just to be kinda safe and don't lost all the thumbs in case of a cache clear-out by the system like you mentioned.

    Let's see how it goes - As I said, I'll let you guys know in a couple of weeks .......

      My System SpecsSystem Spec

  2. #62


    Posts : 32
    Arch x64 / Windows 8.1 Pro x64


    @tommygun, the scripts are .bat's, because that's the script file type extension. The "blue screen" happens as explorer.exe is killed to allow restoring the thumbnails.

    @windows8thumba, that's actually pretty clever. I never even thought of that.
      My System SpecsSystem Spec

  3. #63


    Posts : 12
    Windows 8.1 Pro x64


    @Det87

    ....... I do understand why the blue screen appears.

    The main reason why I converted to exe was because I wanted to assign an icon to the files which I did and just by chance while at startup the Explorer kill process takes place I will stay on Metro and not been taken to Desktop automatically which means I wont even notice the blue screen.

    Anyway, this is not important, but I did run into a complete cache cleanup yesterday - Not at startup, it took place about two hours after the last reboot - Luckily I had the Explorer - Copy backup otherwise all would be gone again.

    I'll try to get to the grounds of it later and let you know, because for now I have to run .......
      My System SpecsSystem Spec

  4. #64


    Posts : 32
    Arch x64 / Windows 8.1 Pro x64


    Yes, it happens from time to time. That's the exact reason the automation won't work, if you don't verify the cache is intact before shutting down.

    Also, basically you could also assing the icons by just creating shortcuts, but if they really work as ".exe"s (which is unbelievable), then who cares.
    Last edited by Det87; 14 Aug 2014 at 07:49.
      My System SpecsSystem Spec

  5. #65


    Posts : 3
    Windows 8.1 Update 1


    Quote Originally Posted by Det87 View Post
    Well, the lines beginning with "::" are simply comments, and the actual work is below them, but I take it you're not using Windows 8?

    If you are, then, for some reason, you don't have the Explorer folder in %LocalAppData%\Microsoft\Windows\ (C:\Users\BR4DDERS\AppData\Local\Microsoft\Windows\).
    I am using Windows 8.1 Update 1, but my System Drive is "E:", I already tried changing it them to "E" though but It didn't work.

    This is what I changed them to:

    Backup Thumbnails.bat
    Code:
    @echo off
    
    :: Go to E:\Users\BR4DDERS\AppData\Local\Microsoft\Windows\
    cd %LocalAppData%\Microsoft\Windows\
    
    :: Remove previous "Explorer - Copy" backup (2>nul: ignore directory doesn't exist)
    rd "Explorer - Copy" /s/q 2>nul
    
    :: Create new one (echo d: copy a directory)
    echo d | xcopy Explorer "Explorer - Copy" /y/s/q
    Restore Thumbnails.bat
    Code:
    @echo off
    
    :: Go to E:\Users\BR4DDERS\AppData\Local\Microsoft\Windows\
    cd %LocalAppData%\Microsoft\Windows\
    
    :: Kill explorer.exe
    taskkill /im explorer.exe /f
    
    :: Copy thumbnails from "Explorer - Copy"
    xcopy "Explorer - Copy\thumbcache_*.*" "Explorer\" /q/y
    
    :: Restart explorer.exe with "start" to auto-close CMD window
    start explorer.exe
    I am a total noob at scripts though.

    When I type "E:\Users\BR4DDERS\AppData\Local\Microsoft\Windows" or "%LocalAppData%\Microsoft\Windows" in the "Explorer" bar it goes to the right folder.



    When I type the commands in CMD it works:

    Last edited by BR4DDERS; 14 Aug 2014 at 17:31. Reason: Added picture
      My System SpecsSystem Spec

  6. #66


    Posts : 12
    Windows 8.1 Pro x64


    @Det87

    ....... check this one out if you like to try: Bat to Exe Converter

    It comes as a Zip file with the option of an installer or portable x32/x64 installation.

    Very handy piece of freeware if needed in certain situations.

    Until now I can't figure out why my thumbnail cache was cleared in the middle of a boot session without a restart or shutdown.

    Still very happy with your scripts though .......
      My System SpecsSystem Spec

  7. #67


    Posts : 32
    Arch x64 / Windows 8.1 Pro x64


    @BR4DDERS, no, but the lines beginning with the double colon (::) don't actually do anything - they're just descriptions for the actual work being done below them. E.g.:

    Code:
    :: taskkill /im explorer.exe /f (this line is ignored)
    echo Hello.
    ..will only print that "Hello." (echo is the command to say something).

    You could try changing the following lines:

    Code:
    cd %LocalAppData%\Microsoft\Windows\
    to:

    Code:
    cd /d E:\Users\BR4DDERS\AppData\Local\Microsoft\Windows\
    @tommygun, like I said, Windows automates the cleanup process in its own secret way that's apparently even outside the Task Scheduler. The thumbnails are then moved to the ThumbCacheToDelete lsubfolder, waiting to be deleted in the next boot. This can happen at the middle of the day, but it will always lbe done at the next boot.

    And this is perfectly "normal" behavior. My scripts won't prevent that, they'll just allow you to restore the thumbnails.
    Last edited by Det87; 16 Aug 2014 at 03:24.
      My System SpecsSystem Spec

  8. #68


    Posts : 3
    Windows 8.1 Update 1


    @Det87 - Cheers, it works now.
      My System SpecsSystem Spec

  9. #69


    Posts : 1,720
    Windows 8.1 Pro
      My System SpecsSystem Spec

  10. #70


    Posts : 6
    Windows 8.1


    I'm on Windows 8.1. I don't know if this has been mentioned before, but when I use the Restore .bat file, it'll only work like once. After that, if I use it after the system has screwed my thumbnails again, it kills and refreshes explorer, and but the thumbnails will still have to manually reload all over again until I restart. And when I copy and paste the script into Command, I get this:
    Click image for larger version

    Is there any fix to allow me to restore as many times as needed until I need to shut down?
      My System SpecsSystem Spec

Page 7 of 12 FirstFirst ... 56789 ... LastLast
W8 keeps deleting thumbnail cache (changed folder permission)
Related Threads
http://i.imgur.com/MdOgMNO.png I'm at a complete loss as to why a random image has associated itself to my Windows folder. What is more frustrating is that there seems to be no way to remove it, as the Windows folder's properties menu doesn't have a "Customize" tab that allows you to reset a...
I've recently changed to Windows 8.1 and honestly don't think it's as bad as people make out, clearly not as user friendly as Windows 7, but hey ho. Anyway, I have a number of folders on my hard-drives and I want to put a preview pic on them so I know exactly what they are, however when I Right...
Hi guys, I've had this problem since I got a new laptop with Windows 8.1: The thumbnail cache resets. I've tried the methods outlined here: Prevent Windows 8 File Explorer From Deleting Image Thumbnail Cache Thumbnail Cache Automatic Deletion Problem in Windows - AskVG Basically I disabled...
hey i gat the same proble can you sove this plzzz. 41736 i have create a new user acc. in my pc and use it and then i shut down my pc. next day my old acc. was lost and all data within it was not opening. 41738 here mayur is my old user name account while mayur_000 is anew one.
Dear Brains, On the other Windows PCs I've used, there has always been a small thumbnail at the bottom of the window showing details of the item/photo selected, but with Window 8, this is missing. Some details are there, but they are not easy to take in at a glance and I really miss the...
Every time I turn my laptop on, I lose my thumbnails and it has to reload them. Seriously frustrating. I've tried today to go through a few refreshes/reinstalls, and I'll occasionally be able to keep them, but then I just start losing them again. I've seen a few mentions of this - another thread...
My xp laptop had recently crash, but the my hard drive is still intact. I have a windows 8 computer now and I am trying to transfer the memory, but when I try to access the xp hard drive from windows 8 computer, I cannot access it. I get the "You don't currently have permission to access this...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook