Windows 8 and 8.1 Forums

No Wifi

  1. #1


    Posts : 3
    Windows 8

    No Wifi


    Hey,
    I just installed Windows 8 and now my Wifi isn't working, it worked fine on the Developer Preview.
    There are no networks found and in PC settings it says "No wireless devices are available".
    Same thing when I use a Linksys USB wifi receiver.

    I have a Broadcom BCM943227HM4L in my Acer Aspire 8951G.

    I can connect to the internet using a LAN cable.

    This is what ipconfig says
    1. C:\WINDOWS\system32>ipconfig /all
    2. --------------------
    3. Windows IP Configuration
    4. Host Name . . . . . . . . . . . . : vixez-PC
    5. Primary Dns Suffix . . . . . . . :
    6. Node Type . . . . . . . . . . . . : Hybrid
    7. IP Routing Enabled. . . . . . . . : No
    8. WINS Proxy Enabled. . . . . . . . : No
    9. DNS Suffix Search List. . . . . . : telenet.be
    10. --------------------
    11. Ethernet adapter Bluetooth Network Connection:
    12. Media State . . . . . . . . . . . : Media disconnected
    13. Connection-specific DNS Suffix . :
    14. Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
    15. Physical Address. . . . . . . . . : EC-55-F9-DB-EF-F8
    16. DHCP Enabled. . . . . . . . . . . : Yes
    17. Autoconfiguration Enabled . . . . : Yes
    18. --------------------
    19. Wireless LAN adapter Wi-Fi:
    20. Media State . . . . . . . . . . . : Media disconnected
    21. Connection-specific DNS Suffix . :
    22. Description . . . . . . . . . . . : Broadcom 802.11n Network Adapter
    23. Physical Address. . . . . . . . . : C0-F8-DA-40-39-F0
    24. DHCP Enabled. . . . . . . . . . . : Yes
    25. Autoconfiguration Enabled . . . . : Yes
    26. --------------------
    27. Ethernet adapter Local Area Connection:
    28. Connection-specific DNS Suffix . : telenet.be
    29. Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    30. Physical Address. . . . . . . . . : E8-9A-8F-0F-58-9B
    31. DHCP Enabled. . . . . . . . . . . : Yes
    32. Autoconfiguration Enabled . . . . : Yes
    33. Link-local IPv6 Address . . . . . : fe80::6094:d936:8730:a000%12(Preferred)
    34. IPv4 Address. . . . . . . . . . . : 192.168.0.195(Preferred)
    35. Subnet Mask . . . . . . . . . . . : 255.255.255.0
    36. Lease Obtained. . . . . . . . . . : Saturday 11 August 2012 19:42:25
    37. Lease Expires . . . . . . . . . . : Monday 13 August 2012 9:29:19
    38. Default Gateway . . . . . . . . . : 192.168.0.1
    39. DHCP Server . . . . . . . . . . . : 192.168.0.1
    40. DHCPv6 IAID . . . . . . . . . . . : 241232745
    41. DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-6B-82-EC-E8-9A-8F-0F-58-9B
    42. DNS Servers . . . . . . . . . . . : 192.168.0.1
    43. NetBIOS over Tcpip. . . . . . . . : Enabled
    44. --------------------
    45. Tunnel adapter Local Area Connection* 19:
    46. Media State . . . . . . . . . . . : Media disconnected
    47. Connection-specific DNS Suffix . :
    48. Description . . . . . . . . . . . : Microsoft 6to4 Adapter
    49. Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    50. DHCP Enabled. . . . . . . . . . . : No
    51. Autoconfiguration Enabled . . . . : Yes
    52. --------------------
    53. Tunnel adapter isatap.telenet.be:
    54. Media State . . . . . . . . . . . : Media disconnected
    55. Connection-specific DNS Suffix . : telenet.be
    56. Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    57. Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    58. DHCP Enabled. . . . . . . . . . . : No
    59. Autoconfiguration Enabled . . . . : Yes
    60. --------------------
    61. Tunnel adapter Reusable ISATAP Interface {8073204E-66A5-421A-9B48-791A3BD3926D}:
    62. Media State . . . . . . . . . . . : Media disconnected
    63. Connection-specific DNS Suffix . :
    64. Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    65. Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    66. DHCP Enabled. . . . . . . . . . . : No
    67. Autoconfiguration Enabled . . . . : Yes
    68. Tunnel adapter Local Area Connection* 15:
    69. Connection-specific DNS Suffix . :
    70. Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
    71. Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    72. DHCP Enabled. . . . . . . . . . . : No
    73. Autoconfiguration Enabled . . . . : Yes
    74. IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:4ad:815:ae5a:6391(Preferred)
    75. Link-local IPv6 Address . . . . . : fe80::4ad:815:ae5a:6391%16(Preferred)
    76. Default Gateway . . . . . . . . . : ::
    77. NetBIOS over Tcpip. . . . . . . . : Disabled
    The network adapter shows fine in the device manager and says it's working properly.
    (I've uninstalled Hamachi since this screenshot)
    Click image for larger version

    This is my Network Connections (with Acer Launch Manager showing it's turned on)
    Click image for larger version

    This is what troubleshooter says:
    1. Issues found Problem with wireless adapter or access point
    2. Problem with wireless adapter or access point
    3. Not fixed - Failed
    4. Reset the wireless adapter
    5. Completed
    6. -----------------------------
    7. Details about wireless connectivity diagnosis:
    8. -----------------------------
    9. Information for connection being diagnosed
    10. Interface GUID: c24f9992-bf00-4bb1-912e-71b25b5a5141
    11. Interface name: Broadcom 802.11n Network Adapter
    12. Interface type: Native WiFi
    13. Connection incident diagnosed
    14. List of visible access point(s): 0 item(s) total, 0 item(s) displayed
    15. -----------------------------
    16. Details about wireless connectivity diagnosis:
    17. -----------------------------
    18. For complete information about this session see the wireless connectivity information event.
    19. Helper Class: Auto Configuration
    20. Initialize status: Success
    21. Information for connection being diagnosed
    22. Interface GUID: c24f9992-bf00-4bb1-912e-71b25b5a5141
    23. Interface name: Broadcom 802.11n Network Adapter
    24. Interface type: Native WiFi
    25. Result of diagnosis: Problem found
    26. Root cause:
    27. This computer cannot connect to wireless networks
    28. The wireless network adapter on this computer is not working properly.
    29. Detailed root cause:
    30. This computer's wireless network adapter is not ready
    31. Repair option:
    32. Resetting your wireless network adapter
    33. This will disable and then enable the network adapter "Wi-Fi" on this computer.

      My System SpecsSystem Spec

  2. #2


    Did you download the driver from Acer or windows update? Try checking for updates under the optional part.

    If that doesn't work you can install the driver from Acer.
      My System SpecsSystem Spec

  3. #3


    Posts : 3
    Windows 8


    Quote Originally Posted by XDleader555 View Post
    Did you download the driver from Acer or windows update? Try checking for updates under the optional part.

    If that doesn't work you can install the driver from Acer.
    Yes, I've installed it several times, also in safe mode.
    I also noticed that when I toggle Airplane Mode on, it still shows the (empty) signal strength bar.

    It's like Windows isn't able to communicate on/off signals and such to the adapter.
      My System SpecsSystem Spec

  4. #4


    Bahrain
    Posts : 154
    Triple Boot: Windows Xp, Windows 7 and Windows Release Preview, Virtual Machine ( Windows 8 )


    Quote Originally Posted by vixez View Post

    This is my Network Connections (with Acer Launch Manager showing it's turned on)
    Click image for larger version
    Could You please try and enable all the wireless devices on your ware? Including Bluetooth.
      My System SpecsSystem Spec

  5. #5


    Posts : 1
    windows 8 pro

    windows 8 wifi setup and connection problem


    i m having a lenovo z580 i had installed windows 8 pro but coudnt connect to the wifi the error is ther in the image i coudnt click also on dat for enabling it pls help as soon as possible


    pls watch the attachment and reply me soon
    Attached Thumbnails Attached Thumbnails Untitled.png  
      My System SpecsSystem Spec

  6. #6


    Quote Originally Posted by vixez View Post
    Quote Originally Posted by XDleader555 View Post
    Did you download the driver from Acer or windows update? Try checking for updates under the optional part.

    If that doesn't work you can install the driver from Acer.
    Yes, I've installed it several times, also in safe mode.
    I also noticed that when I toggle Airplane Mode on, it still shows the (empty) signal strength bar.

    It's like Windows isn't able to communicate on/off signals and such to the adapter.
    You should have established the wireless connection before installing the VPN interfaces like Hamachi and Virtual box which can cause connection problems when they are enabled, disable both of those and also disable the Bluetooth devices and see if your wireless works any better, it might also help to uninstall any type of wireless connection software that is installed.

    Of course it could also be that there is no working Windows 8 driver for this Broadcom adaptor in which case installing the driver in Windows 7 compatibility mode might help.
    Windows 8 Compatibility Mode The Digital Dilemma
      My System SpecsSystem Spec

  7. #7


    Posts : 21
    Windows 7 & 8 64-bit, Mac OSX 10.8.2


    mudit72,

    Check in Device Manager that the Wireless Network Adapter is installed properly, i.e. it doesn't have a "question" or "exclamation" mark against it indicating a problem. Also, if the computer is a Laptop, check that WiFi is switched on.
      My System SpecsSystem Spec

  8. #8


    Posts : 1
    Windows 8.1

    Same problem


    I have the same problem. Been looking on the Internet for last three days.
    I seems same thing happens on all makes of laptops, new and old, regardless OS.

    I have done so far,
    1 uninstall/reinstall driver, device working properly
    2 attempted to reset ip, unsuccessful because media disconnected
    3 netsh reset
    4 registry edit for access denied (whoever researched it must have come across all of these fixes)
    5 MediaSense disable

    All boils down to Win unable to turn the radio on, falsely reporting it is on, like the pic above, where in fact it is off. Happened to me couple of times after updates, always managed to sort it out somehow. Not this time.

    So, please if I am missing a good trick, please please point me out WHAT ELSE can I do?

    Interestingly, manufacturer gives up on sorting it out.

    Thanking you in advance,
    Marivanna
      My System SpecsSystem Spec

No Wifi
Related Threads
Hi there, I have a new problem that has just cropped up today. I am no longer able to connect to public wifi or my phone's wireless hotspot. My laptop either will not connect or connect with limited access. It has connected without issue in the past and as soon as I returned home it connected to...
Hi All, Win8: I have two wifi APs in the home and I have it all set up so that one is the Internet by cell phone tether and the other is the cabled network via the router wifi. Works just fine - except. On wifi 1, Internet I have it set for "Connect automatically" which at boot up it...
Wifi keeps going off in Network & Sharing
I don't understand why Windows 8.1 is giving me so many issues. My laptop is unable to stay connected to the wifi for long and sometimes I am unable to connect. My phone and tablet stay connected to the wifi while my laptop can't. I tried all the remedies for it and yet it has issues. Is it because...
Limited wifi or no wifi in Network & Sharing
The problem started when I first got my laptop, but it was an uncommon thing. During the time I had windows 8, the wifi would turn limited maybe once or twice every few months. Then came along windows 8.1. I was excited for this, as I was still minor issues with windows 8, I thought they had fixed...
W8 Wifi in Network & Sharing
I bought my children new computers this year and they came with W8. Right now both PC's are having issues with the Wifi. It keeps cutting out on them randomly. I looked around and discovered that many others are having the same issue. Apparently it is a driver issue caused by W8. Is there a...
Hi, I have a Gateway NV52L15 notebook and I am having problems with my WiFi access. I have Windows 8. My wireless networks are not showing up. When I troubleshoot the network adapter, I get a messAge that reads that my wireless capability is turned off. When I go to the Gateway Device fast lane, my...
Win 8 Pro & Wifi in Drivers & Hardware
Hi All, Need help to connect to Wifi (wireless) Router. Im looking for a Via Rhine 111 Network controller set of Drivers. Win 8 Pro knocked out my Network controller driver (code 28). Thanks BF.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook