Windows 8 and 8.1 Forums

Erratic computer which has now lost wifi connection.

  1. #1

    Erratic computer which has now lost wifi connection.

    Hello, For a while my laptop has been quite erratic.
    Whilst I was writing a text document in open office it came up with a warning saying that a trojan was trying to download but it seemed to be my Avast saying that it was infact the virus? Everything started flashing (desktop, text document etc) then the screen went blue (no writing). I had to use 'control alt delete' to be able to close down but it was 'closing down' for about 15 mins so I had to close with the button. I got a lot of warnings (one after the other) about a trojan trying to install itself. When I shut down, the blue screen with the whirling donut takes forever. After about 15 mins I usually just have to press the power button to turn off.
    I can continue working on-line even when the desktop has disappeared. As soon as I go to the desktop I lose everything. and have to hard restart. I get the warning messages constantly.
    Then I lost the wifi connection. I am at home using my own router and all my other devices are working fine. It is picking it up, showing 5 bars and saying it is connected and I have internet access, but will not go onto any Internet. Chrome says DNS PROBE FINISHED NO INTERNET.
    When I ran troubleshooting on the wifi connection the the problem found was ' the remote device or resource won't accept the connection'. I have tried to create a new wifi connection with my router but didn't manage to do that.
    I tried to do a system restore but it failed. I also tried to restore to factory settings but after 'preparing' it said 'insert media.... Some files are missing.......your windows installation or recovery media will provide these files'.
    I am running now with the wired LAN connection.
    Is there anything you can advise please?
    If I go ahead and upgrade to W10 will everything reset again?
    Thanks in advance, Jan

      My System SpecsSystem Spec

  2. #2

    You'd be best to make a Recovery CD/Usb from another computer and start up your computer with that USB/CD and start saving your documents to an external drive/usb/cd..

    How to create USB rescue media

    But if you want to take a chance, You can try to clean the virus out using Eset and Bleeping Computers programs..

    Start with Eset Online Scanner and run it through your web browser.. Are you using Firefox by any chance? or Chrome? you can do things like "Refresh Firefox" to force out any bad things in your browser before you connect online to use these tools..

    when running the scan select These options.." posted below

    Free Virus Scan | ESET Online Scanner | ESET

    Click image for larger version

    Then head over to Bleeping computer and get these: - News, Reviews, and Technical Support

    Hitman Pro

    It's time for a Complete Format and Reinstall in my opinion.. but you'll need to copy all your documents via that usb recovery method I mentioned in the beginning..
      My System SpecsSystem Spec

  3. #3

    erratic laptop

    brooksndun, thanks for the reply. I thought it was a virus at first, but I've used MajorGeeks malware forum and run loads of scans which they have analysed and they say I am not infected. The erratic behaviour has actually stopped for about 5-6 days now. The main problem I am having is being unable to use the wifi. I can connect with the cable. The laptop picks up the wifi, shows 5 bars and says it is connected but I cannot actually go on the internet. In Chrome I get a message saying either
    DNS PROBE FINISHED NO INTERNET or "The remote device or resource won't accept the connection".

    I attempted a system restore but it wouldn't. Even tried back to factory settings, but after 'preparing' it said 'insert media.... Some files are missing.......your windows installation or recovery media will provide these files'.

    Yesterday I downloaded W10 to have it ready in case I decided to go ahead and upgrade. I thought I had chosen the option to download but install at a later date but it just carried on and installed. So, I now have W10 and still have exactly the same problem with wifi.

    Any advice you have would be much appreciated.

      My System SpecsSystem Spec

  4. #4
      My System SpecsSystem Spec

  5. #5

    also if you get net repair adapter from bleeping computer you'll be able to do this...

    Click image for larger version
      My System SpecsSystem Spec

  6. #6

    erratic laptop

    Thanks again.
    I will work through these links.
    As I can link to my router no problem with the LAN cable (or is it called Ethernet?) just not with the wifi, I am not sure these will help, as Chrome works fine with the LAN.
    Is my IP address the same regardless of using wifi or LAN cable? If so, would changing it help as it works fine on LAN.
    However, I will keep trying your suggestions.
    Last edited by Jan Scrivens; 22 Dec 2015 at 19:09. Reason: to add more information
      My System SpecsSystem Spec

  7. #7

    You defintely have something wrong though..

    so please run ESET with my settings pictured above.. and start the bleeping computer cleanup with the tools I mentioned..

    HItmanPRO.. and ESET scanner online.. atleast run those and tell me it says your computer is clean..
      My System SpecsSystem Spec

  8. #8

    Hi, I ran ESET and it found "Win32/Bundled.Toolbar:Google D potentially unsafe application" which was quarantined. The problem still existed after a reboot.
    Hitman Pro found nothing.
    Net Adapter Repair ran as instructed but no better. Zero sent or received.
    However when I ran diagnostics on the wifi connector, this time I got a different message “one or more network protocols are missing on this computer”
    Rkill said Program started at: 12/23/2015 04:02:20 AM in x64 mode.
    Windows Version: Windows 10 Home
    Checking for Windows services to stop:
    * No malware services found to stop.
    Checking for processes to terminate:
    * No malware processes found to kill.
    Checking Registry for malware related settings:
    * No issues found in the Registry.
    Resetting .EXE, .COM, & .BAT associations in the Windows Registry.
    Performing miscellaneous checks:
    * Windows Defender Disabled
    [HKLM\SOFTWARE\Microsoft\Windows Defender]
    "DisableAntiSpyware" = dword:00000001
    Checking Windows Service Integrity:
    * fcvsc [Missing Service]
    * HdAudAddService [Missing Service]
    * HyperVideo [Missing Service]
    * netvsc [Missing Service]
    * wfpcapture [Missing Service]
    * CompositeBus => \SystemRoot\System32\DriverStore\FileRepository\compositebus.inf_amd64_912dfdedc3d2f520\CompositeBus .sys [Incorrect ImagePath]
    * NgcSvc => %SystemRoot%\system32\svchost.exe -k LocalSystemNetworkRestricted [Incorrect ImagePath]
    * swenum => \SystemRoot\System32\drivers\swenum.sys [Incorrect ImagePath]
    Searching for Missing Digital Signatures:
    * No issues found.
    Checking HOSTS File:
    * HOSTS file entries found: localhost
    ::1 localhost
    Program finished at: 12/23/2015 04:06:51 AM
    Execution time: 0 hours(s), 4 minute(s), and 31 seconds(s)

    I ran MBAM and RogueKiller a couple of days ago and found nothing.

    I will carry on and do the rest.

    What I would really like to do now is roll back to 8 and do a return to factory settings but I can't because it says 'insert media.... Some files are missing.......your windows installation or recovery media will provide these files'.

    Any ideas how to get round that?

      My System SpecsSystem Spec

  9. #9

    haha nice job doing a pretty darn full malware scan and running utilities!

    have you looked through these settings?

    Click image for larger version

    What is your exact computer model again?
      My System SpecsSystem Spec

  10. #10

    Hi, sorry but not sure what you mean by looking at those settings. What should I be looking for?

    Laptop is Lenovo Flex 14-2
    OS Name Microsoft Windows 10 Home
    Version 10.0.10586 Build 10586
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name LENOVO
    System Manufacturer LENOVO
    System Model 20404
    System Type x64-based PC
    System SKU LENOVO_MT_20404_BU_idea_FM_Lenovo Flex 2-14
    Processor Intel(R) Pentium(R) 3558U @ 1.70GHz, 1701 Mhz, 2 Core(s), 2 Logical Processor(s)
    BIOS Version/Date LENOVO A0CN21WW, 21/03/2014
    SMBIOS Version 2.7
    Embedded Controller Version 1.02
    BIOS Mode UEFI
    BaseBoard Manufacturer LENOVO
    BaseBoard Model Not Available
    BaseBoard Name Base Board
    Platform Role Mobile
    Secure Boot State On
    PCR7 Configuration Binding Not Possible
    Windows Directory C:\WINDOWS
    System Directory C:\WINDOWS\system32
    Boot Device \Device\HarddiskVolume3
    Locale United Kingdom
    Hardware Abstraction Layer Version = "10.0.10586.0"
    Username Lenovo\User
    Time Zone GMT Standard Time
    Installed Physical Memory (RAM) 4.00 GB
    Total Physical Memory 3.91 GB
    Available Physical Memory 674 MB
    Total Virtual Memory 5.32 GB
    Available Virtual Memory 923 MB
    Page File Space 1.41 GB
    Page File C:\pagefile.sys
    Hyper-V - VM Monitor Mode Extensions Yes
    Hyper-V - Second Level Address Translation Extensions Yes
    Hyper-V - Virtualisation Enabled in Firmware No
    Hyper-V - Data Execution Protection Yes

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Erratic computer which has now lost wifi connection.
Related Threads
So I was on the interwebs lol and all of a sudden my laptop lost connection. I thought "really? my internet is out again" so I check my phone and the internet is completely fine. So I had to restart my pc to fix the problem. This is like the 2nd or 3rd time this has happened since I've had my pc....
What the hell is going on? I have an Lenovo P500. Running 8.1. Intel N2230 wifi card It does have a connection, every now and then it may drop but not really. On the icon in the bottom right corner if I just hover the mouse over the wifi icon it is normal, name of connection and internet...
Lost Wi-Fi connection and audio in Network & Sharing
I lost my Wi-Fi connection and audio at the same time. Just now as I tried to open Word to get information on a message I continued to receive about System 86, I discovered that my Microsoft Office Professional 2010 cannot verify the license for this application and repair attempt failed. My Dell...
A couple days ago, I was online just watching YouTube videos and all of a sudden my wifi connection just dropped. I sat around and waited for it to reconnect but it didn't. I disconnected and tried to reconnect but it told me it wasn't able to connect to the network. Nobody else has this problem....
Hello I have done some extensive testing on my Windows 8.1 Tablet downloads speeds and its extremely slow. The download speeds vary greatly from second to second; it will achieve 50kb/sec then the next second jump to 30kb/sec then back to 40kb/sec and continue this erratic behaviour. *It also...
My ISP provides service only via 802.11. I use laptop A most of the time. The captive portal for the service provider only allows one login per account at a time. The policy is intended to prevent multiple people sharing one account. It's just me, I'm the only user, but very occasionally I'd...
Hi I have recently upgraded to Windows 8.1. After the update what i have noticed is i lost wifi connectivity in the virtual machine which running Windows 2008 R2 server. I have Windows 8.1 and VMware workstation 8.0. Windows 2008 R2 is running in the Virtual machine and i was able to connect to...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook