Windows 8 and 8.1 Forums


Wifi problem, taking longer than usual but still connects

  1. #11


    Posts : 9
    Windows 8.1


    By acting weird I mean that whenever I choose a Wifi network to connect to it "takes longer than usual". And if I wait it out it says that the connection is limited. However, the Wifi icon in the system tray indicates that the connection is fine.
    When I go to a browser (I'm using chrome but I don't think it matters because I tried IE and the same problem happend) to do stuff I can still use the internet, but with occasional times where it says that it's still connected but I can't use the internet (chrome gives me a "timed out" error). Or sometimes it loads half the page and then stops.
    Everything works fine when I use an Ethernet cable.

      My System SpecsSystem Spec

  2. #12


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Have you tried downloading the latest Intel Driver? If you are using the Intel Wireless Zero config, turn it off and try Windows Wireless Zero.

    You may have to go as far as removing the driver and the hardware, then reboot and load the latest driver for the wifi adapter.
      My System SpecsSystem Spec

  3. #13


    Posts : 9
    Windows 8.1


    Can you please elaborate, broe23? How can I know which driver or config I'm using? And where can I get the Intel wireless Zero or Windows Wireless Zero from?
    Thank you.
      My System SpecsSystem Spec

  4. #14


    Just found this neat tool, inSSIDer. Gives you a good look at your wireless network.
      My System SpecsSystem Spec

  5. #15


    Posts : 9
    Windows 8.1


    Hello Ztruker,
    So I tried the program that you gave me and I kept an eye on the program for few hours and everything seems to be working fine. Everything that's supposed to be green is green and it looks consistent all the time, even when I lose connection. I think what the program displays is only how strong the signal is and nothing about the connectivity to the internet.
      My System SpecsSystem Spec

  6. #16


    Rats, I was hoping it would show you something.

    The driver for your wireless is here: Intel download center

    Click image for larger version

    It would be worth downloading and installing it to see if it makes a difference as Broe23 suggested.
      My System SpecsSystem Spec

  7. #17


    Posts : 9
    Windows 8.1


    Hello Ztruker,
    Thanks for keeping up with me through this.
    I did download and install the driver that you suggested but I'm still having the same problem. It seems like this driver is for bluetooth, not Wi-Fi.
    I'm still not sure what the source of this problem is. How can I find the source of this problem? Is it surely a driver problem? Could it be something else? And how can I eliminate the other possibilities?
      My System SpecsSystem Spec

  8. #18


    From what I can find, Intel(R) Dual Band Wireless-AC 7260 is a bluetooth device.

    Try the Intel Driver Update Utility. I've used it several times and it works pretty well, see what it tells you.
      My System SpecsSystem Spec

  9. #19


    Central IL
    Posts : 3,468
    Linux Mint 17.2


    Also the DNS Suffix is in the IPv4 properties for the adapter settings. That is what is probably screwing things up. You can also try Farbar's Tools Searching for farbar Try the 2nd & 3rd ones.

    ZTrucker actually depending on the Computer, BT works or does not work. I have one in each of our Toshiba Satellite C850D's that my wife & I use. BT does not work on ours, because Toshiba did not spec the motherboard in our laptops as being capable.

    They only need the latest Intel Dual-band 7260 full package or just driver from Intel's download section.
      My System SpecsSystem Spec

  10. #20


    I missed the DNS Suffix completely, good find.

    DNS Suffux Searchlist

    Description:

    Determines the DNS suffixes to attach to an unqualified single-label name before submission of a DNS query
    for that name.

    An unqualified single-label name contains no dots, such as "example". This is different from a fully qualified
    domain name, such as "example.microsoft.com.".

    With this setting enabled, when a user submits a query for a single-label name, such as "example", a local
    DNS client attaches a suffix, such as "microsoft.com", resulting in the query "example.microsoft.com", before
    sending the query to a DNS server.

    If you enable this setting, you can specify the DNS suffixes to attach before submission of a query for an
    unqualified single-label name. The values of the DNS suffixes in this setting may be set using comma-
    separated strings, such as "microsoft.com,serverua.microsoft.com,office.microsoft.com". One DNS suffix is
    attached for each submission of a query. If a query is unsuccessful, a new DNS suffix is added in place of the
    failed suffix, and this new query is submitted. The values are used in the order they appear in the string,
    starting with the leftmost value and preceding to the right.

    If you enable this setting, you must specify at least one suffix.

    If you disable this setting, the primary DNS suffix and network connection-specific DNS suffixes are appended
    to the unqualified queries.

    If this setting is not configured, it is not applied to any computers, and computers use their local configuration.
    Doesn't sound like that's the problem here, but who knows. Here are ways to clear it:

    DNS Suffix Search List

    about a third of the way down the page is how to clear this using regedit.

    For BT (Blue Tooth) that's all I could find for the specific device shown in ipconfig /all. Do you know of another?
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
Wifi problem, taking longer than usual but still connects
Related Threads
My Lumia 1520 has no problem connecting to the WI-FI in my home and the WI-FI at my friend's house. However, every time I'm in a public place with WI-FI, I get an error message that I can't connect. Also when I'm at a restaurant or a shop or in a mall and they have WI-FI and they give me their...
Hello, I have an HP Pavilion g7-2233cl Laptop running Windows 8. I bought it new (refurbished) about a year and a half ago. Until recently, I’ve had no problem connecting to the Internet via WiFi. But recently, although everything says I’m connected to our home WiFi and things are working...
Hi All, I have an internal wifi card and a USB one. I have two APs, Adapter Name = WifiPh, SSID = AP1 - connects to Internet via tethered phone 192.168.143.1 Adapter Name = WifiLAN SSID = AP2 - connects to local wired LAN router 192.168.3.37 On my laptop (win8.0) it shows WifiPh
i have a lenovo idea pad that will connect to wifi but says limited connection. i can use the iternet via ethernet cable with no issues. My ISP is comcast and i have one of their modems that came with wifi im guessing it doubles as a router seeing i direct connect to it with my laptop. however my...
Hi All, First off, everything is working OK once it is finally connected. I have two wifi inputs to my laptop. The internal Intel wifi-adapter is tethered to my cell phone at 2.4GHz. The other, an N600 TP-Link adapter is connected via the access point of my router which is locked to using the...
I have a tiny wireless piece from realtek that my dad had bought. This piece was working fine up until recently. I had built my own tower and put the piece in there from our old one.. All has been working up until now. Now when I turn on my new tower the wifi connects but does not work. No...
I JUST bought my laptop three weeks ago. Two weeks ago, I started having issues where I would constantly lose my Internet connection (wifi). This is not happening with any other devices in my home, including my IPad and son's laptop. Now it's not recognizing Internet connections at all. Acer wants...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook