Windows 8 and 8.1 Forums


Unable to download files using torrent.

  1. #1


    Posts : 1
    Windows 8.1

    Unable to download files using torrent.


    Hi ..
    Recently, I bought a Lenovo Notebook with Windows 8 pre installed. I have installed only basic software’s for office needs, browsers, some media players, photo editor and utorrent. I have also installed Kaspersky Internet Security, for which I have a 3 year license. The notebook performs pretty well except that the utorrent software is not downloading anything.My internet connection is provided by ABC Communications in Vancouver. I don’t think there are any issues with the connection, as I am able to browse, stream videos and download files with very good speed, but I am not able to download torrent files. I completely scanned the notebook with kaspersky and found no virus issues. Is it any problem with utorrent software or any misconfiguration issues? Can someone help me solve this problem? Thanks in advance.

      My System SpecsSystem Spec

  2. #2


    Trnava
    Posts : 683
    Win 8.1.1 Pro x64


    To check configuration, try downloading one of those torrents:

    Alternative downloads | Ubuntu
      My System SpecsSystem Spec

  3. #3


    Who is your internet provider? Some will throttle or cut you off if your are downloading and uploading a lot of stuff.
      My System SpecsSystem Spec

Unable to download files using torrent.
Related Threads
Every time I try to download, say a codec, or movie maker, or even something simple, I get the pop-up message, Your Administrator has blocked this program. Please contact your IT...". I AM the one and only user on my laptop, and I don't understand this. I have looked at other forums and posts...
Hi All, Sorry not a computer geek and only understand basics and all I know is my poor PC is having problems which even Microsoft can't fix without me paying them an arm and a leg so here goes with the first part. Nothing will download firstly from the store, then I have had various problems...
I can only run apps when NOT connected to the internet. Only pre installed apps becauce I can't download new ones. When connected to the internet I can use a browser, use email and go to the apps store. If I try to run any apps they try to open up and then I get the message "Can't log into...
Solved DISM error, unable to download source files in Performance & Maintenance
In the course of trying to fix another problem I ran the DISM checkhealth command and it said that windows image needed repaired, so I ran the restore health command and I got an error. How can I fix this error? I am attaching a screen shot of the error and Dism logs and CBS logs of both the...
I tried downloading various apps from the store, but the message I get was I can't install this app. For example, I tried to install PDF Reader 8, and I get error code 0x80070032. Does the error code reveal what the problem is? I am running Windows 8, not Windows 8.1, on the Lenovo IdeaPad.
Hi there! Just joined the forum and hope to enjoy the stay! Alright so I just got my new laptop (Samsung series 5 ultrabook) and I have been downloading some programs lately. Well recently I tried to download one and it went through a secure download wizard for some reason. I went through it...
Scenario: Seeking to implement Clean Win 8 install on new SSD Drive, have Win 8 (Purchased) Upgrade License key and receive the following error when attemtpting to Dowload Media for installation via USB via the Windows 8 setup utility . 19250 Can anyone point to a solution/workaround or...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook