Windows 8 and 8.1 Forums


Ethernet not working while wifi does on clean 8.1 install

  1. #1


    Posts : 4
    Windows 8.1 Pro

    82579V gigabit controller


    So, I recently did a fresh install of 8.1 on my custom rig. Hardware's all about 5 years old. Encountered some issues with memory (bad stick identified) and BSODs(Killer NIC seemed to be the cause). These issues are presented here: http://answers.microsoft.com/thread/...4-08727dfc2c10.

    After removing the Killer NIC, i tried using the onboard Intel 82579V gigabit controller. Here's where i encountered this new issue. windows network diagnostics tells me "Ethernet" doesn't have a valid IP configuration. the built in diagnostics for the card say "This adapter is configured to obtain an
    IP address automatically but no DHCP server
    is present on the network. Windows selected
    an IP address using Alternate Private
    IP Addressing. "

    I then bit the bullet and did another clean install. The first driver I then installed was the onboard NIC with the driver provided by Intel: https://downloadcenter.intel.com/dow...r-Windows-8-1-

    same thing. I'm nearing the end of my rope and considering just upgrading my mobo and CPU.


    recently installed 8.1 on my custom rig. Intel z68bc board with an i5 2500k and GTX570. Ran into some issues with memory (bad stick removed) and BSODs (Killer NIC identified as the culprit). most of my situation is outlined here: MULTIPLE IRP COMPLETE REQUESTS - Microsoft Community

    I bit the bullet and did another clean install. first thing installed is the latest driver for my intel 82579V gigabit controller. encountered the same issues as before.
    Last edited by Barman58; 29 Jun 2015 at 01:47.

      My System SpecsSystem Spec

  2. #2


    Posts : 123
    Win8.1


    Can you manually enter the information?
    What type of Internet service are you using (DSL, etc.) and are you connecting through a Router?

    See this Internet Options - Open in Windows 8[1]=Networking Internet
    And IP Address of Default Gateway - Find in Windows[1]=Networking Internet
      My System SpecsSystem Spec

  3. #3


    Posts : 4
    Windows 8.1 Pro


    I am on comcast xfinity and connect through the ethernet to a router which is hooked up to the modem. the ethernet works perfectly when I hook it up to my laptop. seems the issue is with my PC itself and not the ISP/cable/router/modem. reflashed the BIOS for the board since I noticed it had been updated a lot since my version with some LAN updates. Reinstalled everything and Ethernet issue remains.

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : Erik-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    Wireless LAN adapter Local Area Connection* 3:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
    Physical Address. . . . . . . . . : 74-2F-68-64-EC-C2
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Ethernet adapter Bluetooth Network Connection:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
    Physical Address. . . . . . . . . : 74-F0-6D-F3-1A-C0
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Wireless LAN adapter Wi-Fi:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 802.11bgn 1T1R Wireless Adapter
    Physical Address. . . . . . . . . : 74-2F-68-64-EC-C0
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::c4aa:d6b0:e9:52b%4(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.6(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Monday, June 29, 2015 1:49:02 AM
    Lease Expires . . . . . . . . . . : Tuesday, June 30, 2015 8:56:44 AM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 74723176
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-22-BD-13-38-60-77-60-A6-2D
    DNS Servers . . . . . . . . . . . : 192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled
    Ethernet adapter Ethernet:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
    Physical Address. . . . . . . . . : 38-60-77-60-A6-2D
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::2c7a:22c3:39eb:995f%3(Preferred)
    Autoconfiguration IPv4 Address. . : 169.254.153.95(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    DHCPv6 IAID . . . . . . . . . . . : 54026359
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-22-BD-13-38-60-77-60-A6-2D
    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Enabled
    Tunnel adapter isatap.{1B49BCAC-38D7-4709-A4B8-0976B42CB480}:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter isatap.{D35F878E-5CF0-41C5-AF85-A6663BFD96EA}:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Pinging yahoo.com [98.139.183.24] with 32 bytes of data:
    Reply from 98.139.183.24: bytes=32 time=379ms TTL=45
    Reply from 98.139.183.24: bytes=32 time=406ms TTL=45
    Reply from 98.139.183.24: bytes=32 time=236ms TTL=45
    Reply from 98.139.183.24: bytes=32 time=437ms TTL=45
    Ping statistics for 98.139.183.24:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 236ms, Maximum = 437ms, Average = 364ms
    AutoConfigProxy REG_SZ wininet.dll
    MigrateProxy REG_DWORD 0x1
    ProxyEnable REG_DWORD 0x0
    Last edited by sfkickz; 29 Jun 2015 at 11:07.
      My System SpecsSystem Spec

  4. #4


    Posts : 4
    Windows 8.1 Pro


    IPCONFIG /ALL disconnected from wifi

    Windows IP Configuration
    Host Name . . . . . . . . . . . . : Erik-PC
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    Wireless LAN adapter Local Area Connection* 3:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
    Physical Address. . . . . . . . . : 74-2F-68-64-EC-C2
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Ethernet adapter Bluetooth Network Connection:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
    Physical Address. . . . . . . . . : 74-F0-6D-F3-1A-C0
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Wireless LAN adapter Wi-Fi:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : 802.11bgn 1T1R Wireless Adapter
    Physical Address. . . . . . . . . : 74-2F-68-64-EC-C0
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Ethernet adapter Ethernet:
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
    Physical Address. . . . . . . . . : 38-60-77-60-A6-2D
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::2c7a:22c3:39eb:995f%3(Preferred)
    Autoconfiguration IPv4 Address. . : 169.254.153.95(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :
    DHCPv6 IAID . . . . . . . . . . . : 54026359
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-22-BD-13-38-60-77-60-A6-2D
    DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
    fec0:0:0:ffff::2%1
    fec0:0:0:ffff::3%1
    NetBIOS over Tcpip. . . . . . . . : Enabled
    Tunnel adapter isatap.{D35F878E-5CF0-41C5-AF85-A6663BFD96EA}:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Tunnel adapter Teredo Tunneling Pseudo-Interface:
    Media State . . . . . . . . . . . : Media disconnected
    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
    Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Ping request could not find host yahoo.com. Please check the name and try again.
    AutoConfigProxy REG_SZ wininet.dll
    MigrateProxy REG_DWORD 0x1
    ProxyEnable REG_DWORD 0x0
      My System SpecsSystem Spec

  5. #5


    Posts : 123
    Win8.1


    If you go to the internet settings can you manually enter the settings?

    IPv4 Address. . . . . . . . . . . : 192.168.1.6 (Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1

    You may want to try using Googles' DNS servers. See https://developers.google.com/speed/...dns/docs/using

    DNS IPv4: 8.8.8.8 and/or 8.8.4.4
      My System SpecsSystem Spec

  6. #6


    Posts : 4
    Windows 8.1 Pro


    ^will give that a go when I get home from work though i'm not optimistic. already tried basically that (IP was 192.168.1.13 instead) with no results.

    AS Expected, no cigar on manually entering the addresses.
    Last edited by sfkickz; 29 Jun 2015 at 20:52.
      My System SpecsSystem Spec

Ethernet not working while wifi does on clean 8.1 install
Related Threads
Hopefully this is the correct thread. I'm 69 years old, so patience, please! I was able to enjoy blistering speed, 72mbs down / 20 mbs up. My old Dell all-in-one went belly up and I had to purchase a new computer. This coincided with a problem with the BT Infinity broadband where a...
Hello, please help me, i have a problem with my Laptop that can't connect to my home wifi. Another notebook can connect no problem, handphone and ipod no problem, only this 1 laptop. I've just bought the laptop, 1 day after that i dont know why become limited, and then after i try many way from...
Ethernet and WiFi in Network & Sharing
I have a Wifi channel on my pc, and also on my router. I have a network printer attached to the router. Currently my pc is connected to router through ethernet wired connection. When I need to access the PC from a laptop by Wifi, is it best to use the PC WiFi, or the router Wifi connection,...
I have a desktop computer with windows xp, and two laptops , an asus, and an hp with windows 8.1. I can view and share the folders I set up on each pc fine if wifi is turned on. The problem is on the hp laptop if I turn wifi off on the asus. It sees the pc name, but when I click it, my shared...
Hi to all, got a problem for some time and can't find a solution... I think everybody knows about the problem with windows 8.1 at laptops with the limited ethernet (wifi), so I have the same problem on my PC and I cant find a cure... Someone, any advices? Coz of this I cant loggin to my...
Hello- I am trying to troubleshoot a network connectivity issue for my Mom & Dad's laptop. It is an HP 64-bit running Windows 8.1. Up until this morning, it was able to connect to wi-fi. My mother was on the internet with no problems. They have my-fi with AT&T and my dad's laptop and tablet...
Under Network & Sharing Center>Change adapter settings WiFi says Thats-What-She-Said! and Ethernet says the old WiFi name. Here in a minute when my dad sends me the picture Ill post it. -Trenton :) EDIT: It's a windows 8 $14.99 upgrad Gateway NE56R10U laptop
Eight Forums Android App Eight Forums IOS App Follow us on Facebook