Windows 8 and 8.1 Forums


wifi connected; ethernet card will no longer connect

  1. #31


    Try creating a Linux Live CD or flash drive to boot from. See if the Ethernet connection works there. If not then definitely hardware.

      My System SpecsSystem Spec

  2. #32


    Posts : 40
    Windows 8 x64


    Do you mind my asking one last question about this? I ran across a few places online where people said they had to go into the BIOS and disable the onboard LAN to get their PCI adapter to work. Now, I used to have a computer with a bona fide PCI LAN card I plugged into the slot; I know that isn't this, but it is still called Realtek PCIe GBIE family controller for some reason... Would this be a setting in the BIOS I ought to look at? Thank you again...
      My System SpecsSystem Spec

  3. #33


    Your LAN is on the motherboard, not an add-in card, correct?

    On my Lenovo K450 the NIC shows in Device Manager as Realtek PCIe GBE Family Controller too.
      My System SpecsSystem Spec

  4. #34


    Posts : 40
    Windows 8 x64


    Yes I believe so, but since it has PCI in the name I thought I should verify that this wouldn't be an issue... I suppose onboard lan could have gotten disabled somehow and I'd need to re-enable. There was a thing with the touchpad on my daughter's old Toshiba that kept getting disabled and we'd have to re-enable it, never did figure out why.
      My System SpecsSystem Spec

  5. #35


    Posts : 40
    Windows 8 x64


    Just an update to this...I plugged the cable into my work laptop and it fired right up and made a connection...
    I played a lot with my settings and with assigning some things manually instead of being detected automatically, and ended up with an ipconfig that looks like this between my two devices, but the ethernet card still can't get past Unidentified Network status. I tried a couple of things I found online (a PowerShell script and a registry tweak that was supposed to change unidentified networks to Private or Public) but they got me nowhere and I had to restart to avoid losing my wifi. The ipconfig looks good but this still doesn't work...the light (on the router) is literally on but nobody is home... I have not tried the Linux approach but I don't think it'll tell us anything we don't know. The stuff at the top of the ipconfig output is unfamiliar to me, I don't know if those things are right or how to set them at the host level.

    Host Name . . . . . . . . . . . . : CarolineSamsung
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Hybrid
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : domain.actdsltmp

    Ethernet adapter Ethernet:

    Connection-specific DNS Suffix . : domain.actdsltmp
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    Physical Address. . . . . . . . . : 50-B7-C3-81-2C-AA
    DHCP Enabled. . . . . . . . . . . : No
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::9478:d758:242c:2d4e%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.13(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 340834243
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-2A-E5-2B-C4-85-08-E0-C0-E5

    DNS Servers . . . . . . . . . . . : 192.168.1.1
    NetBIOS over Tcpip. . . . . . . . : Enabled

    Wireless LAN adapter Wi-Fi:

    Connection-specific DNS Suffix . : domain.actdsltmp
    Description . . . . . . . . . . . : Intel(R) Centrino(R) Advanced-N 6235
    Physical Address. . . . . . . . . : C4-85-08-E0-C0-E5
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Link-local IPv6 Address . . . . . : fe80::9585:d3c0:ae50:ecb5%3(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.3(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : Sunday, July 5, 2015 12:21:27 PM
    Lease Expires . . . . . . . . . . : Sunday, July 12, 2015 12:21:32 PM
    Default Gateway . . . . . . . . . : 192.168.1.1
    DHCP Server . . . . . . . . . . . : 192.168.1.1
    DHCPv6 IAID . . . . . . . . . . . : 63210760
    DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-2A-E5-2B-C4-85-08-E0-C0-E5
      My System SpecsSystem Spec

  6. #36


    I think a Linux Live CD is still a good test as you have yet to make the onboard NIC work under Windows.
    If it works there then it's a Windows problem. If it doesn't then it's a hardware problem and the only fix is to replace the motherboard, use a USB connected NIC or add a PCMCIA NIC.
      My System SpecsSystem Spec

  7. #37


    Posts : 40
    Windows 8 x64


    The rest of my computer is working really well and I don't want to mess it up, booting from a Linux CD won't do anything to my Windows setup, right?

    Edited to add - I came up and woke up the computer and saw that it was connected via the Ethernet cable! So it kind of woke up and worked, but in a half-assed manner; sometimes quite normal, sometimes very slow, sometimes just hanging. So weird. I ended up disabling the adapter so I could go back to the wifi which is reliable.
    Last edited by fotyc; 05 Jul 2015 at 18:18.
      My System SpecsSystem Spec

Page 4 of 4 FirstFirst ... 234
wifi connected; ethernet card will no longer connect
Related Threads
Hello everyone, I am having an issue. I attempted installed zonealarm free a few days ago when I woke up I saw that it said the installation failed. Yet still I saw zonealarm listed as a new program that was installed. I also can unable to connect to the internet. I changed the settings of...
Hopefully this is the correct thread. I'm 69 years old, so patience, please! I was able to enjoy blistering speed, 72mbs down / 20 mbs up. My old Dell all-in-one went belly up and I had to purchase a new computer. This coincided with a problem with the BT Infinity broadband where a...
Hello, please help me, i have a problem with my Laptop that can't connect to my home wifi. Another notebook can connect no problem, handphone and ipod no problem, only this 1 laptop. I've just bought the laptop, 1 day after that i dont know why become limited, and then after i try many way from...
I seem to be going round in circles trying to reconnect a working Windows 8 laptop to the WiFi after upgrading to 8.1 It refused to recognise the existing and working WiFi upon reboot after upgrade. I have twice ran the 'netsh wlan delete profile name=' command to remove the profile,...
Hello- I am trying to troubleshoot a network connectivity issue for my Mom & Dad's laptop. It is an HP 64-bit running Windows 8.1. Up until this morning, it was able to connect to wi-fi. My mother was on the internet with no problems. They have my-fi with AT&T and my dad's laptop and tablet...
hello everyone, I recently bought a dell inspiron 5520 laptop and I am able to connect to internet using my broadband ISP username and password and they had provided their own modem which works like a charm.. But as soon as I try to connect my laptop to LAN using the Ethernet cable in my room it...
i just bought a dell xt2 on ebay it came with windows 8 pro. my problem is that it goes into limited connection every ten minutes, even when i am next to the router. the error i get when i trouble shoot is the Default gateway is not avaible. let me know if you need any more info.<br>
Eight Forums Android App Eight Forums IOS App Follow us on Facebook