Windows 8 and 8.1 Forums

CMD network problem

  1. #1


    Posts : 6
    Windows 8.1

    CMD network problem


    Hi,
    I'm experiencing a problem on Windows 8. I'm trying to execute a .bat file located in a shared folder (on another pc that runs Windows Vista), and i'm receiveing errors. First, when i tried to execute the file, shows an error saying that cmd doesn't recognize the command. Then, i managed to mount that folder as a virtual drive, and that error got away. But when i try to access the program, an installation error pop up.

    The curious thing is that if i execute the program directly from this pc, there is no trouble at all. But i need to connect to the other pc, because ths program needs to be uptaded every minute (this program manage the book shop where i work at).


    Thanks!

    p.s.: Sorry for my bad english

      My System SpecsSystem Spec

  2. #2


    How are you accessing the bat file on the other PC?

    You can mount the shared folder via net use:
    Code:
    >net use /?
    The syntax of this command is:
    
    NET USE
    [devicename | *] [\\computername\sharename[\volume] [password | *]]
            [/USER:[domainname\]username]
            [/USER:[dotted domain name\]username]
            [/USER:[username@dotted domain name]
            [/SMARTCARD]
            [/SAVECRED]
            [[/DELETE] | [/PERSISTENT:{YES | NO}]]
    
    NET USE {devicename | *} [password | *] /HOME
    
    NET USE [/PERSISTENT:{YES | NO}]
    So net use z: \\Otherpcname\sharedfoldername then z:\xxxx.bat should work.

    Or run the bat file via a UNC name:

    \\Otherpcname\sharedfoldername\xxxxx.bat should work.

    If not, what are the exact, complete error you receive.
      My System SpecsSystem Spec

  3. #3


    Posts : 6
    Windows 8.1


    Thanks Ztruker for the fast answer!

    I've tried using "net use" command and via UNC, but the error persists. The program itself shown an installation error. I've also tried to run it on DosBox. There, the status window shows the following error: "Warning: file (filename) exists and failed to open in write mode. Please remove write-protection" (on several files).
      My System SpecsSystem Spec

  4. #4


    Can you post the bat file content?
      My System SpecsSystem Spec

  5. #5


    Posts : 6
    Windows 8.1


    The .bat file is: "RUN ULTRA k". The folder has a lot of .cob files, i guess it's because it's running on COBOL.
      My System SpecsSystem Spec

  6. #6


    When you run the bat file, it is running on your computer, not on the one the bat file resides on so it won't work. \ if you expect it to process the .cob file on the remote computer.

    The only way this would work is if you can remote connect (Remote Desktop??) to the remote computer.
      My System SpecsSystem Spec

  7. #7


    Posts : 6
    Windows 8.1


    Oh, ok. But if i remote connect to the other PC, i'm still able to use the program on the other PC simultaneously?
    The thing is: we have 2 PCs working simulteanously, and we need to run the program with the database at the same time.
      My System SpecsSystem Spec

  8. #8


    Why not set the batch files to run at specified intervals on both computers then? No remote action would be needed.

    Or use PsExec as shown in this article:

    How to run a program on a remote pc via command line?
      My System SpecsSystem Spec

  9. #9


    Posts : 6
    Windows 8.1


    Quote Originally Posted by Ztruker View Post
    Why not set the batch files to run at specified intervals on both computers then? No remote action would be needed.
    Sorry for my ignorance. How should i do this?
      My System SpecsSystem Spec

  10. #10


    You use the built in scheduler. Here is a short tutorial: How to Use a Task Scheduler in Windows 8
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
CMD network problem
Related Threads
network problem in Network & Sharing
I have installed windows 8.1 yesterday I have WiFi connection this WiFi connection works perfectly on my mobile but from today when I start my laptop it is not working showing unable to connect yo proxy server last it was working fine but it is not so please solve this
Windows 8.1 Pro Network problem in Network & Sharing
I have Recently Installed Windows 8.1 Pro a clean install on desktop of mine which has only one Network card. But came across a strange issue. My Network Connection icon in tray shows a yellow Exclamation mark while my system is accessible on LAN as well can access internet. Status on the icon...
Lenovo y50 Network Problem in Network & Sharing
Excuse my typing, on my phone ATM. I recently performed a downgrade on my Lenovo y50 laptop, and everything worked well in the end and Win7 Home Premium is up and running. I installed all the drivers for the laptop on Lenovo's website, but my WiFi remains unusable (tried direct line from router,...
Network problem in Network & Sharing
Hi everybody! I just installed OS 8 and I have a network problem...I don't see the LAN connection.I know you must install a driver,I installed it and LAN doesn't appear.If you don't know what I mean,I'' put some screenshots in Attachaments.Thank you! PS:I'm at a friend's home right now and sorry...
huge network problem in Network & Sharing
Ok I have this issue where i get limited network access on my wifi after a random amount of time. Could be 5 mins, 5 hours, anything. Now if i disconnect and reconnect my pc freezes every time. If i restart it connects fine. If it's not set to connect auto it connects without freeze.. I've...
Network problem in Network & Sharing
My computer keeps listing the internet connection as "limited". It does this randomly, I don't know when it will happen next. Restarting router/computer fixes it sometimes, but not all the time. Sometimes it takes about 4 restarts of the router until I get a proper connection. Trouble shooting...
Network problem! in Network & Sharing
Hello! I installed OS 8 and my network doesn't work!The "Local Area Network" doesn't appear!I did a new connection(every time when I reinstall the OS I must do a new connection,a PPOE connection),no result.What I can do?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook