Windows 8 and 8.1 Forums


Errors x0c0000035 when joining HomeGroup.

  1. #1


    Posts : 2
    Windows 8.1 64

    Errors 0xC0000035 when joining HomeGroup.


    The following Event Trace Sessions are running (under Performance, Data Collection Sets in Computer Management): “HomeGroupLog”, “P2PLog”, “IDListenLog”, “NegoLog”, “Pku2uLog”. When joining Homegroup Kernel-EventTracing records these events, ID 2: ‘Session “xxx” failed to start with the following error: 0xC0000035’, where xxx is one of the above sessions name. Also stopping and starting service HomeGroupProvider generates these errors, regardless that the sessions are running. So far I tried:
    1. Resetting IP and flushing DNS.
    2. Enabling and disabling IPv6, although HomeGroup requires IPv6.
    3. Deleting all .etl files from %windir%\Logs\HomeGroup.
    4. Adding my user id to both Performance groups.
    The system is Windows 8.1 Pro 64, motherboard is ASUS Z87, CPU Intel i5. This computer never had any hardware problems, never was exposed to any virus or malware. All drivers are as new as possible. SFC scan is clear and DISM had nothing to heal.There are no failed Windows updates. There is no software installed that could interfere with Microsoft networking, no virtual network adapters, no Open software of any kind. The purpose of enabling HomeGroup was to share pictures, documents and printer among all computers at home. Two other computers running Windows 8.1 64, not Pro, do not have those errors when joining HomeGroup. All three computers are hard wired to ISP provided router. I was not able to find any Microsoft documentation for error 0xC0000035. Other web references to this error did not gave me a working solution. Any new ideas, please?
    Last edited by MichaelJ; 30 Apr 2015 at 15:29.

      My System SpecsSystem Spec

  2. #2


    Posts : 2
    Windows 8.1 64


    Sorry for sticky words. Edit box looked good but some words were glued together...
      My System SpecsSystem Spec

Errors x0c0000035 when joining HomeGroup.
Related Threads
joining Domain in Network & Sharing
Hi, I recently Purchased Sony VAIO with pre loaded windows 8. I am a student and I want to join the college Domain to work with Matlab etc. But Windows 8 I have there is no feature to add to Domain. My dealer told me I have to upgrade my OS to Windows 8 Pro Is there a way out or I have...
Hi there. i've had this problem since i first install windows 8. i ignored it and its really bugging me now since i need to open boot screen to turn on the system. Everytime i tried to turn it on, it turns into a black screen with only my pointer showing. I've tried following existing...
Solved Joining a domain in Network & Sharing
hi, on my laptop i have my microsoft account and everything set up and i have just started online schooling but when i go to the campus every few weeks i cant use their internet because i dont have a computer on their domain thing and i want to be able to join their domain but dont want it to...
Homegroup in Network & Sharing
When setting up wireless computer, it does not see the established homegroup on a wired desktop
Hi guys, Just noticed that the "8 Forums" had started up so I thought I'd join you over here. Playing with the new system and watching with interest. Mod ... if this is run by the same group, could you possibly import my "status" flags from Win7? If not, no problem. - Max :D
Eight Forums Android App Eight Forums IOS App Follow us on Facebook